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Rose Electronics warrants the Orion™ FX to be in good working order for one year from the date of purchase 

from Rose Electronics or an authorized dealer. Should this product fail to be in good working order at any time 

during this one-year warranty period, Rose Electronics will, at its option, repair or replace the Unit as set forth 

below. Repair parts and replacement units will be either reconditioned or new. All replaced parts become the 

property of Rose Electronics. This limited warranty does not include service to repair damage to the Unit 

resulting from accident, disaster, abuse, or unauthorized modification of the Unit, including static discharge and 

power surges. 

 

Limited Warranty service may be obtained by delivering this unit during the one-year warranty period to Rose 

Electronics or an authorized repair center providing a proof of purchase date. If this Unit is delivered by mail, 

you agree to insure the Unit or assume the risk of loss or damage in transit, to prepay shipping charges to the 

warranty service location, and to use the original shipping container or its equivalent. You must call for a return 

authorization number first. Under no circumstances will a unit be accepted without a return authorization 

number. Contact an authorized repair center or Rose Electronics for further information.  

 

ALL EXPRESS AND IMPLIED WARRANTIES FOR THIS PRODUCT INCLUDING THE WARRANTIES OF 

MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, ARE LIMITED IN DURATION TO A 

PERIOD OF ONE YEAR FROM THE DATE OF PURCHASE, AND NO WARRANTIES, WHETHER EXPRESS 

OR IMPLIED, WILL APPLY AFTER THIS PERIOD. SOME STATES DO NOT ALLOW LIMITATIONS ON HOW 

LONG AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU.  

 

IF THIS PRODUCT IS NOT IN GOOD WORKING ORDER AS WARRANTED ABOVE, YOUR SOLE REMEDY 

SHALL BE REPLACEMENT OR REPAIR AS PROVIDED ABOVE. IN NO EVENT WILL ROSE 

ELECTRONICS BE LIABLE TO YOU FOR ANY DAMAGES INCLUDING ANY LOST PROFITS, LOST 

SAVINGS OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OF OR 

THE INABILITY TO USE SUCH PRODUCT, EVEN IF ROSE ELECTRONICS OR AN AUTHORIZED DEALER 

HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER 

PARTY.      

 

SOME STATES DO NOT ALLOW THE EXLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL 

DAMAGES FOR CONSUMER PRODUCTS, SO THE ABOVE MAY NOT APPLY TO YOU. THIS WARRANTY 

GIVES YOU SPECIFIC LEGAL RIGHTS AND YOU MAY ALSO HAVE OTHER RIGHTS WHICH MAY VARY 

FROM STATE TO STATE. 

 



DECLARATIONS OF CONFORMITY 

 

This is to certify that Orion FX Series as delivered complies with the 2014/30/EU Council Directive on the 

approximation of the laws of the Member States relating to electromagnetic compatibility, and with the 

2014/35/EU Council Directive on the harmonization of the laws of the Member States relating to the making 

available on the market of electrical equipment designed for use within certain voltage limits., as well as these 

standards: 
 

 EN 55032:2015 + AC:2016 + A11:2020 + A1:2020 

 EN 55035:2017/A11:2020 

 EN IEC 61000-3-2:2019 

 EN 61000-3-3:2013 + A1:2019 + A2:2021 + A2:2021/AC:2022 

 EN 61000-6-2:2019 

 EN 62368-1:2020 + A11:2020 

 EN IEC 63000:2018 
 

 
 

This equipment has been found to comply with the limits for a Class A digital device, pursuant to Part 15 of the 

FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the 

equipment is operated in a commercial environment. This equipment generates, uses, and can radiate radio 

frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful 

interference to radio communications. Operation of this equipment in a residential area is likely to cause 

harmful interference in which case the user will be required to correct the interference at their own expense. 

 

The product safety of the devices is proven by their compliance to the EN 62368-1:2020 + A11:2020 standard. 

 
The manufacturer complies with the EU Directive 2012/19/EU on the prevention of waste electrical and 

electronic equipment (WEEE). The device labels carry a respective marking. 

 

These devices comply with Directive EN 63000:2018 on the restriction of the use of certain hazardous 

substances in electrical and electronic equipment  

 



TABLE OF CONTENTS 

Contents 
Disclaimer 1 

Introduction 1 

Features 2 

Compatibility 3 

Package contents 3 

Orion FX Model Description 4 

Orion FX 16-Port Models 4 

Orion FX 24-Port Models 5 

Orion FX 32-Port Models 6 

Orion FX 32-Port Models with Grid Ports 7 

Orion FX 40-Port Models 8 

Orion FX 48-Port Models 9 

Orion FX 64-Port Models 10 

Orion FX 64-Port Models (Continued) 11 

Orion FX 80-Port Models 12 

Orion FX 80-Port Models (Continued) 13 

Orion FX 120-Port Models 14 

Orion FX 120-Port Models (Continued) 15 

Orion FX 128-Port Models 16 

Orion FX 128-Port Models (Continued) 17 

Orion FX 144-Port Models 18 

Orion FX 144-Port Models (Continued) 19 

Orion FX 160-Port Models 20 

Orion FX 160-Port Models (Continued) 21 

Orion FX 160-Port Models (Continued) 22 

Orion FX 160-Port Models (Continued) 23 

Orion FX 160-Port Models (Continued) 24 

Installation 25 

System Setup 25 

Setup of the matrix 25 

Setup of Extenders 25 

Possible Orion FX Setups 26 

KVM Matrix 26 

Parallel Operation (Stacking) 27 

Matrix Grid 28 

Configuration 29 



 

 

Command Mode 29 

Set user-defined 'Hot Key' 30 

Set ‘Hot Key’ for direct OSD access 30 

Reset ‘Hot Key' 30 

Control Options 31 

Control through the OSD 31 

Entering the OSD 31 

Leaving the OSD 31 

Menu Structure 32 

OSD Keyboard controls 33 

Sorting Functions 33 

Password request 34 

Control through the Java Tool 36 

Requirements 36 

Installation of the Java Tool 36 

Computer Connection to the Matrix 36 

Starting the Java Tool 36 

Connecting to the Orion X 37 

Java Tool Menu Structure 38 

Operating Instructions 39 

Mouse Controls in the Java Tool 39 

Keyboard Controls in the Java Tool 39 

Reload Options 39 

Context Function 40 

Sorting Function 40 

Filter Function 40 

Offline Configuration 40 

Online Configuration 41 

Setting Java Tool Options 42 

Report 46 

Configuring System Settings 47 

System Settings 47 

Modifying System Settings through the OSD 49 

Modifying System Settings through the Java Tool 50 

Automatic ID 51 

Modifying Automatic ID Settings through the OSD 51 

Modifying Automatic ID Settings through the Java Tool 52 

Global OSD Settings 53 



 

 

Modifying Global Hot Key and Fast Key Settings through the OSD 53 

Modifying Global Hot Key and Fast Key Settings through the Java Tool 54 

Access Control 55 

Modifying Access Control through the OSD 56 

Modifying Access Control through the Java Tool 57 

Switch Settings 58 

Modifying Switch Settings through the OSD 59 

Modifying Switch Settings through the Java Tool 60 

Network Configuration 61 

Network Ports Used by Orion FX 62 

Modifying Network Settings through the OSD 63 

Modifying Network Configuration through the Java Tool 64 

Active Directory 67 

Configuration of Active Directory Server Synchronization with the OSD 68 

Configuration of Active Directory Server Synchronization with the Java Tool 70 

SNMP 73 

SNMP Configuration with the OSD 73 

SNMP Configuration with the Java Tool 75 

Date and Time 77 

Modifying Date and Time Settings through the OSD 78 

Modifying Date and Time Settings through the Java Tool 79 

Configuring User Settings 80 

User 80 

Modifying User Settings through the OSD 81 

Modifying User Settings through the Java Tool 83 

User Favorites List 86 

Setting up User Favorites through the OSD 86 

Setting up User Favorites through the Java Tool 88 

User Macros 89 

Setting up User Macros through the OSD 90 

Setting up User Macros through the Java Tool 91 

User Groups 95 

Setting up User Groups through the OSD 95 

Setting up User Groups through the Java Tool 97 

Configuring Extender Settings 98 

Managing Extender Settings through the OSD 99 

Managing Extender Settings through the Java Tool 100 

Flex-Port Extender Units 100 



 

 

USB 2.0 Extender 101 

Configuring USB 2.0 Extenders through the OSD 101 

Configuring USB 2.0 Extenders through the Java Tool 103 

Configuring CPU Settings 105 

CPU Device Settings 105 

Modifying CPU Device Settings through the OSD 106 

Modifying CPU Device Settings with the Java Tool 107 

CPU Groups 110 

Creating and Modifying CPU Groups with the OSD 110 

Creating and Modifying CPU Groups with the Java Tool 111 

Configuration of a CPU Switch 113 

Configuring a CPU Switch with the OSD 113 

Virtual CPU 115 

Assignment of Virtual CPUs through the OSD 115 

Assignment of Virtual CPUs through Java Tool 116 

Configuring Console Settings 118 

Console Device Settings 118 

Setting up CON Devices through the OSD 120 

Setting up CON Devices through the Java Tool 121 

OSD Mouse and Keyboard Configuration 124 

Modifying OSD Mouse and Keyboard Settings with the OSD 125 

Modifying OSD Mouse and Keyboard Settings through the Java Tool 126 

Console Extender OSD Settings 127 

Modifying Console Extender OSD Settings through the OSD 128 

Modifying Console Extender OSD Settings through the Java Tool 129 

Console Favorites List 130 

Setting up Console Favorites through the OSD 130 

Setting up Console Favorites with the Java Tool 131 

Console Macros 132 

Setting up Console Macros through the OSD 133 

Setting up Console Macros through the Java Tool 134 

Virtual Console 137 

Assignment of Virtual Consoles through the OSD 137 

Assignment of Virtual Consoles through Java Tool 138 

Shared Operation 139 

Setting up Shared Operation with the OSD 140 

Setting up Shared Operation with the Java Tool 141 

Multi-Screen Control 142 



 

 

Configuring Multi-Screen Control through the OSD (for Single-Head Applications) 142 

Configuring Multi-Screen Control with the Java Tool 145 

Extended Configuration for Multi-Head Multi-Screen Control with the Java Tool 148 

Saving and Loading of Configurations 149 

Saving the Current Configuration to the Orion FX 149 

Saving the Configuration in a specific internal location 151 

Saving the Configuration to a Specific Storage using the OSD 151 

Saving the Configuration to a Specific Location using the Java Tool 152 

Loading Configurations from Internal Memory 153 

Loading a Configuration from Internal Memory with the OSD 153 

Loading a Configuration from Internal Memory with the Java Tool 154 

Saving of Configurations (External) 155 

Loading of Configurations (external) 156 

Export and Import Options 158 

Export Options 158 

Import Options 159 

Matrix Cascading 160 

Setting Up Matrix Cascading through the OSD 160 

Setting Up Matrix Cascading through the Java Tool 162 

Matrix Grid 164 

Administration of Settings 164 

General Preparation 164 

Setting Up a Matrix Grid through the OSD 165 

Setting Up a Matrix Grid through the Java Tool 167 

Firmware Update 169 

Matrix Update 169 

Preparation 169 

Performing the Update 170 

Extender Update 173 

Preparation 173 

Performing the Update in Standard Mode (Parallel Update) 174 

Performing the Update in Expert Mode (sequential Update) 177 

Operation 179 

Switching Operation via Keyboard Commands 179 

Direct Switching 179 

Direct Switching of Video, Keyboard and Mouse 179 

Direct Switching of Video, Keyboard and Mouse in Private Mode 179 

Direct Switching of Video Only 180 



 

 

Direct Switching of Video, Keyboard and Mouse to previous CPU 180 

Disconnect current connection 180 

Scan Mode 180 

Function Keys <F1>-<F16> 180 

Switching a CON Unit to a local Source 181 

Multi-Screen Control 181 

Switching through the mouse 181 

Switching through the keyboard 181 

Switching Operation through the OSD 182 

KVM Switching 182 

Switching using the Selection List for CPU Devices 184 

Activating automatic Scan Mode for CPU Devices 184 

Extended Switching 185 

USB 2.0 Switching 186 

Switching a CON Unit to a Local Source with the OSD 187 

Switching via Macro List 188 

Switching Single EXT Units within Devices through the OSD 189 

Addressing of Master and Sub Matrices 190 

Switching Operation through the Java Tool 191 

Extended Switching 191 

Predefining Macros 195 

Redundancy 197 

Monitoring Redundancy Status with the OSD 197 

Monitoring Redundancy Status with the Java Tool 198 

Power Up and Power Down Functions 199 

Restart 199 

Restarting Through the OSD 199 

Restarting through the Java Tool 199 

Factory Reset 199 

Resetting Through the OSD 199 

Resetting Through the Java Tool 199 

Power Down 200 

Power Down through the OSD 200 

Power Down through the Java Tool 200 

Summary of Keyboard Commands 201 

Extender Commands 201 

Matrix Commands 202 

Diagnostics and Status 203 



 

 

LED Indicators 203 

Device Status LEDs 203 

Port Link Status LEDs, CATx 1G 204 

Port Link Status LEDs, CATx 3G 204 

Port Link Status LEDs, Fiber 205 

Network Connection Link and Activity Status LEDs 206 

Power Supply Status LEDs 206 

Port Status 207 

Viewing Port Status with the Java Tool 207 

Port Status Matrix Grid 210 

Extender OSD 211 

Network Status 212 

Viewing Network Status through the OSD 212 

Viewing Network Status with the Java Tool 213 

Matrix Firmware Status 213 

Firmware Status through the OSD 214 

Firmware Status through the Java Tool 215 

Extender Firmware Status 216 

Extender Firmware on I/O Board Status 219 

Trace Function 220 

Syslog Monitoring 221 

Filter Function 222 

Recording Function 222 

Syslog Find Function 223 

System Check 224 

Repair 226 

Technical Support 226 

Safety 227 

Safety and EMC Regulatory Statements 228 

Troubleshooting 229 

External Failure 229 

Video Interference 229 

Fan Malfunction 229 

Power Supply Unit Malfunction 229 

Network Error 230 

Failure at the matrix 230 

Port Interconnect Failure 230 

Error Indication at the 1G CATx port 230 



 

 

Error Indication at the 3G CATx Port 231 

Error Indication at the Fiber Port 231 

Blank Screen 232 
 
  



 

 

Figures 
Figure 1. Front Panel, 16-Port Model with all CATx Ports 4 

Figure 2. Front Panel, 16-Port Model with All Fiber Ports 4 

Figure 3. Rear Panel, 16-Port Models 4 

Figure 4. Front Panel, 24-Port Model with all CATx Ports 5 

Figure 5. Front Panel, 24-Port Model with All Fiber Ports 5 

Figure 6. Rear Panel, 24-Port Models 5 

Figure 7. Front Panel, 32-Port Model with all CATx Ports 6 

Figure 8. Front Panel, 32-Port Model with All Fiber Ports 6 

Figure 9. Rear Panel, 32-Port Models 6 

Figure 10. Front Panel, 32-Port Model with Grid Port and all CATx Ports 7 

Figure 11. Front Panel, 32-Port Model with Grid Port and all Fiber Ports 7 

Figure 12. Rear Panel, 32-Port Models with Grid Port 7 

Figure 13. Front Panel, 40-Port Model with all CATx Ports 8 

Figure 14. Front Panel, 40-Port Model with all Fiber Ports 8 

Figure 15. Front Panel, 40-Port Model with 24 CATx and 16 Fiber Ports 8 

Figure 16. Rear Panel, 40-Port Models 8 

Figure 17. Front Panel, 48-port Model with All CATx Ports 9 

Figure 18. Front Panel, 48-Port Model with All Fiber Ports 9 

Figure 19. Rear Panel, 48-Port Models 9 

Figure 20. Front Panel, 64-Port Model with All CATx Ports 10 

Figure 21. Front Panel, 64-Port Model with All Fiber Ports 10 

Figure 22. Front Panel, 64-Port Model with 40 Fiber Ports and 24 CATx Ports 10 

Figure 23.Front Panel, 64-Port Model with 40 CATx Ports and 24 Fiber Ports 10 

Figure 24. Rear Panel, 64-Port Models 11 

Figure 25. Front Panel, 80-Port Model with all CATx Ports 12 

Figure 26. Front Panel, 80-Port Model with all Fiber Ports 12 

Figure 27. Front Panel, 80-Port Model with 40 CATx Ports and 40 Fiber Ports 12 

Figure 28. Rear Panel, 80-Port Models 13 

Figure 29. Front Panel, 120-Port Model with All CATx Ports 14 

Figure 30. Front Panel, 120-Port Model with All Fiber Ports 14 

Figure 31. Front Panel, 120-Port Model with 80 CATx Ports and 40 Fiber Ports 15 

Figure 32. Rear Panel, 120-Port Models 15 

Figure 33. Front Panel, 128-Port Model with All CATx Ports 16 

Figure 34. Front Panel, 128-Port Model with All Fiber Ports 16 

Figure 35. Rear Panel, 128-Port Models 17 

Figure 36. Front Panel, 144-Port Model with All CATx Ports 18 

Figure 37. Front Panel, 144-Port Model with All Fiber Ports 18 



 

 

Figure 38. Rear Panel, 144-Port Models 19 

Figure 39. Front Panel, 160-Port Model with All CATx Ports 20 

Figure 40. Front Panel, 160-Port Model with All Fiber Ports 21 

Figure 41. Front Panel, 160-Port Model with 120 CATx Ports and 40 Fiber Ports 22 

Figure 42. Front Panel, 160-Port Model with 80 CATx Ports and 80 Fiber Ports 23 

Figure 43. Rear Panel, 160-Port Models 24 

Figure 44. Single-head KVM Matrix 26 

Figure 45. Parallel Operation (Stacking) 27 

Figure 46. Matrix Grid 28 

Figure 47. OSD Main Menu 32 

Figure 48. Configuration Login Screen in the OSD 34 

Figure 49. Configuration Menu in the OSD 35 

Figure 50. Java Tool Device Connect 37 

Figure 51. Device Finder in the Java Tool 37 

Figure 52. System Settings – System Screen in the Java Tool 38 

Figure 53. Java Tool Online Configuration 41 

Figure 54. Default Settings Tab in the Java Tool Options Menu 42 

Figure 55. Java Tool Font Size, Tool Tips and Color Theme 43 

Figure 56. Java Tool Language and Character Set 44 

Figure 57. Java Tool Miscellaneous Options Menu 45 

Figure 58. Java Tool Configuration Report 46 

Figure 59. Modifying System Settings through the OSD 49 

Figure 60. Modifying System Settings through the Java Tool 50 

Figure 61. Modifying Automatic ID Settings through the OSD 51 

Figure 62. Modifying Automatic ID Settings through the Java Tool 52 

Figure 63. Global Hot Key and Fast Key settings in the OSD 53 

Figure 64. Global Hot Key and Fast Key Settings in the Java Tool 54 

Figure 65. Modifying Access Control through the OSD 56 

Figure 66. Modifying Access Control through the Java Tool 57 

Figure 67. Modifying Switch Settings through the OSD 59 

Figure 68. Modifying Switch Settings through the Java Tool 60 

Figure 69. Modifying Network Settings through the OSD 63 

Figure 70. Modifying Network Settings through the Java Tool 64 

Figure 71. Syslog Activation 65 

Figure 72. Syslog Options Tab in the Java Tool 66 

Figure 73. Network Settings for Active Directory with the OSD 68 

Figure 74. Active Directory Configuration with the OSD 69 

Figure 75. Active Directory Setup with the Java Tool 70 



 

 

Figure 76. Creating a User for Active Directory with the Java Tool 71 

Figure 77. Create an LDAP User in the Java Tool 71 

Figure 78. Create a new LDAP Group with the Java Tool 72 

Figure 79. SNMP Monitoring through the OSD 73 

Figure 80. SNMP Monitoring through the Java Tool 75 

Figure 81. Setting SNMP Options in the Java Tool 76 

Figure 82. Add SNMP User in the Java Tool 76 

Figure 83. Modifying Date and Time Settings through the OSD 78 

Figure 84. Modifying Date and Time Settings through the Java Tool 79 

Figure 85. Modifying User Settings through the OSD 81 

Figure 86. Modifying User Settings through the Java Tool 83 

Figure 87. Choosing a User Type in the Java Tool 84 

Figure 88. New User Password Assignment in the Java Tool 84 

Figure 89. Assigning New User Access Rights in the Java Tool 85 

Figure 90. OSD Main Menu 86 

Figure 91. User Favorites OSD menu 87 

Figure 92. Setting up a User Favorites List with the Java Tool 88 

Figure 93. Setting Up User Macros through the OSD 90 

Figure 94. Setting Up User Macros through the Java Tool 91 

Figure 95. User Macros Function Key selection with Java Tool 92 

Figure 96. User Macro Function Selection with Java Tool 93 

Figure 97. User Macro Parameter Selection with Java Tool 94 

Figure 98. User Groups Settings in the OSD 95 

Figure 99. Setting up User Groups with the Java Tool 97 

Figure 100. Select New Group type in the Java Tool 97 

Figure 101. Managing Extender Settings through the OSD 99 

Figure 102. Managing Extender Settings through the Java Tool 100 

Figure 103. Configuring USB 2.0 Extenders through the OSD 101 

Figure 104. Configuring USB 2.0 Extenders through the Java Tool 103 

Figure 105. New Extender Unit Type Selection in the Java Tool 103 

Figure 106. Activate Fixed USB Port Dialog 104 

Figure 107. Modifying CPU Device Settings through the OSD 106 

Figure 108. Modifying CPU Device Settings with the Java Tool 107 

Figure 109. New CPU Device Dialog in the Java Tool 109 

Figure 110. Creating and Modifying CPU Groups with the Java Tool 111 

Figure 111. CPU Group Template Pop-Up Menu in the Java Tool 112 

Figure 112. Configuring a 484 Series Switch with the OSD 113 

Figure 113. Virtual CPU Device Assignment through the OSD 115 



 

 

Figure 114. Virtual CPU Devices Assignment through Java Tool 116 

Figure 115. Open CPU device in Assignment Virtual CPU Menu 117 

Figure 116. Setting Up CON Devices through the OSD 120 

Figure 117. Setting Up CON Devices through the Java Tool 121 

Figure 118. New CON Device Type 122 

Figure 119. Assign CON Device Access Rights by Right Click 123 

Figure 120. Modifying OSD Mouse and Keyboard Settings through the OSD 125 

Figure 121. Modifying Mouse and Keyboard Settings through the Java Tool 126 

Figure 122. Modifying Extender OSD Settings through the OSD 128 

Figure 123. Modifying Extender OSD Settings through the Java Tool 129 

Figure 124. Setting up Console Favorites through the OSD 130 

Figure 125. Setting Up Console Favorites through the Java Tool 131 

Figure 126. Setting Up Console Macros through the OSD 133 

Figure 127. Setting up Console Macros through the Java Tool 134 

Figure 128. Assign Settings Menu in the Java Tool 135 

Figure 129. Select CON Device to Receive Assigned Settings in the Java Tool 136 

Figure 130. Virtual CON Devices Assignment through the OSD 137 

Figure 131. Virtual to Real Console Assignment through Java Tool 138 

Figure 132. Enabling Shared Operation with the OSD 140 

Figure 133. Enabling Shared Operation with the Java Tool 141 

Figure 134. Setting Up Multi-Screen Control with the OSD 143 

Figure 135. Setting Up Multi-Screen Control with  the Java Tool 145 

Figure 136. Multi-Head Multi-Screen Configuration with the Java Tool 148 

Figure 137. Configuration Save in the OSD 149 

Figure 138. Remote Save in the Java Tool 150 

Figure 139. Remote Save Configuration Prompt in the Java Tool 150 

Figure 140. Saving Configuration to Internal Storage Locations with the OSD 151 

Figure 141. Saving Configuration to Internal Storage with the Java Tool 152 

Figure 142. Select a Configuration Internal Storage Location with the Java Tool 152 

Figure 143. Loading Internal Configuration through the OSD 153 

Figure 144. Loading Internal Configuration through the Java Tool 154 

Figure 145. Prompt to Activate Loaded Configuration 154 

Figure 146. Saving External Configuration through the Java Tool 155 

Figure 147. Loading external configuration through the Java Tool 156 

Figure 148. File Upload of Externally Saved Configuration in the Java Tool 157 

Figure 149. Selecting a Slot to Store the Externally Saved Configuration in the Java Tool 157 

Figure 150. Completed Loading of Externally Stored Configuration in the Java Tool 157 

Figure 151. Exporting Configuration Lists in the Java Tool 158 



 

 

Figure 152. Configuration List File Name and Storage Location in the Java Tool 158 

Figure 153. Importing a Configuration List in the Java Too 159 

Figure 154. Importing Configuration Lists through the Java Tool 159 

Figure 155. Setting Up Matrix Cascading Through the OSD 160 

Figure 156. Setting Up Matrix Cascading Through the Java Tool 162 

Figure 157. Creating New Cascade Units with the Java Tool 162 

Figure 158. Setting Up a Matrix Grid through the OSD - Step 1 165 

Figure 159. Setting Up a Matrix Grid through the OSD - Step 2 166 

Figure 160. Setting Up a Matrix Grid through the Java Tool 167 

Figure 161. Matrix Grid Wizard in the Java Tool, Step 1 168 

Figure 162. Matrix Grid Wizard in the Java Tool, Step 2 168 

Figure 163. Additional Firmware Update Selection Options 170 

Figure 164. Update Matrix Firmware in the Java Tool 170 

Figure 165. Save Matrix Status Prompt 171 

Figure 166. Firmware Update Progress Indicator 171 

Figure 167. Prompt to Restart the Matrix After Firmware Update 172 

Figure 168. Firmware Update Success 172 

Figure 169. Firmware Directory in the Java Tool 173 

Figure 170. Extender Update in Standard Mode through the Java Tool - Step 1: Upload Firmware 174 

Figure 171. Upload Extender Firmware to I/O boards with Java Tool 175 

Figure 172. Extender Firmware Update Part 2 in the Java Tool 175 

Figure 173. Enable Downgrade to Reload Current or Previous Firmware with the Java Tool 176 

Figure 174. Extender Update in Sequential Mode – Step 1 (from the Java Tool) 177 

Figure 175. Activate Service Mode with the Java Tool 178 

Figure 176. OSD View Service Mode – Step 2 (from the Service Mode of the OSD) 178 

Figure 177. Main Menu of the OSD 182 

Figure 178. KVM Switching Through the OSD 183 

Figure 179. CPU Selection List in the OSD for KVM Switching 184 

Figure 180. Extended KVM Switching through the OSD 185 

Figure 181. CON Switching Through the OSD 187 

Figure 182. Switching via Macro List in the OSD 188 

Figure 183. Switching of Single Extenders within Devices in the OSD 189 

Figure 184. Extended KVM Switching through Java Tool - Method 1 (From Extended Switch) 191 

Figure 185. Full Access Selection List in the Java Tool 192 

Figure 186. Extended KVM Switching through Java Tool - Method 2 (From View Matrix) 194 

Figure 187. Setting up Macro Presets in the Java Tool 195 

Figure 188. New Preset Macro Query 195 

Figure 189. Selecting the Preset Switching Operation 196 



 

 

Figure 190. Checking Redundant Links with the OSD 197 

Figure 191. Checking Redundant Links with the Java Tool 198 

Figure 192. Device Status LED 1 and LED 2 203 

Figure 193. I/O Port Link Status Indicators, 1G CATx 204 

Figure 194. I/O Port Link Status Indicators, 3G CATx 204 

Figure 195. I/O Board Port Link Status Indicators, Fiber 205 

Figure 196. Network Connection Link and Activity Status LEDs 206 

Figure 197. Power Supply Status Indicators 206 

Figure 198. Viewing Port Status with the Java Tool 207 

Figure 199. Port Status Mouse Context Menu 209 

Figure 200. View Port Status Matrix Grid 210 

Figure 201. Extender OSD 211 

Figure 202. Network Status in the OSD 212 

Figure 203. Viewing Network Status through the Java Tool 213 

Figure 204. Firmware Status through the OSD 214 

Figure 205. Viewing Firmware Status through the Java Tool 215 

Figure 206. Save Status Location and File Name in the Java Tool 215 

Figure 207. Save Status Anonymous Option in the Java Tool 216 

Figure 208. Save Status Steps in the Java Tool 216 

Figure 209. Extender Firmware Status in the Java Tool 217 

Figure 210. Expanded Firmware Status of Extender with the Java Tool 218 

Figure 211. Extender Firmware on I/O Board Status 219 

Figure 212. Trace Log Monitoring in the OSD 220 

Figure 213. Syslog Monitoring with the Java Tool 221 

Figure 214. Syslog Find Function 223 

Figure 215. System Check with the Java Tool 224 

Figure 216. Troubleshooting a 1G CATx Port Error 230 

Figure 217. Troubleshooting a 3G CATx Port Error 231 

Figure 218. Troubleshooting a Fiber Port Error 231 

Figure 219. Troubleshooting Blank Screen 232 

Figure 220. RJ45 Network Connector 236 

Figure 221. I/O Board RJ45 Connector 236 

Figure 222. I/O Port Fiber Type LC Connector 236 
  



 

 

Tables 
Table 1. Compatible Devices 3 

Table 2. Basic Keyboard Commands 29 

Table 3. Keyboard Commands - Hot Key Codes 29 

Table 4. Standard OSD Keyboard Commands 32 

Table 5. Keyboard Controls in the OSD 33 

Table 6. OSD Sorting Functions 33 

Table 7. Default Login Settings 34 

Table 8. Mouse Controls in the Java Tool 39 

Table 9. Keyboard Controls in the Java Tool 39 

Table 10. Java Tool Sorting Functions 40 

Table 11. Java Tool Filter Functions 40 

Table 12. Java Tool Options 42 

Table 13. Java Tool Miscellaneous Options 45 

Table 14. System Data in the OSD 48 

Table 15. Buttons in the OSD System Screen 49 

Table 16. Automatic ID Settings 51 

Table 17. Buttons in the OSD System Screen 51 

Table 18. Global OSD Settings 53 

Table 19. OSD Save / Reject Selection Options 54 

Table 20. Access Control Settings 56 

Table 21. Buttons in OSD Configuration Access Screen 56 

Table 22. Switch Settings 58 

Table 23. Buttons in OSD Switch Settings Screen 59 

Table 24. Network Settings 62 

Table 25. Orion FX Network Ports 62 

Table 26. Buttons in the OSD Network Settings Screen 63 

Table 27. Java Tool Syslog Settings 65 

Table 28. Syslog Options 66 

Table 29. Active Directory Parameters 67 

Table 30. Available SNMP Traps 74 

Table 31. Date and Time Settings 77 

Table 32. User Settings 80 

Table 33. Buttons in the OSD User Settings Screen 81 

Table 34. Buttons in the Java Tool User Settings Screen 83 

Table 35. User Macro Settings 89 

Table 36. General Extender Settings 98 

Table 37. Buttons in the OSD Extender Settings Screen 99 



 

 

Table 38. Buttons in the Java Tool Extender Settings Screen 100 

Table 39. CPU Device Settings 105 

Table 40. Buttons in the CPU Device Settings Screen 106 

Table 41. Buttons in the Java Tools CU Device Settings Screen 108 

Table 42. Keyboard Commands in the Java Tool CPU Device Settings Screen 108 

Table 43. CPU Group Settings 110 

Table 44. Some Buttons in the CPU Device Settings Screen 110 

Table 45. CPU Group Settings 113 

Table 46. Some Buttons in the CPU Device Settings Screen 114 

Table 47. CON Device Settings 119 

Table 48. Buttons in the Java Tool CON Devices Screen 121 

Table 49. Keyboard Commands in the Java Tool CON Devices Screen 122 

Table 50. Keyboard Commands for CPU Access Assignment in Java Tool in CON Devices Menu 123 

Table 51. Mouse and Keyboard Settings 124 

Table 52. Buttons in the Console Extender OSD Mouse and Keyboard Settings Screen 125 

Table 53. Extender OSD Settings 127 

Table 54. Console Macro Settings 132 

Table 55. Java Tool Virtual CON Assignment Screen Buttons 138 

Table 56. Multi-Screen Parameters in the OSD 142 

Table 57. Setting Up Multi-Screen Control with the Java Tool 145 

Table 58. Firmware Update Options in the Java Tool 169 

Table 59. Additional Selection Options in the Update firmware menu 169 

Table 60. Keyboard Commands for Local Source Switching 181 

Table 61. Keyboard Commands for Multi-Screen Switching 181 

Table 62. Keyboard Commands for Connecting and Disconnecting in the OSD 184 

Table 63. Extended KVM Switch Settings in the OSD 186 

Table 64. Description of Connection Symbols in the Java Tool Extended Switch Screen 193 

Table 65. Buttons in the Java Tool Extended Switching Screen 193 

Table 66. Extender Keyboard Commands 201 

Table 67. Matrix Keyboard Commands 202 

Table 68. Device Status Indicators 203 

Table 69. CATx 1G Link Status Indicators 204 

Table 70. CATx 3G Link Status Indicators 204 

Table 71. Fiber Link Status Indicators 205 

Table 72. Network Connection Link and Activity Status Indicators 206 

Table 73. Front Panel Power Supply Indicators 206 

Table 74. Color Indicators in the Java Tool Port Status Screen 207 

Table 75. Symbols in the Java Tool Port Status Screen 208 



 

 

Table 76. Extender Information for a Port in the Java Tool Port Status Screen 208 

Table 77. Mouse Context Menu for a Port in the Java Tool Port Status Screen 209 

Table 78. Information Displayed in the Extender OSD Screen 211 

Table 79. Network Status Settings 212 

Table 80. Information Displayed in the Matrix Firmware Status Screen 213 

Table 81. Information Displayed in the Extender Firmware Status Screen 216 

Table 82. Extender Firmware Update Indicators in the Java Tool 218 

Table 83. Information Displayed in the Extender Firmware on I/O Board Status Screen 219 

Table 84. Information Displayed in Trace Function 220 

Table 85. Filter Options for Syslog Monitoring 222 

Table 86. System Check Notification Levels 225 

Table 87. Troubleshooting an External Failure 229 

Table 88. Troubleshooting Video Interference 229 

Table 89. Troubleshooting a Fan Malfunction 229 

Table 90. Troubleshooting a Power Supply Unit Malfunction 229 

Table 91. Troubleshooting a Network Error 230 

Table 92. Troubleshooting a Failure at the Matrix 230 

Table 93. Troubleshooting a 1G CATx Port Error 230 

Table 94. Troubleshooting a 3G CATx Port Error 231 

Table 95. Troubleshooting a Fiber Port Error 231 

Table 96. Troubleshooting a Blank Screen 232 

Table 97. Supported CATx Cable Types 234 

Table 98. Maximum CATx Cable Lengths 234 

Table 99. Supported Fiber Cable Types 234 

Table 100. Maximum Fiber Cable Lengths 235 

Table 101. Connector Type for Fiber Cables 235 

Table 102. RJ45 Network Connector Pinouts 236 

Table 103. I/O Board RJ45 Connector Pinouts 236 

Table 104. I/O Port Fiber Type LC Connector Pinouts 236 

Table 105. Current and Voltage and Power Requirements for the Orion FX CATx 1G 237 

Table 106. Current and Voltage and Power Requirements for the Orion FX CATx 3G 237 

Table 107. Current and Voltage and Power Requirements for the Orion FX CATx 3G 237 

Table 108. Environmental Conditions Requirements for the Orion X 238 

Table 109. Size of the 4U Orion FX model and its Shipping Box 238 

Table 110. Size of the 2U Orion FX model and its Shipping Box 238 

Table 111. Size of the 1U Orion FX model and its Shipping Box 238 

Table 112. Shipping Weight of the 4U Orion FX 238 

Table 113. Shipping Weight of the 2U Orion FX 238 



 

 

Table 114. Shipping Weight of the 1U Orion FX 238 

Table 115. MTBF Values for the Orion FX 239 

Table 116. Part Numbers for Orion FX Units with CATx 1G Ports 240 

Table 117. Part Numbers for Orion FX Units with CATx 3GPorts 240 

Table 118. Part Numbers for Orion FX Units with Fiber Single Mode 1G Ports 240 

Table 119. Part Numbers for Orion FX Units with Fiber Single Mode 3G Ports 241 

Table 120. Part Numbers for Orion FX Units with Mixed CATx and Fiber 1G Ports 241 

Table 121. Part Numbers for Orion FX Units with Mixed CATx and Fiber 3G Ports 241 

Table 122. Part Numbers for Orion FX Units Matrix Grid Version with 1G Ports 241 

Table 123. Part Numbers for Orion FX Units with Expansion Capability in a 2U Chassis 242 

Table 124. Part Numbers for Orion FX Units with Expansion Capability in a 4U Chassis 242 

  



 

 

Appendices 
Appendix A – General Specifications 233 

Interfaces 233 

RJ45 (Network) 233 

RJ45 (Interconnect) 233 

Fiber SFP Type LC (Interconnect) 233 

Interconnect Cable 233 

CATx 233 

Type of Interconnect Cable 234 

Maximum Acceptable Cable Length 234 

Fiber 234 

Type of Interconnect Cable 234 

Maximum Acceptable Cable Length 235 

Type of Connector 235 

Connector Pinouts 236 

RJ45 Connector (Network) 236 

RJ45 Connector (Interconnect) 236 

Fiber SFP Type LC Connector 236 

Maximum Current, Voltage, and Power Consumption 237 

Orion FX, CATx 1G 237 

Orion FX, CATx 3G 237 

Orion FX, Fiber 1G and 3G 237 

Environmental Conditions 238 

Dimensions 238 

Orion FX 120-port, 128-port, 144-port, and 160-port (4U) 238 

Orion FX 48-port, 64-port, and 80-port models (2U) 238 

Orion FX 16-port, 24-port, 32-port, and 40-port models (1U) 238 

Weight 238 

Orion FX 120-port, 128-port, 144-port, and 160-port (4U) 238 

Orion FX 48-port, 64-port, and 80-port models (2U) 238 

Orion FX 16-port, 24-port, 32-port, and 40-port models (1U) 238 

MTBF 239 

Appendix B – Part numbers 240 
 



INTRODUCTION 

  Orion FX Manual 1 
 

Disclaimer 
While every precaution has been taken in the preparation of this manual, the manufacturer assumes no 
responsibility for errors or omissions. Neither does the manufacturer assume any liability for damages resulting 
from the use of the information contained herein. The manufacturer reserves the right to change the 
specifications, functions, circuitry of the product, and manual content at any time without notice. 
 
The manufacturer cannot accept liability for damages due to misuse of the product or other circumstances 
outside the manufacturer’s control. The manufacturer will not be responsible for any loss, damage, or injury 
arising directly or indirectly from the use of this product. (See limited warranty.) 
 
Introduction 
Thank you for choosing the Rose Electronics Orion™ FX System. The Orion FX System is the result of Rose 
Electronics’ commitment to providing continued state-of-the-art switching solutions for today’s demanding 
workplace. The Orion FX System has proven to be a valuable investment for all types of businesses that have 
the need to monitor, maintain, route, switch and access information from multiple computer systems. Its use in 
large computer and multimedia facilities gives the IT professional the added flexibility to monitor and maintain 
several systems, running on different platforms, from multiple KVM stations. The Orion FX System is the 
common-sense solution that provides the flexibility and security required for today’s business environment. 
 
Rose Electronics' Orion FX System is designed to be configured to meet system demands - one user or 
multiple users, two computers or hundreds. All configurations offer standard features that allow for easy, 
secure, and complete access to as many computers as the system has, from multiple KVM user stations. The 
Orion FX unit is connected to the computers and user stations through CATx cables, single-mode fiber cables 
or multi-mode fiber cables. Using CATx cabling, the distance can be up to 460 feet (140m) on either side of the 
matrix. The distance can be up to 3,280 feet (1 km) using multi-mode fiber, or 32,808 feet (10 km) using single-
mode Fiber. The use of lower bulk cables makes installation easier, quicker, and less expensive. 
 
The Orion FX is available in models which can support from 16 up to 160 independent ports, each of which 
functions independently. Each port can be defined and switched either as a console or a CPU port. The ports 
can be all CATx or all Fiber, or a combination of the two. It is designed to operate with extenders that can 
transmit keyboard, video, mouse, USB 2.0 signals. It can also be used as a video only matrix. 
 
The convenient On-Screen Display (OSD) menus are intuitive and easy to use. They guide the user through 
the process of configuring the Orion FX. 
 
The Orion FX is used along with extender Transmitters (CPU devices), and Receivers (CON devices). The 
CPU devices connect to the computer or video source, and the CON devices connect to DVI, HDMI or 
DisplayPort displays, as well as USB keyboards and USB mice. The CPU and CON devices connect to the 
Orion FX using CATx or Fiber cables. CPU and CON device models vary depending on the device support 
required.  
 
The reliability, security, and versatility of the Orion FX streamline any data center or server room by simplifying 
maintenance, access, and updating. 
 
Note:  This is a Class A product. In a domestic environment, this product may cause radio interference, in 
which case the user may be required to take adequate measures to correct the interference at their own 
expense. The safety instructions and installation guidelines in this manual should be considered carefully. 
Compliance with the specifications for cable lengths and types is essential. 
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Features 

■ Comes in a variety of models, each with different numbers of ports, from 16-port to 160-port 
■ Ports can be all CATx, all Fiber, or mixed CATx and Fiber 
■ Extend KVM stations and computers up to 460 feet (140m) on either side of the matrix through CATx 

cable, up to 3,280 feet (1 km) using multi-mode fiber, or 32,808 feet (10 km) using single-mode fiber 
■ Supports resolutions up to 1920 x 1200 @ 60Hz  
■ Intuitive OSD for easy use and configuration at each user station 
■ Each port on the Orion FX will automatically be configured as an input or output depending on the type of 

device that is connected. If a CPU device is connected, the port becomes an input. If a CON device is 
connected, the port becomes an output. 

■ Switch between video sources of the same resolution instantly 
■ Handles a variety of signals including: 

 DVI-D, DVI-I(VGA), HDMI, DisplayPort inputs 

 USB 2.0, USB HID 

 PS/2 

 Analog and Digital audio 
■ Orion FX units can be cascaded or stacked to build larger systems 
■ Matrix grid configuration allows combining Orion FX units into larger systems with redundant connections 
■ Multi-screen control provides for configuring extenders with multiple displays so that they can be 

seamlessly blended to function as one display in a variety of configurations  
■ Redundant power connections 
■ Rack-mountable: 

 16-port, 24-port, 32-port, and 40-port models are 1U size 

 48-port, 64-port, and 80-port models are 2U size 

 120-port, 128-port, 144-port, and 160-port are 4U size 
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Compatibility 

Video DVI-I (VGA or DVI), HDMI, DisplayPort 

Keyboards Compatible with all standard USB keyboards. Keyboards with a built-in hub are also supported 
maximum of two HID devices supported 

Mouse Compatible with all standard USB 2-button, 3-button and wheel mice 

Audio Supports analog and digital audio 

USB Supports USB 2.0 devices 

Interconnect  CATx cable allows a maximum distance of 460 ft (140 m) on either side of the switch. 
 Single-mode fiber cable allows up to 32,800 feet (10 km) on either side of the switch.  
 Multi-mode fiber cable allows up to 3,280 feet (1 km) on either side of the switch. 

 
Table 1. Compatible Devices 

 

Contact Rose Electronics for PS/2 keyboard and mouse support options 

 
Package contents 

■ Orion FX unit as ordered  
■ 1 x power cord for each power connector 
■ Rack mount kit with screws (optional) 
■ 1 x CATx network crossover cable (optional) 
■ Java Tool Software 
■ Manual 
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Orion FX Model Description 
The Orion FX is available in models with 16, 24, 32, 40, 48, 64, 80, 120, 128, 144, and 160 ports. These 
models are available with all CATx ports, all fiber ports, and mixed CATx and fiber ports. 
 
Orion FX 16-Port Models 
 

 
 

Figure 1. Front Panel, 16-Port Model with all CATx Ports 

 

 
 

Figure 2. Front Panel, 16-Port Model with All Fiber Ports 

 

1 – I/O Ports 1 through 8 4 – Network port 2 (RJ45) 
2 – I/O Ports 9 through 16 5 – Reset button 
3 – Network port 1 (RJ45)  

 

 
Figure 3. Rear Panel, 16-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 24-Port Models 
 

 
 

Figure 4. Front Panel, 24-Port Model with all CATx Ports 

 

 

Figure 5. Front Panel, 24-Port Model with All Fiber Ports 

 

1 – I/O Ports 1 through 8 4 – Network Port 1 (RJ45) 
2 – I/O Ports 9 through 16 5 – Network port 2 (RJ45) 
3 – I/O Ports 17 through 24 6 – Reset button 

 

 

Figure 6. Rear Panel, 24-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 32-Port Models 
 

 
 

Figure 7. Front Panel, 32-Port Model with all CATx Ports 

 

 
 

Figure 8. Front Panel, 32-Port Model with All Fiber Ports 

 

1 – I/O Ports 1 through 8 5 – Network Port 2 (RJ45) 
2 – I/O Ports 9 through 16 6 – Reset button 
3 – I/O Ports 17 through 24 7 – I/O Ports 25 through 32 
4 – Network port 1 (RJ45)  

 

 
 

Figure 9. Rear Panel, 32-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 32-Port Models with Grid Ports 
 

 
 

Figure 10. Front Panel, 32-Port Model with Grid Port and all CATx Ports 

 

 
 

Figure 11. Front Panel, 32-Port Model with Grid Port and all Fiber Ports 

 

1 – I/O Ports 1 through 8 5 – Network Port 2 (RJ45) 
2 – I/O Ports 9 through 16 6 – Reset button 
3 – Grid port 1 7 – I/O Ports 17 through 24 
4 – Network port 1 (RJ45) 8 – I/O Ports 25 through 32 

 

 
Figure 12. Rear Panel, 32-Port Models with Grid Port 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 40-Port Models 
 

 
 

Figure 13. Front Panel, 40-Port Model with all CATx Ports 

 

 
 

Figure 14. Front Panel, 40-Port Model with all Fiber Ports 

 

 
 

Figure 15. Front Panel, 40-Port Model with 24 CATx and 16 Fiber Ports 

 

1 – I/O Ports 1 through 8 5 – Network Port 2 (RJ45) 
2 – I/O Ports 9 through 16 6 – Reset button 
3 – I/O Ports 17 through 24 7 – I/O Ports 25 through 32 
4 – Network port 1 (RJ45) 8 – I/O Ports 33 through 40 

 

 
Figure 16. Rear Panel, 40-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 48-Port Models 
 

 
 

Figure 17. Front Panel, 48-port Model with All CATx Ports 

 

 
 

Figure 18. Front Panel, 48-Port Model with All Fiber Ports 

 

1 – I/O Ports 1 through 8 6 – I/O Ports 41 through 48 
2 – I/O Ports 25 through 32 7 – Network Port 1 (RJ45) 
3 – I/O Ports 9 through 16 8 – Network Port 2 (RJ45) 
4 – I/O Ports 33 through 40 9 – Reset button 
5 – I/O Ports 17 through 24  

 

 
Figure 19. Rear Panel, 48-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 64-Port Models 

 
Figure 20. Front Panel, 64-Port Model with All CATx Ports 

 
Figure 21. Front Panel, 64-Port Model with All Fiber Ports 

 
Figure 22. Front Panel, 64-Port Model with 40 Fiber Ports and 24 CATx Ports 

 
Figure 23.Front Panel, 64-Port Model with 40 CATx Ports and 24 Fiber Ports 

1 – I/O Ports 1 through 8 7 – Network Port 1 (RJ45) 
2 – I/O Ports 41 through 48 8 – Network Port 2 (RJ45) 
3 – I/O Ports 9 through 16 9 – Reset button 
4 – I/O Ports 49 through 56 10– I/O Ports 25 through 32 
5 – I/O Ports 17 through 24 11– I/O Ports 33 through 40 
6 – I/O Ports 57 through 64  
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Orion FX 64-Port Models (Continued) 

 
Figure 24. Rear Panel, 64-Port Models 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 80-Port Models 
 

 
 

Figure 25. Front Panel, 80-Port Model with all CATx Ports 

 

 
 

Figure 26. Front Panel, 80-Port Model with all Fiber Ports 

 

 
 

Figure 27. Front Panel, 80-Port Model with 40 CATx Ports and 40 Fiber Ports 

 

1 – I/O Ports 1 through 8 8 – Network Port 2 (RJ45) 
2 – I/O Ports 41 through 48 9 – Reset button 
3 – I/O Ports 9 through 16 10– I/O Ports 25 through 32 
4 – I/O Ports 49 through 56 11– I/O Ports 65 through 72 
5 – I/O Ports 17 through 24 12– I/O Ports 33 through 40 
6 – I/O Ports 57 through 64 13– I/O Ports 73 through 80 
7 – Network Port 1 (RJ45)  
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Orion FX 80-Port Models (Continued) 

 
 

Figure 28. Rear Panel, 80-Port Models 

 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 120-Port Models 
 

 
 

Figure 29. Front Panel, 120-Port Model with All CATx Ports 

 

 
 

Figure 30. Front Panel, 120-Port Model with All Fiber Ports 
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Orion FX 120-Port Models (Continued) 

 
 

Figure 31. Front Panel, 120-Port Model with 80 CATx Ports and 40 Fiber Ports 

1 – I/O Ports 1 through 8 10 – I/O Ports 25 through 32 
2 – I/O Ports 41 through 48 11 – I/O Ports 65 through 72 
3 – I/O Ports 9 through 16 12 – I/O Ports 33 through 40 
4 – I/O Ports 49 through 56 13 – I/O Ports 73 through 80 
5 – I/O Ports 17 through 24 14 – I/O Ports 81 through 88 
6 – I/O Ports 57 through 64 15 – I/O Ports 89 through 96 
7 – Network Port 1 (RJ45) 16 – I/O Ports 97 through 104 
8 – Network Port 2 (RJ45) 17 – I/O Ports 105 through 112 
9 – Reset button 18 – I/O Ports 113 through 120 

 

 
Figure 32. Rear Panel, 120-Port Models 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 128-Port Models 

 
 

Figure 33. Front Panel, 128-Port Model with All CATx Ports 

 

 
 

Figure 34. Front Panel, 128-Port Model with All Fiber Ports 

1 – I/O Ports 1 through 8 11 – I/O Ports 65 through 72 
2 – I/O Ports 41 through 48 12 – I/O Ports 33 through 40 
3 – I/O Ports 9 through 16 13 – I/O Ports 73 through 80 
4 – I/O Ports 49 through 56 14 – I/O Ports 81 through 88 
5 – I/O Ports 17 through 24 15 – I/O Ports 105 through 112 
6 – I/O Ports 57 through 64 16 – I/O Ports 89 through 96 
7 – Network Port 1 (RJ45) 17 – I/O Ports 113 through 120 
8 – Network Port 2 (RJ45) 18 – I/O Ports 97 through 104 
9 – Reset button 19 – I/O Ports 121 through 128 
10– I/O Ports 25 to 32  
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Orion FX 128-Port Models (Continued) 
 

 
Figure 35. Rear Panel, 128-Port Models 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 144-Port Models 

 
Figure 36. Front Panel, 144-Port Model with All CATx Ports 

 
Figure 37. Front Panel, 144-Port Model with All Fiber Ports 

1 – I/O Ports 1 through 8 12 – I/O Ports 33 through 40 
2 – I/O Ports 41 through 48 13 – I/O Ports 73 through 80 
3 – I/O Ports 9 through 16 14 – I/O Ports 81 through 88 
4 – I/O Ports 49 through 56 15 – I/O Ports 121 through 128 
5 – I/O Ports 17 through 24 16 – I/O Ports 89 through 96 
6 – I/O Ports 57 through 64 17 – I/O Ports 129 through 136 
7 – Network Port 1 (RJ45) 18 – I/O Ports 97 through 104 
8 – Network Port 2 (RJ45) 19 – I/O Ports 137 through 144 
9 – Reset button 20 – I/O Ports 105 through 112 
10– I/O Ports 25 to 32 21 – I/O Ports 113 through 120 
11– I/O Ports 65 through 72  
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Orion FX 144-Port Models (Continued) 
 

 
Figure 38. Rear Panel, 144-Port Models 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Orion FX 160-Port Models 
 

 
Figure 39. Front Panel, 160-Port Model with All CATx Ports 

 
1 – I/O Ports 1 through 8 13 – I/O Ports 73 through 80 
2 – I/O Ports 41 through 48 14 – I/O Ports 81 through 88 
3 – I/O Ports 9 through 16 15 – I/O Ports 121 through 128 
4 – I/O Ports 49 through 56 16 – I/O Ports 89 through 96 
5 – I/O Ports 17 through 24 17 – I/O Ports 129 through 136 
6 – I/O Ports 57 through 64 18 – I/O Ports 97 through 104 
7 – Network Port 1 (RJ45) 19 – I/O Ports 137 through 144 
8 – Network Port 2 (RJ45) 20 – I/O Ports 105 through 112 
9 – Reset button 21 – I/O Ports 145 through 152 
10– I/O Ports 25 to 32 22 – I/O Ports 113 through 120 
11– I/O Ports 65 through 72 23 – I/O Ports 153 through 160 
12– I/O Ports 33 through 40  
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Orion FX 160-Port Models (Continued) 
 

 
Figure 40. Front Panel, 160-Port Model with All Fiber Ports 

 
1 – I/O Ports 1 through 8 13 – I/O Ports 73 through 80 
2 – I/O Ports 41 through 48 14 – I/O Ports 81 through 88 
3 – I/O Ports 9 through 16 15 – I/O Ports 121 through 128 
4 – I/O Ports 49 through 56 16 – I/O Ports 89 through 96 
5 – I/O Ports 17 through 24 17 – I/O Ports 129 through 136 
6 – I/O Ports 57 through 64 18 – I/O Ports 97 through 104 
7 – Network Port 1 (RJ45) 19 – I/O Ports 137 through 144 
8 – Network Port 2 (RJ45) 20 – I/O Ports 105 through 112 
9 – Reset button 21 – I/O Ports 145 through 152 
10– I/O Ports 25 to 32 22 – I/O Ports 113 through 120 
11– I/O Ports 65 through 72 23 – I/O Ports 153 through 160 
12– I/O Ports 33 through 40  
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Orion FX 160-Port Models (Continued) 
 

 
Figure 41. Front Panel, 160-Port Model with 120 CATx Ports and 40 Fiber Ports 

 
1 – I/O Ports 1 through 8 13 – I/O Ports 73 through 80 
2 – I/O Ports 41 through 48 14 – I/O Ports 81 through 88 
3 – I/O Ports 9 through 16 15 – I/O Ports 121 through 128 
4 – I/O Ports 49 through 56 16 – I/O Ports 89 through 96 
5 – I/O Ports 17 through 24 17 – I/O Ports 129 through 136 
6 – I/O Ports 57 through 64 18 – I/O Ports 97 through 104 
7 – Network Port 1 (RJ45) 19 – I/O Ports 137 through 144 
8 – Network Port 2 (RJ45) 20 – I/O Ports 105 through 112 
9 – Reset button 21 – I/O Ports 145 through 152 
10– I/O Ports 25 to 32 22 – I/O Ports 113 through 120 
11– I/O Ports 65 through 72 23 – I/O Ports 153 through 160 
12– I/O Ports 33 through 40  
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Orion FX 160-Port Models (Continued) 
 

 
Figure 42. Front Panel, 160-Port Model with 80 CATx Ports and 80 Fiber Ports 

 
1 – I/O Ports 1 through 8 13 – I/O Ports 73 through 80 
2 – I/O Ports 41 through 48 14 – I/O Ports 81 through 88 
3 – I/O Ports 9 through 16 15 – I/O Ports 121 through 128 
4 – I/O Ports 49 through 56 16 – I/O Ports 89 through 96 
5 – I/O Ports 17 through 24 17 – I/O Ports 129 through 136 
6 – I/O Ports 57 through 64 18 – I/O Ports 97 through 104 
7 – Network Port 1 (RJ45) 19 – I/O Ports 137 through 144 
8 – Network Port 2 (RJ45) 20 – I/O Ports 105 through 112 
9 – Reset button 21 – I/O Ports 145 through 152 
10– I/O Ports 25 through 32 22 – I/O Ports 113 through 120 
11– I/O Ports 65 through 72 23 – I/O Ports 153 through 160 
12– I/O Ports 33 through 40  

 
 



 

  Orion FX Manual 24 
 

Orion FX 160-Port Models (Continued) 
 

 
Figure 43. Rear Panel, 160-Port Models 

1 – Power supply connector (standard) 3 – Grounding 
2 – Power supply connector (redundant)  
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Installation 
The installation section of this manual explains the basic system setup. It also describes in detail how to set up 
the Orion FX as a KVM Matrix, how to stack Orion FX matrices, and how to make a grid of matrices. 
 
System Setup 
It is recommended that first time users initially connect all of the system components in the same room as a 
test setup. This will facilitate identifying and correcting any cabling problems, and simplify the system 
configuration process.  
 
Setup of the matrix  
Configure the Orion FX matrix as follows. 

1. Connect a CON Unit to an I/O port of the matrix. 

2. Connect a keyboard, mouse and monitor to the CON unit.  

3. Apply power to the Orion FX and the CON unit.  

4. Display the OSD menu by typing <'Hot Key'>, <’o’> (default hot key sequence is 2x <Left Shift>). 

5. Select Configuration, and login with administrator rights (default user is “admin”, password “admin”). 

6. Configure according to application requirements. 

7. Select Save in the Configuration menu, and then select Restart Matrix.  

8. Optional: Establish a network connection between the matrix and a computer running the Java Tool in 
order to perform extended configuration. The default IP address is 192.168.100.99, with DHCP 
deactivated. Java Tool set up is described in Control through the Java Tool below.  

 
Note: When installing several Orion FX switches at the same time, it is strongly recommended to install them 
one at a time and to assign unique IP addresses to each in order to avoid IP address conflicts 
 
Setup of Extenders  
Configure the CPU and CON units as follows. 

1. Connect CON units to the matrix using CATx or fiber interconnect cables.  

2. Connect the CON units to their console devices (monitor, keyboard and mouse).  

3. Connect the 5VDC power supply units to the CON units and apply power.  

4. Check the basic function of the CON units by displaying the OSD menu with <'Hot Key'>, <o> (default 
hot key sequence is 2x <Left Shift>). 

5. Connect the sources (computer, CPU) to CPU units using the provided video and USB cables.  

6. Connect the CPU unit to the matrix using CATx or fiber interconnect cables.  

7. Connect the 5VDC power supplies to the CPU units.  

8. Start the system by applying power to the Matrix. 
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Possible Orion FX Setups 
The Orion FX can be set up in a variety of ways to provide the optimal system environment. Some parts of the 
Orion FX can be configured for single display computers, with other parts for multi-display computers. The 
KVM and USB 2 support can also be configured.  
 
While the Orion FX can be configured using the OSD of a connected CON unit, it can also be configured 
through a network connection with a computer running the Java Tool.  
 
The following sections illustrate some typical Orion FX configurations. 
 
KVM Matrix  
In single-head mode, up to 160 ports can be used either as input or as output ports depending on the 
components and equipment. Non-blocking access is available to all users, i.e. user access is not limited by the 
activities of another user.  
 

 
 

Figure 44. Single-head KVM Matrix 

 

1 - Source (computer, CPU) 2 - CPU Units 
3 - Interconnect cables 4 - Orion FX matrix 
5 - CON Units 6 - Console (monitor, keyboard, mouse) 

 
If a single-head console is used, it is possible to access dual-head or quad-head computers, but control is only 
possible at monitor 1. 
 
Video from any source can be viewed by any number of monitors simultaneously. Audio (optional) can also be 
switched in the same manner. 
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Parallel Operation (Stacking) 
For installations with multiple monitors per workstation or additional support of USB 2.0 transmission paths, the 
number of connectable CPUs and consoles can be increased by parallel operation (stacking) of several Orion 
FX devices. 
 
One Orion is configured as the Master Matrix, with its IP address entered into the Master IP Address field. All 
other Orion units in the system are configured as Sub Matrices. The Sub Matrices must be connected through 
their network connectors (RJ45) to the same network as the master matrix. The Enable LAN Echo option 
must be activated at the master matrix. 
 
When a switching command is executed at the master matrix, the synchronized matrices will also switch 
automatically.  
 
Switching of stacked devices might be delayed by several seconds.  
 

 
 

Figure 45. Parallel Operation (Stacking) 

 

1 - Dual-Head source (computer, CPU) 5 - Synchronized Matrix 
2 - CPU unit 6 - Network Connection Master / Synchronized Matrix 
3 - Interconnect cable 7 - CON unit 
4 - Master Matrix 8 - Console (2x monitor, keyboard, mouse) 
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Matrix Grid 
A Matrix Grid is a multiple matrix configuration which increases the total number of ports accessible beyond 
those in a single Orion FX. It is also useful when important equipment must be redundantly connected to 
several different matrix units. A Matrix Grid consists of a master matrix and at least one sub matrix. Up to 24 
matrices can be interconnected in a matrix grid installation. 
 
Orion units in a Matrix Grid are connected to each other by “Grid Lines”. The Grid Lines may connect the sub 
matrices directly to the master matrix or to other sub matrix units. The Matrix Grid can be set up in several 
ways, such as a ring, a hub and spokes, or a fully connected configuration, depending on the where the Grid 
Lines are installed. Grid Line signals are bidirectional, and each one can support a KVM connection. All 
switching operations are exclusively performed through the Grid Master. 
 

 
 

Figure 46. Matrix Grid 
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Configuration 
The Orion FX switch can be configured through keyboard commands in Command Mode, through the On-
Screen Display menus, or using the Java Tool. These options are described below. 
 
Command Mode 
The Orion FX Command Mode allows users to perform some functions through keyboard commands during 
normal use. 
 
To enter Command Mode, use a 'Hot Key' sequence, and to exit Command Mode, press <Esc>. While in 
Command Mode, the Caps Lock and Scroll Lock LEDs on the console keyboard will flash repeatedly. 
 
In Command Mode, normal keyboard and mouse operation will cease. Only valid keyboard commands are 
available. 
 
If no keyboard command is executed within 10 seconds after activating Command Mode, the matrix will 
automatically exit Command Mode. 
 
The following table lists the keyboard commands to enter and to exit Command Mode, and to change the 'Hot 
Key' sequence: 
 

Function Keyboard Command 

Enter Command Mode (default) 2x <Left Shift> (or 'Hot Key') 

Exit Command Mode <Esc> 

Change 'Hot Key' sequence 
<current 'Hot Key'>, <c>, 
<new 'Hot Key' code>, <Enter> 

 
Table 2. Basic Keyboard Commands 

 

<Key> + <Key> Press keys simultaneously 
<Key> , <Key> Press keys successively 
2x <Key>  Press key quickly, twice in a row (similar to a mouse double-click) 
 
The 'Hot Key' sequence to enter Command Mode can be changed. The following table lists the 'Hot Key' 
Codes for the available key sequences. 
 

'Hot Key' Code 'Hot Key' 

0 Freely selectable by user 

2 2x <Scroll> 

3 2x <Left Shift> 

4 2x <Left Ctrl> 

5 2x <Left Alt> 

6 2x <Right Shift> 

7 2x <Right Ctrl> 

8 2x <Right Alt> 
 

Table 3. Keyboard Commands - Hot Key Codes 
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Set user-defined 'Hot Key'  
When setting a user-defined 'Hot Key' (e.g. 2x<Space>), ‘Hot Key’ Code 0 is used. For example, to set 
2x<Space> as the ‘Hot Key’, the following keyboard sequence would be used: 
<current 'Hot Key'>, <c>, <0>, <Space>, <Enter>. 
 
Set ‘Hot Key’ for direct OSD access 
Besides using the ‘Hot Key’ for standard functions, a second ‘Hot Key’ can be set up to directly access the 
OSD.  
 
To use one of the pre-defined ‘Hot Key’ Codes (Codes from 2 to 8) from Table 3, use the following keyboard 
sequence: 
<current 'Hot Key'>, <f>, <'Hot Key' code>, <Enter>. 
 
To specify a user-defined ‘Hot Key’ like 2x<Space>, use the following keyboard sequence: 
<current 'Hot Key'>, <f>, <0>, <Space>, <Enter>. 
 
Reset ‘Hot Key' 
In order to set a ‘Hot Key' back to the default settings of the extender, press the key combination  
<Right Shift>+<Del> within 5 seconds after switching on the CON unit or plugging in a keyboard. 
 
To delete a ‘Hot Key’ for direct OSD access, use the following keyboard sequence: 
<current 'Hot Key'>, <f>, <0>, <Del>, <Enter>. 
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Control Options 
The following methods are available to configure and operate the Orion FX:  
 through a CON unit OSD 

 through the Java Tool 
 
Control through the OSD 
The Orion FX can be configured through the OSD (On-Screen-Display). The settings of the Configuration menu 
are described below. All other menus are described in later sections. You can access the OSD with a keyboard 
connected to a CON unit which is in the Orion FX system. 
 
When making changes through the OSD, please note the following. 

1. When the Okay button is clicked, all changes are applied to the active configuration and saved in the 
volatile memory of the matrix. In the event of a sudden power failure, these changes are lost. Perform 
one of the following operations to save the changes permanently. 

 Save the current configuration changes to the Orion FX unit as described on page 149. 

 Save the configuration to a specific storage as described on page 151. 

 Perform a restart of the unit as described on page 199. 

2. A change in system-relevant parameters (e.g., change of the IP address) is immediately displayed in 
the OSD. To activate these system-relevant configuration changes on the matrix, the matrix must be 
restarted. The restart of the matrix may take several minutes, and the matrix will be unavailable during 
the restart. 

 
Entering the OSD  

1. Start Command Mode with the 'Hot Key' (default: 2x <Left Shift>).  
2. Press <o> to open OSD. If the Enable CPU Selection option (described in Console Extender OSD 

Settings section) is enabled in the Configuration menu, a selection list for switching between available 
CPU Devices is displayed. In that case, press <F7> to go to the OSD main menu. 

Leaving the OSD  
 Press <Esc> in the main menu, or <Left Shift> + <Esc> from any OSD menu. 
The OSD will be closed without any further changes and the currently active CPU connection will be displayed. 
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Menu Structure 
The general layout of the OSD is structured into three areas:  
 Upper status area (topmost two text lines) 

 Working area  

 Lower status area (lowest two text lines) 
 

 
 

Figure 47. OSD Main Menu 

 

The following functions are available in most menus: 
 

Button Function 

Cancel Discard changes 

Okay Apply changes (temporary storage of the active configuration in memory) 
 

Table 4. Standard OSD Keyboard Commands 
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OSD Keyboard controls 
The following keyboard actions are available for navigation and configuration within the menus. 
 

Keyboard Command Function 

<Cursor Left> 
Input field: cursor left 

In menus: next input field 

<Cursor Right> 
Input field: cursor right 

In menus: previous input field 

<Cursor Up> 
In input fields: Line up (with wrap around) 

In menus: Line up (without wrap around) 

<Cursor Down> 
In input fields: Line down (with wrap around) 

In menus: Line down (without wrap around) 

<Page Up> Previous page, in menus with more than one page 

<Page Down> Next page in menus with more than one page 

<Tab> In menus with input fields, next input field 

<Left Shift> + <Tab> In menus with input fields, previous input field 

<+> 
In selection fields, next option 

In CPU selection list, with cursor on a CPU Group, expand group 

<-> 
In selection fields, previous option  

In CPU selection list, with cursor on a CPU Group, collapse group 

<Space> Switching in selection fields between two conditions, e.g. between ON / OFF or 
Y (Yes) / N (No) 

<Enter> 

In menus with input fields, save data 

In menus, select menu item 

With buttons, confirm selected button 

<Esc> 
In menus with input fields, cancel input data without saving 

In menus with selection fields: Go back to the higher level menu 
 

Table 5. Keyboard Controls in the OSD 

Sorting Functions 
Keyboard commands can be used with lists and tables in the OSD, to quickly sort, search, and refresh the 
items displayed. The following sorting options are available: 
 

Keyboard Command Function 

<F1> 
Sort by ID numbers in descending order by pressing the keyboard command once.  

Sort by ID numbers in ascending order by pressing the keyboard command twice 
(ID). 

<F2> 
Sort by ID names in descending order by pressing the keyboard command once.  

Sort by ID names in ascending order by pressing the keyboard command twice 
(Name). 

<F3> Go to the next result in the list of results of the search field (Next). 

<F4> Go to the previous result in the list of results of the search field (Previous). 

<F5> Refresh the currently displayed list (Refresh). 

<F6> Jump between the search field and the list of results (Find). 

<F8> Show unavailable CPUs 

<F9> Activate search function from the beginning of the name (Compare) 
 

Table 6. OSD Sorting Functions 
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Password request 
Access to the configuration menu requires login with administrator rights. The default user name and password 
for the admin account are as follows: 
 

Field Default Value 

User admin 

Password admin 
 

Table 7. Default Login Settings 

 

To access the configuration menu, proceed as follows:  
1. Press the <F10> key in the main menu of the OSD. The login screen appears.  

2. Enter the login data of the administrator  
 

 
 

Figure 48. Configuration Login Screen in the OSD 

 

For security reasons, this administrator password should be changed as soon as possible. 
 
To log out, press the <F10> key again. 
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After the administrator user name and password are entered, the Configuration menu is displayed. 
 

 

Figure 49. Configuration Menu in the OSD 
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Control through the Java Tool 

Requirements  
The following requirements have to be met to use the Java Tool:  
■ Minimum RAM of 512 MB 
■ Operating System with integrated Java Runtime: 

 Microsoft Windows: 8, 8.1, 10 
■ Operating System with a user-installed Java Runtime Environment 

 Microsoft Windows: 8, 8.1, 10 

 MacOS: 10.14 (Mojave) or higher, Intel platform 

 Oracle Java Runtime Environment (JRE) 1.8.x or higher  

 Strongly recommended: Oracle Java 1.8 update 152, or higher. 
■ Java Tool software  
■ Available network connection between the computer running the Java Tool and the matrix  
 
Contact the system administrator concerning JRE and the network connection.  
 
Installation of the Java Tool 
The Java Tool is available as a single executable program file that does not require installation.  
 
 Copy the tool to a directory on the computer.  
 
If the Java Tool was not provided, contact Rose Electronics. 
 
Computer Connection to the Matrix 
Use a crossover network cable for a direct connection between the Java Tool computer and the matrix, or a 
standard CATx cable for a connection through an Ethernet switch or hub. 
 
Do not use a network connection between the Java Tool computer and Orion FX that is primarily used to 
transmit audio data. 
 
 Use the appropriate network cable(s) to make the desired connections between the RJ45 ports of the 

computer and the RJ45 network port of the Orion FX.  
 
Starting the Java Tool 
 Open the Java Tool by double clicking the program icon or selecting the program and pressing the <Enter> 
key on the keyboard.  
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Connecting to the Orion X 
FTP rights are required. 
 

1. Open the Java Tool.  

2. Select Device > Connect in the menu bar, and enter the IP address of the matrix in the pop-up input 
field. 

 

 
 

Figure 50. Java Tool Device Connect 

 

3. Enter the administrator user name and password for the Orion FX. 

4. Confirm the inputs by clicking the Login button or select Cancel to abort login. 

5. Alternatively, select Device > Device Finder in the menu bar, or click the Device Finder icon in the 
toolbar.  

6. Select from the Orion FX units found and click the Connect button. Administrator log in is required. 
 

 
 

Figure 51. Device Finder in the Java Tool 

 

Up to twelve connections between the matrix and Java Tool software can be established at the same time. 
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Java Tool Menu Structure 
 

 
 

Figure 52. System Settings – System Screen in the Java Tool 

 

The Java Tool screen is subdivided into various sections:  
■ Menu bar (top line)  
■ Toolbar (second line with function icons)  
■ Tab bar (third line)  
■ Task area (left menu section below the Tab bar)  
■ Working area (right menu section below the Tab bar)  
■ Status bar (bottom line) 
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Operating Instructions  
The operation of the Java Tool is intuitive, because the Tool is similar to the user interface of common 
operating systems. 
 
The integrated help texts in the working area of the Java Tool can be activated or deactivated by clicking the 
Show Help checkbox in the upper right corner of the working area. 
 
Mouse Controls in the Java Tool 
The following mouse commands are available 
 

Mouse Command  Function 

Left mouse button click Menu selection, marking 

Double click left mouse button Open function-specific selection menus 

Right mouse button click Open context-specific selection menus 
 

Table 8. Mouse Controls in the Java Tool 

 

Keyboard Controls in the Java Tool 
The following keyboard commands are available. 
 

Keyboard Command Function 
<Cursor Left> Cursor to the left 

<Cursor Right> Cursor to the right 

<Cursor Up> Line up 

<Cursor Down> Line down 

<Page Up> Previous page in input or status menus with more than one page 

<Page Down> Next page in input or status menus with more than one page 

<Tab> Next field in input menus 

<Left Shift> + <Tab> Previous field in input menus 

<Space> 
Switching in selection fields between two conditions (checkmark or not) 

Open already marked fields for editing or selecting 

<Enter> 
Menu item selection 

In menus: Data saving 

<Ctrl> + <Tab> 
Leave tables 

Jump from tables into the next field 

<Ctrl> + <Left Shift> +<Tab> 
Leave tables 

Jump from tables into the previous field 
 

Table 9. Keyboard Controls in the Java Tool 

 

Some of the functions in the menu bar can be executed with keyboard commands listed to the right of the menu 
item (e.g. press <Ctrl> + <S> to execute Save). 
 
Reload Options 
The information shown in the Java Tool can be reloaded in different ways.  
■ By pressing <F5> on the keyboard 
■ By clicking Edit > Reload in the menu bar 
■ By clicking the "Reload" symbol in the symbol bar 
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Context Function 
The Java Tool offers several context-specific functions that support user-friendly operation. The individual 
context specific functions are described in their respective chapters. 
 To execute a context-specific function, click the right mouse button on the corresponding field and select the 

desired function.  
 

Sorting Function 
Lists and tables in the Java Tool have sorting functions for easy searching.  
 

Sort Function  Action Result 

Ascending sort Click the left mouse button once on 
the header of the column to be sorted 

The column is sorted in ascending order, with an 
arrow pointing upwards to indicate the sort type 

Descending sort Click the left mouse button twice on 
the header of the column to be sorted 

The column is sorted in descending order, with 
an arrow pointing downwards to indicate the sort 
type 

Cancel sort Click the left mouse button once or 
twice on the head of the sorted 
column 

The displayed arrow disappears 

 
Table 10. Java Tool Sorting Functions 

 

Filter Function 
Lists and tables in the Java Tool can also be filtered to display only relevant results. An active filter is indicated 
by an asterisk in the header. 
 

Filter Function  Action Result 

Activate filter Click the left mouse button in the filter entry 
field above the header. Then type the word 
or part of a word to be used to filter. 

The filter results are displayed immediately. 
The filter symbol is displayed in green. 

Cancel filter Delete the test in the filter entry field The list or table shows the complete 
content. The filter symbol is displayed in 
gray. 

 
Table 11. Java Tool Filter Functions 

 

Offline Configuration 
Configuration and system settings can be changed via the Java Tool in offline mode, without a direct 
connection between the tool and Orion FX. Afterwards, the configuration must be uploaded to the matrix. 
 

To activate an Orion FX configuration created offline, proceed as follows:  
1. Select File > Upload in the menu bar.  

2. Enter the IP address of the Orion FX, the admin user name and password, and the storage location of 
the new configuration (default, or config01 - config08) in the Select Configuration Slot menu. 

3. Select Device > Connect in the menu bar and once again enter the IP address of the Orion FX, the 
user name and password.  

4. Select Status & Updates > Activate Configuration in the task area and select the storage location 
that was selected in step 2.  

5. Use the Activate button to load the selected configuration in the Orion FX. 

6. The connection and the open tab will be closed and the Orion FX will restart. 
 

During the activation of a configuration, the matrix is temporarily unavailable. 
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Online Configuration 
Configurations and system settings can also be modified when the Java Tool is in Edit Mode with an active 
connection between matrix and Java Tool. 
 

 
 

Figure 53. Java Tool Online Configuration 

 

To change a configuration in Edit Mode, proceed as follows: 
1. Select the menu item Device > Activate Edit Mode or click the icon in the Toolbar. The setting will 

also be shown on the right side of the title bar of the working area. 

2. Make any edits in the configuration and system settings, and confirm by clicking the Apply button. The 
changes will be applied immediately. 

3. To deactivate Edit Mode, select the menu item Device > Deactivate Edit Mode in the menu bar. 

4. Click the Remote Save button to save the configuration changes to the active configuration of the 
matrix. 
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Setting Java Tool Options 

Default Settings 
The Java Tool can be adapted and customized by changing its default settings. To activate or change the 
default settings, proceed as follows:  
 Select Extras > Options in the menu bar. The Options menu will open with Default Settings tab selected.  
 

 
 

Figure 54. Default Settings Tab in the Java Tool Options Menu 
 

 
The following default settings can be changed: 
 

Option Description 

IP / Hostname Default IP address of the matrix required for connection 

User Default user name required for connection 

Configuration Directory Default directory for configuration files 

Firmware Directory Default directory for update files 

Status Directory Default directory for the firmware status files 

Import / Export Directory Default directory for import and export files 

Preset Directory Default directory for macro files 
 

Table 12. Java Tool Options 
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Java Tool Style Settings 
To set font size and color theme for the Java Tool, proceed as follows:  

1. Select Extras > Options in the menu bar and click the Style tab. 

2. Select the desired font size (normal or large). 

3. Click the Show Toolbar Button Text checkbox to display tooltip when the mouse cursor hovers over a 
menu item in the toolbar. 

4. Select the color theme for the software (Dark or Gray). 

5. Click Ok to confirm the changes and then restart the software. 
 

 
 

Figure 55. Java Tool Font Size, Tool Tips and Color Theme 
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Java Tool Language 
The language used in the Java Tool can be selected in this menu.  

1. Select Extras > Options in the menu bar and open the Language tab. 

2. Select the desired language and the corresponding character set. 

3. Click Ok to confirm the changes. 

4. Close the Java Tool software and restart it. 
 

 
 

Figure 56. Java Tool Language and Character Set 
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Java Tool Miscellaneous Options 
Additional options for the Orion FX Java Tool are available in this menu.  
 

Option Description 

Device Finder on Startup Start the device Finder automatically at Java Tool startup 

Name Adoption Name entered for a device and also applied to the extender, 
and vice versa 

Show Super Grid View Show the Super Grid option in the task area 

Show power backplane and fan firmware Show the firmware of the fans and the power backplane in the 
menu Status & Updates > Status – Matrix Firmware 

Enable single I/O board update on 
compact switch Applies only to Orion FX 

Enable splitted firmware update (matrix 
and extender) for master and sub part of 
the 576 matrix 

Applies only to Orion X 576 

 
Table 13. Java Tool Miscellaneous Options 

1. Select Extras > Options in the menu bar and open the Miscellaneous tab. 

2. Check or uncheck the selection boxes for the options to be changed. 

3. Click Ok to confirm the changes. 

4. Close the Java Tool software and restart it. 
 

 
 

Figure 57. Java Tool Miscellaneous Options Menu 
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Report 
The Java Tool is equipped with a report function that exports the current switching status and all relevant parts 
of the matrix configuration to a PDF file.  
 
To create a report, proceed as follows:  

1. Select File > Report... in the menu bar. A selection assistant will be opened.  

2. Select the information to be included in the report and confirm with the Next > button.  

3. Indicate the preferred storage location and file name for the report and confirm with the Finish button. 
The report will be created as a PDF file. 

 

 
 

Figure 58. Java Tool Configuration Report 

 

The report function can be used in both online mode and offline mode. 
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Configuring System Settings 
Orion FX system settings can be configured by administrators through either the OSD or the Java Tool. 
 
System Settings 
The following settings can be modified. 
 

Field Selection Description 

Device Text Enter the device name of the matrix (default: SWITCH_01) 

Name Text Enter the name of the configuration that is used to save the current 
settings (default: Standard) 

Info Text Additional text field to describe the configuration (default: Factory 
settings) 

Sub Matrix 
Y 

When Sub matrix is activated through the OSD, control of the OSD is 
automatically lost. Control can be recovered by re-opening the OSD, 
using the keyboard command for Sub matrix OSD: <hot key>, <s>, 
<o>.  

N Function not active (default) 

Load Default 
Y Loads the matrix with the default configuration after a restart or when 

powered on. 

N Loads the matrix with the last saved configuration after a restart or when 
powered on (default) 

Auto Save 
Y 

Save the current configuration of the matrix to flash memory every 10 
minutes. 
Note: During saving of the configuration, the matrix will not be 
operational. Saving occurs if changes have been made to the 
configuration, or switching operations have been executed since the last 
save. 

N Function not active (default) 

Enable COM Echo 
Y 

Echo all switching commands in the matrix through the serial interface.  
Note: This function should be enabled when using a media controller 
through the serial interface. 

N Function not active (default) 

Enable LAN Echo 
Y 

Echo all switching commands in the matrix through the LAN connection. 
Note: This function should be enabled when using a media controller via 
LAN connection; and on the Master matrix when using stacking with two 
or more matrices. 

N Function not active (default) 

Enable Redundancy 
Y 

Automatically switch to the second link of a connected redundant CON 
unit if the primary link of a CPU unit is lost (default). 
Note: This must be activated: 
•  for a single Orion FX unit with redundant link connections, 
•  in both Orion FX units in a fully redundant setup. 

N Function not active  

Synchronize 
Y Synchronize the sub matrix according to the switch status of the master 

matrix. 

N Function not active (default) 

Echo Only 
Y 

Synchronize the matrix based on the echo of a second matrix. 
Note: This is a bidirectional synchronization where both matrices have to 
be configured to Synchronize with the Master IP of the other matrix. 

N Function not active (default) 
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Field Selection Description 

Master IP Address Numerical Set the network address of the master matrix  
(default value: 000.000.000.000) 

Invalid IO-Boards 
Y 

Keep I/O boards with incorrect or invalid firmware online in the matrix. 
Note: To keep an I/O board with wrong or damaged firmware online in 
the matrix, the maintenance mode of the matrix will be activated. 

N Shut down I/O boards with incorrect or invalid firmware automatically 
(default). 

Enable old Echo 
Y Internally translate current switching commands (since V2.09) into the 

old switching commands and send them as an echo. 

N Function not active (default) 

Remove IO-Boards Y Orion X 576-port only: Shut down I/O boards in the Orion X 576 chassis 
if the second CPU board is not available. Connections will be disconnected 

Keep Gridlines 
Y Keep gridlines connected while waiting for the grid master. 

N Function not active (default) 

Horizontal Mouse 
Speed 1/x 1-9 Adjust the horizontal mouse speed, 1 = slow, 9 = fast (default value: 4) 

Vertical Mouse 
Speed 1/x 1-9 Adjust the vertical mouse speed, 1 = slow, 9 = fast (default value: 5) 

Double Click Time 100-800 Specify the maximum time interval between 2 mouse clicks that will be 
recognized as a double click (default value: 200 ms) 

Keyboard layout Region Set the OSD keyboard layout based on the keyboard in use  

Global Hot Key  Hex number Key used to enter command mode (default: 00, no global hot key) 

Global Fast Key Hex number Key used to enter command mode and display the OSD (default: 00, no 
global Fast Key) 

 
Table 14. System Data in the OSD 
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Modifying System Settings through the OSD 
 Select Configuration in the main menu and log in.  
 Select System in the Configuration menu.  
 

 
 

Figure 59. Modifying System Settings through the OSD 

 

Any changes made must be confirmed or rejected by selecting between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 15. Buttons in the OSD System Screen 
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Modifying System Settings through the Java Tool 
 Select the System Settings > System. 
 

 
 

Figure 60. Modifying System Settings through the Java Tool 

Make the necessary changes and click the Apply or Cancel buttons. 
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Automatic ID 
CPU and CON devices can be automatically created when a new extender unit is connected. This menu can 
be accessed in the OSD and the Java Tool.  
 

Field Selection Description 

Enable Auto Config 
Y Automatic creation of a new CPU or CON device when new extender 

modules are connected (default) 

N Function not active 

ID Real CPU Device Numerical Initial value of the automatic ID for real CPUs (default value: 1000) 

ID Virtual CPU Device Numerical Initial value of the automatic ID for virtual CPUs (default value: 2000) 

ID Real CON Device Numerical Initial value of the automatic ID for real CONs (default value: 3000) 

ID Virtual CON Device Numerical Initial value of the automatic ID for virtual CONs (default value: 4000) 
 

Table 16. Automatic ID Settings 

Modifying Automatic ID Settings through the OSD 
 Select Configuration in the main menu, log in, and select System. 
 

 
 

Figure 61. Modifying Automatic ID Settings through the OSD 

 

Enable or disable Auto Config, and enter Start ID values, and select between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 17. Buttons in the OSD System Screen 
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Modifying Automatic ID Settings through the Java Tool 
 Select the Automatic ID tab in System Settings > System. 
 

 
 

Figure 62. Modifying Automatic ID Settings through the Java Tool 

Enable or disable Auto Config, enter Start ID values, and click the Apply or Cancel buttons. 
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Global OSD Settings 
Orion Hot Keys and Fast Keys can be assigned globally, as well as individually to each console extender. A 
Hot key puts the console into command mode. A Fast Key puts the console into command mode and displays 
the OSD. Valid values for the Hot Key and the Fast Key are the USB-HID keyboard scan codes for keyboards 
with the US layout. The selected key must be pressed once if it is a function key or the print key, and twice if it 
is any other key.  
Note: Individual console extender assignments for Hot Key and Fast Key override global assignments. 
 

Field Selection Description 

Hot Key / Fast Key 

00 No global Hot Key / Fast Key defined, no modification of the extender 
module 

01 to FE Overwrite the Hot Key / Fast Key of the extender module with the 
entered value of the global Hot Key / Fast Key 

FF Deactivate the Hot Key / Fast Key of the extender module 
 

Table 18. Global OSD Settings 

Modifying Global Hot Key and Fast Key Settings through the OSD 
 Select Configuration in the main menu, log in, and select System  
 

 
 

Figure 63. Global Hot Key and Fast Key settings in the OSD 
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Enter the desired values for Global Hotkey and Fastkey and select between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 19. OSD Save / Reject Selection Options 

 

Modifying Global Hot Key and Fast Key Settings through the Java Tool 
 Select the Global OSD Settings tab in System Settings > System. 
 Select the keys desired from the drop-down menus and click the Apply or Cancel buttons. 
 

 
 

Figure 64. Global Hot Key and Fast Key Settings in the Java Tool 
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Access Control 
The access control configuration can be modified in the in the OSD and the Java Tool. The following settings 
can be modified. 
 

Field Selection Description 

Force User Login 
Y 

Users must login with a user name and a password once to enter 
OSD. Thereafter the user remains logged in until the user explicitly 
logs out or an auto logout occurs. 
Note: When using the Force User Login function, console 
favorites (see Console Favorites List) and console macros (see 
Console Macros) remain active. 

N Function not active (default) 

Enable User ACL 
Y 

CPU access is restricted according to the permissions in the User 
Access Control List. 
 User login is required 
 Switching by keyboard 'Hot Keys' requires a prior login 

N Function not active (default) 

Enable CON ACL 
Y CPU access is restricted according to the permissions in the 

Console Access Control List. No login required. 

N Function not active (default) 

OR User/CON ACL 
Y User’s access rights are the sum of the User ACL and the Console 

ACL after logging in to a console (extended access)  

N Function not active (default) 

AND User/CON ACL 
Y User can only access equipment allowed in BOTH the User ACL and 

the Console ACL 

N Function not active (default) 

Enable new User 
Y Newly created users automatically receive access to all CPUs. 

N Function not active (default) 

Enable new CON 
Y Newly created CON devices automatically receive access to all 

CPUs. 

N Function not active (default) 

Auto Disconnect 
Y When the OSD is opened at a console its current CPU connection 

will be automatically disconnected. 

N Function not active (default) 

OSD Timeout 0-999 seconds 
Period of inactivity after which OSD will be closed automatically. 
 Select 0 seconds, for no timeout (default: 0 seconds) 

Auto Logout 0-999 minutes 

Period of inactivity of a logged-in user at a console after which the 
user will be automatically logged out. The user’s current 
connection may be disconnected as a result of the logout, 
depending on the access rights in the User and Console ACL. 
 Select 0 minutes to disable inactivity logout. 
 Using the setting -1 allows the user to remain logged in until a 
manual logout is executed. 
 The timer is not active as long as the OSD is open. 
(default: 0 minutes) 

Keep CPU 
Y 

Keep the connection to the CPU device active in the background 
after Auto Logout. After a new login there is no need to re-connect 
to the CPU device. 

N Function not active (default) 
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Field Selection Description 

Show CPU 
Y Always show the name of the current CPU in the Connection Info 

box. 

N Function not active (default) 
 

Table 20. Access Control Settings 

 
Modifying Access Control through the OSD 
 Select Configuration in the main menu and log in. 
 Select Access. 
 

 
 

Figure 65. Modifying Access Control through the OSD 

 

Select between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 21. Buttons in OSD Configuration Access Screen 
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Modifying Access Control through the Java Tool 
 Select System Settings > Access in the task area.  
 

 
 

Figure 66. Modifying Access Control through the Java Tool 

Make the necessary changes and click the Apply or Cancel buttons. 
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Switch Settings 
The configuration of the switching parameters is set in this menu. This menu can be accessed in the OSD and 
the Java Tool. The following settings can be modified. 
 

Field Selection Description 

Enable Video Sharing 
Y 

Users can switch to any CPU as an observer, even ones connected to 
another user (observers without keyboard or mouse control). 
Note: Switching as an observer is done with <Space>, not <Enter>. 
The current user must have Update Connection Info enabled for his 
CON EXT to be notified when another user connects. 

N Function not active (default) 

Force Connect 
Y 

Users can connect to any CPU with keyboard and mouse control, even 
ones with another user currently connected. 
Note: The previous user is changed to video only status. To share K/M 
control, Force Connect must be activated. 

N Function not active (default) 

Force Disconnect 
Y 

An extension of Force Connect: if users connect to a CPU which already 
has another user connected, that user will be disconnected. 
Note: To share K/M control, Force Disconnect must be deactivated. 

N Function not active (default) 

CPU Auto Connect 
Y 

If a console is not connected to a CPU, an automatic connection to the 
next available CPU can be established by pressing any key or clicking a 
mouse button. 

N Function not active (default) 

CPU Timeout 0-999 
minutes 

Period of inactivity after which a console will be automatically 
disconnected from its current CPU (default value: 0 minutes) 

Keyboard Connect 
Y Activate request for K/M control by keyboard event (keystroke will be 

lost) 

N Function not active (default) 

Mouse Connect 
Y Activate request for K/M control by mouse event 

N Function not active (default) 

Release Time 0-999 
seconds 

Period of inactivity of a connected console after which K/M control can be 
requested by other consoles connected to the CPU (default: 10 seconds). 
Note: Setting "0" allows other users to immediately take control. Only 
one console can have keyboard and mouse control at a time. The other 
consoles that are connected to the same CPU have a video only status. 

Macro Single Step 
Y Execute macros one command at a time 

N Function not active (default) 
 

Table 22. Switch Settings 

To configure shared operation, proceed as follows: 
1. Select Configuration, log in, and select Switch in the main menu. 
2. Activate Enable Video Sharing. 
3. Activate Force Connect. 
4. Activate Keyboard Connect, if keyboard events should trigger taking control. 
5. Activate Mouse Connect, if mouse events should trigger taking control. 
6. Set a Release Time of inactivity after which KVM control can be taken. 
7. Click the Okay button to confirm the settings. 

 

Note:  Keyboard Connect and/or Mouse Connect are only effective if Force Connect and/or CPU Auto 
Connect are enabled. If the Keyboard Connect and/or Mouse Connect options are activated, a current user 
must be inactive for the number of seconds specified by Release Time before a new user can gain control. 
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Modifying Switch Settings through the OSD 
 In the main menu select Configuration, log in, and select Switch. 
 

 
 

Figure 67. Modifying Switch Settings through the OSD 

 

Make the necessary changes and select between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 23. Buttons in OSD Switch Settings Screen 
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Modifying Switch Settings through the Java Tool 
 Select System Settings > Switch in the task area.  
 

 
 

Figure 68. Modifying Switch Settings through the Java Tool 

Make the necessary changes and click the Apply or Cancel buttons. 
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Network Configuration 
The following Network settings can be modified through the OSD and the Java Tool. 
 

Field Selection Description 

Dual Interface 
Y Disable redundant network interface 

N Redundant network interface is active (default) 

DHCP 
Y 

Network settings are automatically supplied by a DNS server  
Note: If DHCP is activated and there is no network connection, matrix boot 
time might increase. 

N Function not active (default) 

IP address Byte Enter the IP address to be used when DHCP is inactive  
(default: 192.168.100.99). 

Subnet Mask Byte Enter the subnet mask to be used when DHCP is inactive 
(default: 255.255.255.0). 

Gateway Byte Enter the gateway address to be used when DHCP is inactive, in the form 
"192.168.1.1". 

Multicast Byte For Matrix Grids with a Multicast group, input the Multicast address 
(default: 255.255.255.0). 

API Service #1 
Y LAN interface of Orion FX activated for access via Java Tool, API service 

port 5555/5565 (default). 

N Function not active 

Grid Service #1 
Y Activate Grid Service Port 5557/5567 of Orion FX for access via Java Tool,  

N Function not active (default) 

SSL Services #1 
Y Activate SSL encryption for API, Java Tool, and Matrix Grid communication 

N Function not active (default) 

Syslog #1/#2 
Y Enable Syslog server for status request messages 

N Function not active (default) 

Syslog Server #1/#2 Byte Enter the Syslog server’s IP address in the form “192.168.1.1” and the 
Syslog port (default: 514) 

LDAP 
Y Enable user authentication with Active Directory Server 

N Function not active (default) 

LDAP TLS/SSL 
Y Enable transport layer security for Active Directory requests 

N Function not active (default) 

LDAP Server Byte Enter the IP address of the LDAP server (in the form “192.168.1.1”), and 
the LDAP port (Default: 389) 

LDAP Base DN Text Enter the LDAP Base DN per the existing structure of the user directory 

Trace DEB 
Y 

Activate debug messages in Trace (default: N) 
Note: Debug messages are exclusively for matrix diagnostics. They should 
be activated only after consultation with Rose Electronics, or increased 
data traffic might limit performance. 

N Function not active (default). 

Trace INF 
Y Activate information messages in Trace 

N Function not active (default). 

Trace NOT 
Y Activate notification messages in Trace (default). 

N Function not active. 

Trace WAR 
Y Activate warning messages in Trace (default). 

N Function not active. 
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Field Selection Description 

Trace ERR 
Y Activate error messages in Trace (default). 

N Function not active. 

Syslog #1/#2 DEB 
Y 

Activate debug messages in Syslog.  
Note: Debug messages are exclusively for matrix diagnostics. They should 
be activated only after consultation with Rose Electronics, or increased 
data traffic might limit performance of the Orion FX. 

N Function not active (default). 

Syslog #1/#2 INF 
Y Activate information messages in Syslog. 

N Function not active (default). 

Syslog #1/#2 NOT 
Y Activate notification messages in Syslog (default). 

N Function not active. 

Syslog #1/#2 WAR 
Y Activate warning messages in Syslog (default). 

N Function not active. 

Syslog #1/#2 ERR 
Y Activate error messages in Syslog (default). 

N Function not active. 
 

Table 24. Network Settings 

 

If changes are made to network parameters, save the changes and restart Orion FX to activate the changes. 
Restarting the Orion FX can take several minutes and the system will be unavailable during the restart. 
 
Note: Consult your system administrator before modifying the network parameters. Otherwise, unexpected 
results and failures may occur in combination with the network.  
 
Network Ports Used by Orion FX 
The following ports are used by Orion FX, depending on the configuration. Ports which are to be utilized for 
functions must be not be blocked by network security. 
 

Function Port 

FTP 21 / TCP 

DNS 53 

SNTP 123 / UDP 

SNMP 161, 162 / UDP 

LDAP 389 

Syslog 514 / UDP 

API 5555 / TCP (5565 for SSL) 

Broadcast 5556 / UDP (5566 for SSL) 

Matrix Grid 5557 / TCP (5576 for SSL) 
 

Table 25. Orion FX Network Ports 
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Modifying Network Settings through the OSD 
 Select Configuration in the main menu, log in, and select Network in the Configuration menu. 
 

 
 

Figure 69. Modifying Network Settings through the OSD 

 

Select between the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 26. Buttons in the OSD Network Settings Screen 
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Modifying Network Configuration through the Java Tool 
 Select System Settings > Network in the task area. 
 

 
 

Figure 70. Modifying Network Settings through the Java Tool 

 
Make the necessary changes and click the Apply or Cancel buttons. 
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Activating Syslog 
Starting or stopping the Syslog function is done with this Java Tool menu. The following parameters can be 
configured: 
 

Field Selection Description 

Enable Syslog 
Activated Enable Syslog service 

Deactivated Function not active (default) 

Syslog Server Byte Enter the IP address of the Syslog servers in the form “192.168.1.1” 

Log Level 

Debug 
Activate debug messages in syslog (default: deactivated) 
Note:  Syslog debug messages are for diagnostics only, not normal 
operation.  

Info Activate information messages in syslog (default: deactivated) 

Notice Activate notification messages in syslog (default: activated) 

Warning Activate warning messages in syslog (default: activated) 

Error Activate error messages in syslog (default: activated) 
 

Table 27. Java Tool Syslog Settings 

 

1. Select System Settings > Network in the task area. 

2. Select the Syslog tab in the working area. 

3. Make the desired changes to the settings and click Apply to confirm. 
 

 
 

Figure 71. Syslog Activation 
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Syslog Options 
The following Syslog settings can be modified: 
 

Option Description 

Port The computer port used to transmit messages via UDP 

Log File Directory Default directory for log file storage 

Log File Name Default log file name 

Log File Extension Default log file extension 

Daily Log Files Log files are stored every 24 hours 

Maximum Log File Size, KB Maximum allowed size of log files  

Maximum number of Log Files Maximum number of log files allowed.  

Acoustic Notification Enable acoustic notification for errors. 

Autostart When the Java Tool software is started, the syslog 
function is started in the background 

Open Monitoring Tab When the Java Tool software is started, the monitoring 
tab is opened. 

 
Table 28. Syslog Options 

Note:  When the maximum log file size is reached, a new log file will be created. When the maximum number 
of log files is reached, the oldest will be overwritten. 
 

1. Select Extras > Options in the menu bar and open the Syslog tab. 
 

 
 

Figure 72. Syslog Options Tab in the Java Tool 

2. Enter the appropriate information and click the Ok button to confirm. 
3. Close the Java Tool software and restart it. 
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Active Directory 
The Orion FX matrix can be synchronized with Active Directory for user authentication. This allows users to log 
in to Orion FX with login information from the Active Directory server. The connection between Orion FX and 
the Active Directory server is established via OpenLDAP and synchronized every 5 minutes. 
 
The search for users to be synchronized and automatically added to the KVM matrix configuration can be 
based on a group or an organizational unit (OU). In either case a user must be at least assigned to one 
group. 
 
With the group approach, all users belonging to a defined group in the active directory server are added to the 
KVM matrix and synchronized. The organizational units are added to the Orion FX configuration as user 
groups. This means that the group that includes the user can be found as an Orion FX user group in the 
configuration after the synchronization. A user can be member of up to 8 groups. 
 
With the organizational unit (OU) approach, all users belonging to groups that are located directly under this 
organizational unit are added and synchronized. The groups can also include subgroups. The structure of the 
groups is added to the Orion FX configuration as user groups. Each group will be represented in the KVM 
matrix as a user group after the synchronization. Groups located in sub organizational units are ignored.  
 
The integration of Active Directory is only available with the newer controller boards.  
 
The following parameters can be configured: 
 

Field Selection Description 

LDAP 
Y LDAP for user verification is active 

N Function not active (default) 

TLS/SSL 
Y Enable secure transmission (transport layer security) for Active 

Directory access 

N Function not active 

LDAP Server Byte The IP address of the LDAP Server, in the form “192.168.1.1”, and 
the LDAP port (Default: 389/636) 

Configured LDAP User Text Name of the configured LDAP user 

LDAP Base DN Text Input of the LDAP Base DN according to the existing structure of the 
user directory  

 
Table 29. Active Directory Parameters 

 



 

  Orion FX Manual 68 
 

Configuration of Active Directory Server Synchronization with the OSD 
In the OSD, LDAP is configured in two menus: Network and User Data. 
 Select Configuration in the main menu and log in. 
 Select Network. 
 

 
 

Figure 73. Network Settings for Active Directory with the OSD 

1. In the Network Services section, activate at least the function LDAP, and optionally LDAP TLS/SSL. 

2. Enter the appropriate IP address and port number in the field LDAP Server (default port: 389, 636 for 
SSL). 

3. Enter the appropriate information into the field LDAP Base DN (e.g., dc=example, dc=com). 

4. Click Okay to save the changes. 

5. Restart the Orion FX for the changes to take effect. 

6. When Orion FX has rebooted, select Configuration in the Main menu and log in. 

7. Select User Data. 
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Figure 74. Active Directory Configuration with the OSD 
 

8. Click the New LU button to create a new LDAP user. This user functions as a bind user. 

9. Enter the name of the bind user from the Active Directory into the Name field. 

10. Enter the Common Name (CN) of the bind user into the Login Name field. 

11. Enter the password of the bind user from the Active Directory into the fields Password and Repeat 
Password. 

12. Confirm the creation of the user by clicking the Okay button. 

13. Now click the New LG button to create a new LDAP group. The group determines which users of the 
Active Directory server should be synchronized. 

14. Enter a name into the Name field. 

15. Enter either Common Name (CN) of a group or the Common Name of an organizational unit into the 
field LDAP OU=/CN= in the form “OU=” name of the organizational unit, or “CN=” name of the group. 
The field entry must include either “OU=” or “CN=”. 

16. Confirm the creation of the group by clicking the Okay button. 
 
Active Directory synchronization can now be used. 
 

Note: A matrix configuration should only include one LDAP user and one LDAP group at the same time. The 
LDAP user and the LDAP group can be created, changed or deleted during ongoing operation without 
restarting the Orion FX. 
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Configuration of Active Directory Server Synchronization with the Java Tool 

1. Select System Settings > Network in the task area. 

2. Select the LDAP tab in the working area. 
 

 
 

Figure 75. Active Directory Setup with the Java Tool 

3. Click the LDAP checkbox. 

4. Optionally click the Use TLS/SSL checkbox to activate those functions. 

5. Enter the server IP address and port number into the fields LDAP Server and Port (default port: 389, 
636 for SSL). 

6. Enter the LDAP Base DN into the field Base DN (e.g. dc=example, dc=com). 

7. Click the Apply button to save the changes, and restart the Orion FX for the changes to take effect. 
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8. Select User Settings > Users & Groups in the task area. 
 

 
 

Figure 76. Creating a User for Active Directory with the Java Tool 

9. Click the New User button. 

10. Select Create a LDAP User in the pop-up window and click the OK button. 
 

 
 

Figure 77. Create an LDAP User in the Java Tool 
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11. Enter the name of the bind user from the Active Directory in the Name field. 

12. Enter the Common Name (CN) of the bind user from the Active Directory into the Login Name field. 

13. Enter the password of the bind user from the Active Directory into the field Password and confirm it. 
14. Confirm the creation of the user by pressing the button Apply. 
15. Open the tab Groups. 

16. Click the New Group button to create a new LDAP group. 
 

 
 

Figure 78. Create a new LDAP Group with the Java Tool 

 

17. Select Create a LDAP Group in the pop-up window. The group determines which users of the Active 
Directory server should be synchronized. 

18. Enter a name into the Name field. 

19. Enter either the Common Name (OU) of an organizational unit or the Common Name (CN) of a right 
group into the field LDAP OU=/CN= as shown below: 
a. OU= name of the organizational unit  
b. CN= name of the right group  

20. Confirm the creation of the user by clicking the Apply button. 
 
Active Directory synchronization can now be used. 
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SNMP 
The SNMP function allows all function-critical and safety-critical elements of the matrix to be monitored and 
queried. This function complies with the RFC 1157 standard. The SNMP option can be configured with the 
OSD and the Java Tool. 
 
Note:  When using SNMP monitoring, the use of a dedicated network to maintain continuous access is 
strongly recommended. 
 
SNMP Configuration with the OSD 
 
To enable SNMP and configure a SNMP server with the OSD, proceed as follows: 

1. Select Configuration in the main menu and log in. 

2. Select SNMP. 
 

 
 

Figure 79. SNMP Monitoring through the OSD 
 

3. Set the Enable option to Y (Yes) in the SNMP Agent pane by pressing the space bar. Activating this 
option grants permission for an active query of the SNMP agent. 

4. Set the Enable Traps option to Y (Yes) in the SNMP Server pane. This allows active transmission of 
trap messages from the SNMP agent to the SNMP server. 

5. Set the IP address of the SNMP server in Server Address. 

6. Activate the desired traps by setting them to Y (Yes). 

7. Confirm the selections by clicking the Okay button. 
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The following traps are available. 
 

Trap Description 

Status Notification about matrix status 

Temperature Notification about temperature within the matrix 

Insert Board Notification about insertion of a new I/O board into a slot 

Remove Board Notification about removal of an I/O board from a slot 

Invalid Board Notification about a faulty I/O board 

Insert Extender Notification about a connection of a new extender to the matrix, an extender 
powered on, or a new link between an extender and the matrix 

Remove Extender Notification about removal of an extender from the matrix, an extender powered off, 
or a link between an extender and the matrix interrupted 

Switch Command Notification about a switching operation performed in the matrix 

Fan Tray #1 Notification about the status of fan tray #1 

Fan Tray #2 Notification about the status of fan tray #2 

Power Supply #1 Notification about the status of power supply unit #1 

Power Supply #2 Notification about the status of power supply unit #2 

Power Supply #3 Notification about the status of power supply unit #3 

Power Supply #4 Notification about the status of power supply unit #4 
 

Table 30. Available SNMP Traps 

 

Two SNMP servers can be used at the same time. To view the SNMP status with the OSD, select Status in 
the main menu, and then select SNMP. 
 
Note: Restart the Orion FX to activate the SNMP agent and changes to SNMP server information. 
 



 

  Orion FX Manual 75 
 

SNMP Configuration with the Java Tool 
To activate the SNMP-Agent, proceed as follows. 

1. Select System Settings > Network in the task area. 

2. Select the SNMP tab. 
 

 
 

Figure 80. SNMP Monitoring through the Java Tool 

 

3. Tick the SNMP Agent check box. Activating this option grants permission for an active query of the 
SNMP agent. 

4. Tick the Enable Traps checkbox. This allows active transmission of trap messages from the SNMP 
agent to the SNMP server. 

5. Enter the IP address of the server in the SNMP Server field. 

6. Activate the desired traps. 

7. Click the Apply button.  
 

Note: Restart the Orion FX to activate the SNMP agent and any changes to SNMP server information. 
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Setting up SNMP Options with the Java Tool 
Presets for an SNMPv3 user can be set up for the computer on which the Java Tool software is located. 

 
 

Figure 81. Setting SNMP Options in the Java Tool 
 

To set or activate presets, proceed as follows: 
1. Select Extras > Options in the menu bar and open the SNMP tab.  

2. Click the Manage SNMPv3 Users button. A list of previously created SNMPv3 users is displayed 

3. Click the Add User button. A dialog window is displayed. 

 
 

Figure 82. Add SNMP User in the Java Tool 

4. Enter the required data and click the Ok button to confirm the entries. 

5. Click the Close button to close the users list. 

6. Click the Ok button in the SNMP tab to confirm the settings. 

7. Close the Java Tool software and restart it 
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Date and Time 
This menu allows changes to the Date and Time, based on Simple Network Time Protocol (SNTP). This menu 
can be accessed in the OSD and the Java Tool. 
 
The following settings can be modified. 
 

Field Selection Description 

SNTP Client 
Y Enable network time server synchronization 

N Function not active (default) 

SNTP Server Byte Enter the SNTP server’s IP address (default: 000.000.000.000) 

Time Zone Region If SNTP is active, enter the time zone where the matrix is installed. 

Month 1-12 Enter month 

Date 1-31 Enter date 

Year 1-99 Enter year 

Day of the week 1-7 Enter day of the week 

Hours 0-23 Enter hour 

Minutes 0-59 Enter minute 

Seconds 0-59 Enter second 
 

Table 31. Date and Time Settings 
 

Note:  Date format is according to English notation. 
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Modifying Date and Time Settings through the OSD 
 Select Configuration in the main menu, log in, and select Date+Time. 
 

 
 

Figure 83. Modifying Date and Time Settings through the OSD 

 

To configure Orion FX to use a timeserver, proceed as follows:  
1. Set the SNTP Client option to Y (Yes). 

2. Enter the IP address of the SNTP server in the SNTP Server field. 

3. Select the time zone for the region where the Orion FX is located in the Time Zone field. 

4. Click the Okay button to confirm the settings. 

5. Restart the matrix. The system time will now be synchronized with the SNTP server. 
 
To set the real time clock without using SNTP, proceed as follows:  

1. Set the current date in the Date field.  

2. Set the current day of the week in the Day field (Monday = 1).  

3. Enter the current time (international standard notation) in the Time field.  

4. Click the Set RTC button to confirm the settings.  
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Modifying Date and Time Settings through the Java Tool 
 Select System Settings > Date and Time in the task area. 
 

 
 

Figure 84. Modifying Date and Time Settings through the Java Tool 

To configure Orion FX to use a timeserver, proceed as follows:  
1. Enable SNTP option.  

2. Enter the IP address of the SNTP server in the SNTP Server field. 

3. In the Time Zone field, select the time zone for the region where the Orion FX is located. 

4. Click the Apply button to confirm the settings. 

5. Restart the matrix. The system time will be now synchronized with the SNTP server.  
 
To set the real time clock without using SNTP, proceed as follows:  

1. Set the current date in the Date field.  

2. Set the current time in the Time field.  

3. Click the Apply button to set the system time.  

4. Option: To set the Orion FX time using the current time of the computer running the Java Tool, click the 
Get Local Time button. 
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Configuring User Settings 
Users and their permissions can be created and modified through the OSD and the Java Tool. 
 
User 
Select from the following settings to create a new user or to edit an existing user’s attributes. 
 

Field Selection Description 

ID/Priority Integer User ID/User priority (0 – 999) 

Name Text 

Standard users: the login name (case sensitive, 1 to 16 characters) 

LDAP Users: the name (case sensitive, 1 to 16 characters) 

Users synchronized via LDAP: the sAMAccountName, retrieved from the 
LDAP server. 

Full Name Text 

Standard users: the full descriptive name (1 to 32 characters) 

LDAP Users: the login name (1 to 32 characters) 

Users synchronized via LDAP: the userPrincipalName retrieved from the 
LDAP server 

Password Text 
Standard users: user password (case sensitive, 1 to 16 characters) 

LDAP Users: the password retrieved from the server (case sensitive, 1 
to 16 characters) 

Member of Group Selection User Group assignment 

Administrator 
Y Permission for system configuration and all switching operations 

N Administrator permissions not granted (default) 

Super User 
Y Permission to switch any console to any CPU in Extended Switching. 

N Super User permission not granted (default) 

Power User 
Y 

Permission to switch consoles to CPUs in Extended Switching 
according to the CON ACL or User ACL (see Access Control), but not in 
Private Mode 

N Power User permission not granted (default) 

SNMP User 
Y Permission to use SNMPv3 (encrypted) 

N SNMP permission not granted (default) 

Auto Connect 
Y After user login, re-establish the last CPU connection 

N Function not active (default) 

AD Synchronized 
Y Synchronize group attribute for users from an Active Directory 

N Function not active (default) 

AD Group Locked 
Y 

Lock synchronization of group attribute for users from an Active 
Directory. This is required for a manual change of user groups for a 
specific Active Directory user. 

N Function not active (default) 
 

Table 32. User Settings 
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Modifying User Settings through the OSD 
 Select User Data in the Configuration menu. 
 

 
 

Figure 85. Modifying User Settings through the OSD 

 

The User List contains the ID number and name of all users and user groups.  
 
These buttons can be used to create and edit users and groups: 
 

Button Function 

New U. Create a new user 

New G. Create a new user group 

New LU New LDAP user 

New LG New LDAP user group 

Edit Edit the currently selected user or group 

Delete Delete the selected user or group 

Cancel Reject changes 

Okay Save Changes 
 

Table 33. Buttons in the OSD User Settings Screen 
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To create a new user with the OSD menu, proceed as follows: 
1. Click the New U. button. The Priority field will be selected. 

2. Assign a relative priority to the new user (0 to 999), and press Tab. A higher number indicates a higher 
priority. 

3. A system generated user name will be displayed. Edit the user name as desired, using up to 16 
characters, and press Tab. 

4. The Full Name field can be used to input the user’s full name or description. Press Tab. 

5. Enter a login Password for the user. Press Tab. 

6. Confirm the password by entering it again in the Repeat Password field and press Tab. 

7. By default, new users are not assigned group membership. To make the new user a member of an 
existing group, press the down arrow key until the desired group appears in the Member of Group 
field. Press Tab. 

8. By default, new users are not assigned advanced user privileges. To make the new user an 
Administrator, Super User, Power User or SNMP User, tab to the appropriate field and press the 
space bar to change the default ‘N’ selection to ‘Y’. 

9. Press the Tab key to reach the Auto Connect field. To cause the system to automatically reconnect 
the new user to their last connected CPU device each time they log in, press the space bar to change 
the default ‘N’ selection to ‘Y’. Press Tab to move to the CPU Access Control List. 

10. Initially there will no CPU devices in the new user’s Full access or Video access list. Press Tab twice 
to move to the No access list of computers. 

11. To move a CPU device from the new user’s No access list to the Full access list, select it and type the 
“f” key.  

12. To move a CPU device from the new user’s No access list to the Video access list, select it and type 
the “v” key.  

13. After modifications to the new user’s Access Control list are complete, press Tab to highlight the 
Cancel button. To discard all information and selections for the new user, press Enter. 

14. To retain the new user’s information, press Tab to highlight Okay and press Enter. 
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Modifying User Settings through the Java Tool 
 Select User Settings > Users & Groups in the task area. 
 Select the User tab in the working area to create users or edit existing user information. 
 

 
 

Figure 86. Modifying User Settings through the Java Tool 

 

Select between the following buttons: 
 

Button Function 

New User Open a new user configuration 

Delete User Delete an existing user 

Apply Create a new user account 

Cancel Reject changes 
 

Table 34. Buttons in the Java Tool User Settings Screen 

 



 

  Orion FX Manual 84 
 

To create a new user, proceed as follows: 
1. Click the New User button. 

2. Choose from standard User, LDAP User, SNMP User, or choose to use an existing user as a template. 
 

 
 

Figure 87. Choosing a User Type in the Java Tool 

 

3. Click the OK button. 

4. A system generated user name will be displayed. Edit the user name as desired. 

5. Optionally, enter a more descriptive Full Name for the user. 

6. Enter a Password, confirm the entry and click Ok. 
 

 
 

Figure 88. New User Password Assignment in the Java Tool 

 

7. Select the desired Priority, from 0 to 999. 

8. If the user needs the additional access rights of an Administrator, Super User, or Power User, click on 
the appropriate box. 

 



 

  Orion FX Manual 85 
 

9. To give the new user CPU access rights, right click on CPUs in the No Access list and then click on 
Assign Full Access rights or Assign Video Access rights in the pop-up menu. The selection will be 
added to the appropriate column. 

 

 
 

Figure 89. Assigning New User Access Rights in the Java Tool 

 

10. Alternatively click on a CPU device name to select it and type <f> to move it into the Full Access list, 
<v> to move it to the Video Access list, or <n> to move it to the No Access list 

11. Click the Favorites tab, and select a CPU device from the CPU Device available list to add to the 
user’s favorites for easy OSD access.  

12. Optionally hold down the keyboard Ctrl button and click on other CPU devices to add them to the 
selection. 

13. Click the single right arrow button to add the selected CPU devices to the Favorite CPU Devices list. 

14. To add all the CPU devices, click the double right arrow button. 

15. Click on entries in the Favorite CPU Devices list and press the keyboard <+> or <-> keys to move the 
selection higher or lower in the list. 

16. Click the Apply button to save the new user settings. 
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User Favorites List 
This menu is used to create individual favorites lists of CPU devices that users switch to frequently. A favorites 
list can contain the names of up to 16 different CPU devices. Switching to favorites can be done from the 
keyboard using a 'Hot Key' sequence. This menu can be accessed in the OSD and the Java Tool. 
 
Setting up User Favorites through the OSD 
The OSD User Favorites menu is not a part of the Configuration menu’s User Data section, but is found in the 
Main menu’s Assignments submenu. Login is required to access the User Favorites menu, and the Favorites 
list created there will apply to the logged in user. 
 
 Select Main Menu > Assignments. 
 

 
 

Figure 90. OSD Main Menu 
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 Select User Favorites and log in 
 

 
 

Figure 91. User Favorites OSD menu 

 

To create a favorites list for the logged in user, proceed as follows: 
1. Select a CPU from the CPU Devices list to add to the favorites list. Press <a> to add the CPU Device 

to the favorites list. Remove a CPU from a favorites list by selecting it and pressing <r>. 

2. The order of the CPU devices within the favorites list can be changed by selecting a CPU device and 
pressing <+> and <->. 

3. Click the Okay button to save the settings. 
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Setting up User Favorites through the Java Tool 
 Select User Settings > Users & Groups in the task area. 
 Select the User tab in the work area and select a user whose favorites list should be modified. 
 Select the Favorites tab. 
 

 
 

Figure 92. Setting up a User Favorites List with the Java Tool 

 

To create a favorites list for the selected user, proceed as follows: 
1. Select CPU devices in the CPU Device available list to be added to the user’s Favorite CPU Devices 

list. Press and hold the <Ctrl> key to select more than one CPU device at a time. 

2. Click the > button to move the selected CPU devices to the favorites list. If the >> button is clicked, the 
first 16 CPU devices in the CPU Device available list will be moved to the favorites list. 

3. A selected CPU device within the Favorite CPU Devices list can be moved up or down in the list by 
selecting it and pressing the <+> and <-> keys. 

4. To remove a CPU from the favorites list, select it and press the < button. If the << button is pressed, all 
CPU devices will be removed from the favorites list. 
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User Macros 
This menu is used to create macro commands for switching, disconnection or user administration. It can be 
found in the OSD and the Java Tool. 
 
Macro commands are created for each user individually. A macro can execute up to 16 switching commands 
successively. Macros 1 through 16 are invoked by pressing the 'Hot Key' and the function keys <F1> to <F16>. 
Macros 17 through 32 are invoked by pressing the ‘Hot Key’ and <Shift> + <F1> to <F16>. 
 
Note:  The user must be logged in to the Orion FX to invoke user macros. 
 
The following actions can be assigned to a User Macro: 
 

Field Selection Description 

Function 
(01-16) 

Connect  
(P1=CON, P2=CPU) Make a bidirectional connection from console P1 to CPU P2 

Connect Video  
(P1=CON, P2= CPU) Make a video connection from console P1 to CPU P2 

Disconnect  
(P1=CON) Disconnect console P1 

Logout User Logout current user 

Assign CPU  
(P1=VCPU, P2=RCPU) 

Assign a virtual CPU device to a real CPU device (see Virtual 
CPU) 

Assign CON  
(P1=RCON, P2=VCON) 

Assign a real console device to a virtual console device (see 
Virtual Console) 

Push  
(P1=CON) 

The user’s current KVM connection is forwarded to console P1 
and the user’s connection is changed to a video only connection. 

Push Video  
(P1=CON) 

The video signal of the user’s current connection (either KVM or 
video only) is forwarded to console P1. The user’s connection 
remains unchanged (KVM or video only). 

Get  
(P1=CON) 

The user’s console gets a KVM connection to the CPU that is 
currently connected to console P1. The connection of console P1 
is changed into a video only connection. 

Get Video  
(P1=CON) 

The user’s console gets a video only connection to the CPU that 
is currently connected to console P1. The connection of console 
P1 remains unchanged (KVM or video only). 

Login User  
(P1=CON, P2=User) Login User P2 at console P1  

P1 Con or CPU device Name of CON or CPU device 

P2 Con or CPU device, or User Name of CON or CPU device, or User ID 
 

Table 35. User Macro Settings 

 

Note: Macros can also be used to switch to CPU groups. 
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Setting up User Macros through the OSD 
 Select Configuration in the main menu, log in, and select User Macros. 
 

 
 

Figure 93. Setting Up User Macros through the OSD 

To create a macro for a user, proceed as follows: 
1. Enter characters in the Find Field to locate a user in the list, and the press tab to select the user. 

2. Alternatively press the Tab key in the Find Field to move to the User list and use the up or down arrow 
keys to select a user. 

3. Press the Tab key to move the selection to the Key field and use the up or down arrow keys to select 
the function key (F1 to F16) to which a macro is to be assigned. 

4. Press the Tab key to move the selection to the list of existing macros. Use the up or down arrow keys 
to select the position in the macro list where the new macro command is to be inserted. 

5. Press the Tab key to move the selection to the Edit button.  

6. Press Enter to select the Function field. Use the keyboard up or down arrow keys to change functions. 

7. Press the Tab key to move to the Parameters #1 field. Use the keyboard up or down arrow key to 
select the desired value for Parameter #1.  

8. Press the Tab key to move to the Parameters #2 field. Use the keyboard up or down arrow key to 
select the desired value for Parameter #2.  

9. Press the Tab key to highlight the Cancel and Okay buttons. Select the Okay button and press the 
enter key to confirm the user’s new macro. 
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Setting up User Macros through the Java Tool 
 Select User Settings > Users & Groups In the working area, select the user for whom macros are to be 

created and click the Macros tab. 
 

 
 

Figure 94. Setting Up User Macros through the Java Tool 
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To create a macro for the selected user, proceed as follows: 
1. Select the Function key (F1 to F16, or Shift + F1 to F16) in the Key field to assign to the macro. 

Currently assigned function keys will appear green in the horizontal display of function key icons. 
 

 
 

Figure 95. User Macros Function Key selection with Java Tool 
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2. Select the commands that should be part of the macro in the Function column. Double click an empty 
field in the function column and select a function for the macro from the list. 

 

 
 

Figure 96. User Macro Function Selection with Java Tool 
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3. If the function requires parameters, select the values for parameters P1 and P2, as required (e.g. 
corresponding consoles and CPUs). 

 

 
 

Figure 97. User Macro Parameter Selection with Java Tool 

 

4. Confirm the macro by clicking the Apply button. 
 
For convenient macro configuration, the following context functions are available: 
  To assign a given user’s macros to other users, click on the user’s name, then click the Assign Settings 

to... button below the User list. Select Macros from the list of settings displayed, and then click Next. Select 
the user or users to receive the macros from the list of available user names and click the > button to add 
those names to the Assign settings to… list. Click Finish to complete the macros assignment. The Copy 
Settings from... button functions similarly, except the user to receive macros is selected first. 

  All the macro commands of a selected key can be copied into the cache by clicking the Copy Key Macros 
button. These macros can then be pasted into a different key by selecting the key and clicking the Paste Key 
Macros button. All macros of a selected key can be removed by using the Delete Key Macros function. 
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User Groups 
The Orion FX provides for the creation of User Groups, aggregates of similar types of users who have similar 
computer access needs, for instance all power users, or all Software Engineers. The members of a group are 
given the same kind of access to the same computers, in addition to any individual access rights they may 
have. This can greatly simplify access administration in larger systems. The menus for creating User Groups 
can be accessed with the OSD and with the Java tool. 
 
Setting up User Groups through the OSD 
 Select Configuration in the main menu, log in, and select User Data. 
 

 
 

Figure 98. User Groups Settings in the OSD 

Creating a Standard User Group 

1. Click the New G... button. 

2. Enter a group name into the field Name. 

3. Click the Okay button to save the Group. 
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Creating an LDAP Group 

1. Click the New LG button to create a new LDAP group. The group determines which users in the Active 
Directory server should be synchronized. 

2. Enter a name into the field Name. 

3. Enter either the Common Name (CN) of a group or the name of an organizational unit (OU) into the 
field LDAP OU=/CN= , where: 
• OU = the name of the organizational unit 
• CN = the name of the group 
Note: the field entry must include either OU= or CN=. 

4. Click the Okay button to confirm the creation of the group. Active Directory synchronization can now be 
used. 

Note: an Orion FX configuration should include only one LDAP user and one LDAP group at the same time. The 
LDAP user and the LDAP group can be created, changed or deleted during ongoing operation, and does not 
require a restart of the system. 
 
Assigning a User to a Group 
To assign a user to a group, proceed as follows: 

1. Select the user you want to assign to a User Group. 

2. Select the User Group for the assignment in the field Member of Group using the cursor up and down 
keys. 

3. Click the Okay button to confirm the assignment. 
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Setting up User Groups through the Java Tool 

1. Select User Settings > Users & Groups, and select the Groups tab in the working area. 
 

 
 

Figure 99. Setting up User Groups with the Java Tool 

2. Click the New Group button  
3. Select the New Group’s type and click OK. 

 
 

Figure 100. Select New Group type in the Java Tool 

4. Enter a name for the group, with up to 16 characters. 
5. For LDAP Groups, enter the Common Name (CN) or the organizational unit name (OU) into the field  

LDAP OU=/CN= . 
6. Click the Apply button to create the group. 
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To assign a user to a group, proceed as follows: 
1. In the Groups tab of the Users & Groups menu, select a Group to be assigned user(s). 

2. Select a user in the list User/Group available. 

3. Click and drag the selection to the User/Group assigned list, or click the right arrow button. 

4. Click the Apply button to complete the assignment. 
 
Configuring Extender Settings 
When KVM Extenders are connected to the Orion FX matrix, extender units are created automatically. All EXT 
units can be managed with this menu. It can be accessed in the OSD and the Java Tool. 
 
The extender unit describes the connection of a physical extender to the matrix. Every extender board with a 
direct cable connection to the matrix is recognized as an extender unit. Dual-Head KVM extenders are 
recognized as two independent extenders. The data of add-on modules is included in one EXT Unit together 
with the associated extender module. 
 
The following settings are displayed. 
 

Field Selection Description 

ID Number Numerical value of the extender ID. For KVM Extenders, the ID is the 
serial number provided by the extender unit, and cannot be changed. 

Name Text Name of the extender unit 

Fixed 
Y Extender unit has a fixed port assignment (default) 

N Function not active. 

Port 1-160 (depending on the 
Orion FX matrix) Port number of the extender unit 

 
Table 36. General Extender Settings 
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Managing Extender Settings through the OSD 
 Select Configuration in the main menu and log in. 
 Select EXT Units in the Configuration menu.  
 

 
 

Figure 101. Managing Extender Settings through the OSD 
 

Select between the following buttons: 
 

Button Function 

New Create a new extender unit 

Edit Edit an existing extender unit 

Delete Delete an existing extender unit 

Cancel Reject changes 

Okay Save Changes 
 

Table 37. Buttons in the OSD Extender Settings Screen 

 
The settings for General OSD Data are described below in the Mouse and Keyboard section. 
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Managing Extender Settings through the Java Tool 
 In the Task area, under Extenders and Devices, select EXT Units. 
 

 
 

Figure 102. Managing Extender Settings through the Java Tool 

 

Select between the following buttons: 
 

Button Function 

New Unit Create a new extender unit 

Delete Unit Delete an existing unit 

Apply Confirm changes of an extender unit 

Cancel Reject changes 
 

Table 38. Buttons in the Java Tool Extender Settings Screen 

 

Flex-Port Extender Units 
Many extenders have functionality which is automatically recognized by the system and these extenders 
cannot be created manually. This is the Flex-Port function of the Orion FX matrix. 
 
Note:  The connection of a fixed port extender module (e.g. USB 2.0) to a Flex-Port extender can cause 
unintended results. 
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USB 2.0 Extender 
This section describes how to configure and use USB 2.0 extenders. These extenders must be connected to 
standard I/O boards. They can be configured for independent switching, or can be assigned to existing CON or 
CPU devices. USB 2.0 extenders can be configured through the OSD or the Java Tool. 
 
Configuring USB 2.0 Extenders through the OSD 
 Select Configuration in the main menu and log in. 
 Select EXT Units in the Configuration menu. 
 

 
 

Figure 103. Configuring USB 2.0 Extenders through the OSD 

 

To create a USB 2.0 extender definition through the OSD, proceed as follows: 
1. Press the New button. An extender with an eight-digit ID will be created, starting with digit 9.  

2. Assign an appropriate name to the extender in the Name field. 

3. Enter the I/O port number where the USB 2.0 extender unit is connected to the matrix into the Port 
field. 

4. To configure the extender as a CON Unit, set the USB-CON (standalone) option to Y (C#1 of Input 
Signals) and confirm by clicking the Okay button. 
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5. To configure the created extender as a CPU Unit, set the USB-CPU (standalone) option to Y (C#1 of 
Output Signals), and confirm by clicking the Okay button. 

6. Restart the I/O board to activate the USB fixed port for the new EXT unit. 

7. Next, either assign the USB 2.0 CON/CPU EXT unit to an existing CON/CPU device, or create a new 
CON or CPU device.  

8. To assign the USB 2.0 CON extender to an existing CON Device, select the existing device, and move 
the USB 2.0 CON extender from the EXT available field into the EXT assigned field.  

9. Alternatively, to create a new CON device, see Console Device Settings. To create a new CPU device, see 
CPU Device Settings. 

10. If parallel operation is used within the matrix, set the Release Time in the Configuration > Switch 
screen to 10 seconds or more (see Modifying Switch Settings through the OSD). 

11. Restart all I/O boards on which USB 2.0 extenders have been configured, or alternatively restart the 
Orion matrix.  

 
The USB 2.0 extenders are now configured and can be used. 
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Configuring USB 2.0 Extenders through the Java Tool 
 Select Extenders and Devices > EXT Units in the task area. 
 

 
 

Figure 104. Configuring USB 2.0 Extenders through the Java Tool 

1. Click the New Unit button. This opens a pop-up window. 
 

 
 

Figure 105. New Extender Unit Type Selection in the Java Tool 
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2. From the Templates in the selection box, select USB 2.0 CON Unit or USB 2.0 CPU Unit and click the 
OK button. An extender with an eight-digit ID will be created, starting with digit 9.  

3. Enter an appropriate name for the extender in the Name field.  

4. Enter the port number of the matrix where the USB 2.0 extender is physically connected into the Port 
field.  

5. Confirm the settings by pressing the Apply button. A pop-up window is displayed. 
 

 
 

Figure 106. Activate Fixed USB Port Dialog 

6. Click the Yes button to restart the I/O board and activate the USB fixed port for the new EXT unit. After 
restart of the I/O board, the parameters and settings of the USB 2.0 extender module are shown in the 
working area of the respective EXT Unit. 

7. The USB 2.0 CPU/CON EXT Unit has to now be either assigned to an existing CPU/CON Device or a 
new CPU/CON Device has to be created for the assignment:  

• For a CPU Device see CPU Device Settings.  

• For a CON Device see Console Device Settings. 

8. If parallel operation is used within the Orion FX matrix, set the Release Time in the System Settings > 
Switch menu to 10 seconds or more (see Modifying Switch Settings through the Java Tool). 

9. Restart all I/O boards on which USB 2.0 extenders have been configured, or restart the matrix.  

 
The USB 2.0 extenders are now configured and can be used. 
 
■ Manually created EXT units are always set as fixed port EXT units. This configuration is necessary to, for 

example, switch USB 2.0 connections through the matrix. 
■ To make a fixed port available again for Flex-Port EXT units after deleting a fixed port EXT unit, restart the 

I/O board. 
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Configuring CPU Settings 
CPU Device Settings 
New CPU devices are defined in this menu, including their assignment to EXT units. The assignment helps to 
describe and switch more complex computer configurations (e.g. Quad-Head with USB 2.0) in the Orion FX 
system. This menu can be accessed in the OSD and the Java Tool. 
 
The following settings can be modified. 
 

Field Selection Description 

ID Text ID of the CPU unit 

Name Text Name of the CPU device 

Member of 
Group Selection Assign the CPU device to a group. 

Member of 
Switch Selection Assign the CPU input to the respective CPU Switch 

Remote CPU Selection Assign an IP CPU device to the IP CPU EXT unit 

CPU assigned  ID and name of the assigned Virtual CPU Device, automatically retrieved 
(see Virtual CPU) 

Group 
Y Automatically set if the CPU device is assigned to a CPU Group 

N Function not active (default) 

Switch 
Y Automatically set for a CPU Switch 

N Function not active (default) 

Remote Access 
Y Automatically set for an IP CPU Device 

N Function not active (default) 

Virtual Device 
Y Automatically set for a Virtual CPU Device 

N Function not active (default) 

Allow Private 
Y Allow switching to the CPU device in Private Mode 

N Function not active (default) 

Force Private 
Y Force switching to the CPU device in Private Mode only 

N Function not active (default) 

Fix Color Selection Show a colored frame when switching to the CPU device (choice of 7 
colors). 

Reference 
Y 

Establish a reference CPU device whose device and extender settings 
can be inherited by any CPU unit when it is initially connected to the 
matrix. Should be only activated for a single CPU device. 

N Function not active (default) 

2 Step Access 
Y Make a new connection to the CPU device Video Only, and open a pop-

up window requiring confirmation to establish a Full Access connection 

N Function not active (default) 

Exclusive 
Access 

Y 

Create an access limitation such that when the CPU device already has a 
Full Access connection, only a higher priority connecter can establish a 
new Full Access connection and take control of keyboard and mouse. 
Equal priority connecters can only establish Video Only connection. 
Lower priority connectors are denied connection. 

N Function not active (default) 

MSC disabled 
Y Deactivate Multi-Screen Control function 

N Activate Multi-Screen Control function 

CPU Colors Selection The CPU device name will be highlighted according the color setting for 
test and background (choice of 16 colors). 

 
Table 39. CPU Device Settings 
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Modifying CPU Device Settings through the OSD 
 Select Configuration in the main menu and log in. 
 Select CPU Devices in the Configuration menu. 
 

 
 

Figure 107. Modifying CPU Device Settings through the OSD 

 

Select between the following buttons: 
 

Button Function 

New R. Create a new real CPU device 

New V. Create a new virtual CPU device 

New G. Create a new CPU Group 

New S. Create a new CPU Switch 

New Sp. Create a CPU device for a CPU Switch 

Edit Edit an existing CPU device 

Delete Delete an existing CPU device 

Cancel Reject changes 

Okay Save changes 
 

Table 40. Buttons in the CPU Device Settings Screen 

 



 

  Orion FX Manual 107 
 

To create a CPU Device, proceed as follows:  
1. Click the New R. button to create a new real CPU Device or click the New V. button to create a new 

virtual CPU Device. 

2. Enter a CPU Device name into the field Name.  

3. Click the Okay button.  

The CPU Device is now created. 
  
To assign an EXT Unit to a CPU Device, proceed as follows:  

1. Select the CPU Device you want to assign an EXT Unit.  

2. Select the EXT Unit for the assignment in the EXT available list.  

3. Click the Okay button.  
 
The EXT Unit is now assigned to the CPU Device. 
 
Modifying CPU Device Settings with the Java Tool 
 Select Extenders & Devices > CPU Devices in the task area. 
 

 
 

Figure 108. Modifying CPU Device Settings with the Java Tool 
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Select between the following buttons: 
 

Button Function 

New Device Open a new CPU Device 

Delete Device Delete a CPU Device 

Apply Confirm a created CPU Device 

Cancel Reject changes 
 Assign selected extender units 
 Assign all available extender units 
 Remove the selected extender units 
 Remove all extender units 
 Change assignment number of the EXT unit downwards 
 Change assignment number of the EXT unit upwards 

 Change assignment number of the EXT unit to first position 

 Change assignment number of the EXT unit to last position 
 

Table 41. Buttons in the Java Tools CU Device Settings Screen 

The following keyboard commands can be used. 
 

Function Keyboard Command 

Change assignment number of the EXT unit upwards <+> 

Change assignment number of the EXT unit downwards <-> 
 

Table 42. Keyboard Commands in the Java Tool CPU Device Settings Screen 
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To create a new CPU device, proceed as follows: 
1. Click the New Device button. A pop-up window lists type choices. 

 
Figure 109. New CPU Device Dialog in the Java Tool 

2. Select between the choices available (a template requires at least one existing CPU device).  

3. Click the OK button and a new CPU device is created. 

4. Select the desired parameters for the new CPU device. 

5. Click the Apply button to create the CPU device 
 
To access a new CPU from the Orion FX matrix, an assignment of one or more CPU EXT units is required. 
Proceed as follows: 

1. Select the new CPU in the CPU Devices list. 

2. Select one or more extenders in the Extender available list. 

3. Perform the assignment by clicking the  button. To assign all available extenders to the CPU, click 
the  button. The assignments are displayed in the Extender assigned list. 

4. Confirm the assignment by clicking the Apply button. 
 
To remove an extender assignment, proceed as follows: 

1. Select a CPU in the CPU Devices list. 

2. Select one or more extenders in the Extender assigned list. 

3. Remove the assignment with the  button. To remove all existing assignments, click the  button. 

4. Confirm the removal with the Apply button. 
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CPU Groups 
The Orion FX allows multiple CPU devices to be configured as a CPU Groups. The groups can be used to 
logically or thematically aggregate the CPU Devices. For example, all CPU Devices that are connected to a 
specific matrix in a matrix grid could be grouped together. The configuration of CPU groups can increase the 
clarity of the Orion FX configuration. This menu can be accessed in the OSD and the Java Tool. 
 
The following settings can be modified. 
 

Field Selection Description 

ID Text ID of the CPU group 

Name Text Name of the CPU group 

Member of Group Selection Assign the CPU device to a group. 

Group 
Y Automatically set if the CPU Device is assigned to a CPU Group  

N Function not active (default)  
 

Table 43. CPU Group Settings 

 

Creating and Modifying CPU Groups with the OSD 
 Select Configuration in the main menu and log in. 
 Select CPU Devices in the Configuration menu. 
 
Select between the following buttons. 
 

Button Function 

New G. Create a new CPU group 

Edit Edit an existing CPU group 

Delete. Delete an existing CPU Group 

Cancel Reject changes 

Okay Save changes 
 

Table 44. Some Buttons in the CPU Device Settings Screen 

 

To create a new CPU group, proceed as follows. 
1. Click the New G. button 

2. Enter a name for the group in the Name field. 

3. Click the Okay button. 
 
The CPU Group has been created.  
 
To assign a CPU Device to a group, proceed as follows: 
 Select CPU Devices in the Configuration menu. 

1. Select the CPU Device to assign to a CPU Group. 

2. Select the CPU Group in the field Member of Group using the cursor up and down keys. 

3. Click the Okay button. 
 
The CPU Device is now assigned to the CPU Group. 
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Creating and Modifying CPU Groups with the Java Tool 
 Select Extenders & Devices > CPU Devices in the task area. 
 

 
 

Figure 110. Creating and Modifying CPU Groups with the Java Tool 
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Follow the steps below to create a new CPU Group using the Java Tool. 
1. Select the CPU Groups tab in the working area. 

2. Click the New Group button. 

3. If any CPU Croups were previously created, a pop-up window will open. 
 

 
 

Figure 111. CPU Group Template Pop-Up Menu in the Java Tool 

 

4. Select an existing Group as a template, or just click on the OK button. 

5. Enter a name for the Group in the field Name. 

6. Click the Apply button, and the Group is created. 
 
To assign a CPU Device to a CPU Group, proceed as follows: 

1. Select the CPU Groups tab in the working area of the Extenders & Devices > CPU Devices menu. 

2. Select the CPU Group to be assigned a CPU Device. 

3. Select a CPU Device to be assigned to the group in the CPU/Group available. 

4. Either click and drag the selection to the CPU/Group assigned list or click the right arrow button. 

5. Click the Apply button to save the assignment. 
 



 

  Orion FX Manual 113 
 

Configuration of a CPU Switch 
The CPU Switch is an 8:1 port concentrator for up to eight computer sources connected by VGA and USB HID 
(keyboard and mouse). It can be specifically configured for use with an Orion FX. The configuration allows 
individual switching of up to eight input signals with the OSD. This menu is available in the OSD. 
 
The following settings can be modified. 
 

Field Selection Description 

ID Text ID of the CPU device 

Name Text Name of the CPU device 

Member of switch Selection Assign the CPU input to the respective CPU Switch  

Switch 
Y Automatically set for a CPU Switch  

N Function not active (default)  
 

Table 45. CPU Group Settings 

 

Configuring a CPU Switch with the OSD 
 Select Configuration in the main menu and log in. 
 Select CPU Devices in the Configuration menu. 
 

 
 

Figure 112. Configuring a 484 Series Switch with the OSD 
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Select between the following buttons. 
 

Button Function 

New S. Create a new CPU Switch 

New SP. Create a CPU EXT Unit for a CPU Switch 

Edit Edit an existing CPU group 

Delete. Delete an existing CPU Group 

Cancel Reject changes 

Okay Save changes 
 

Table 46. Some Buttons in the CPU Device Settings Screen 

 

Follow the steps below to set up a new CPU switch. 
1. Click the New S. button. 

2. Enter a name for the switch in the Name field. 

3. Assign an EXT Unit to the CPU Switch in the EXT Assigned field. 

4. Click the New SP. button. A new CPU (input) for a CPU Switch will be created (port 1). 

5. Assign the newly created CPU to a CPU Switch in the field Member of Switch. 

6. Repeat steps 4 and 5 for each input port in use on the CPU Switch. 

7. Click the Okay button. The CPU switch is now configured and can be individually switched with the 
OSD. 
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Virtual CPU 
Orion FX allows CPU specific assignments. Assigning virtual CPUs to real CPUs simplifies the process of 
switching several consoles to the same CPU. If several consoles are switched to a virtual CPU which is 
assigned to a real CPU, the change only has to be done once, and all consoles will receive the video signal of 
the real CPU. It is possible to assign one or several real CPUs to a virtual CPU, but only one virtual CPU can be 
assigned to a real CPU. This can be done through the OSD or the Java Tool. 
 
Assignment of Virtual CPUs through the OSD 
 Select Assignments > Virtual CPU devices in the main menu.  
 

 
 

Figure 113. Virtual CPU Device Assignment through the OSD 

 
To make an assignment, proceed as follows:  

1. Select the Virtual CPU in the Virtual Devices list that is to be assigned to a real CPU.  

2. Click the Edit button.  

3. Select the CPU in the Real Devices list that is to be assigned to the selected virtual CPU.  

4. Click the Okay button to confirm the assignment. 
 



 

  Orion FX Manual 116 
 

Assignment of Virtual CPUs through Java Tool 
 Select Assignment > Virtual CPU Devices at the bottom of the task area on the left of the Java Tool. 
 

 
 

Figure 114. Virtual CPU Devices Assignment through Java Tool 

 

To make an assignment, proceed as follows:  
1. Select a virtual CPU in the Virtual CPU list. 

2. Double click in the Real CPU column to get a list of all available real CPUs. 

3. Select a real CPU. 

4. Click the Send button to send the assignment to Orion FX. 
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When the Auto Send checkbox in the left lower corner of the working area is ticked, switching operations will 
be performed immediately, without user confirmation by clicking the Send button. 
 
There is a blank field just above the Virtual CPU and Real CPU lists, which can be used to enter characters to 
filter long lists of devices. Only those devices which match the entered characters are displayed.  
 
The Java Tool additionally offers the option to switch directly from the Assignment menu to the Definition 
menu to check specific settings for the CPU in question. 
 
 Use the right mouse button to select the desired CPU, and select Open CPU Device. 
 

 
Figure 115. Open CPU device in Assignment Virtual CPU Menu 
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Configuring Console Settings 
Console Device Settings 
New CON devices are created with this menu, including access rights and extender assignments. The menu 
can be accessed in the OSD and the Java Tool. 
 
The following settings can be modified. 
 

Field Selection Description 
ID Text ID of the CON Unit 

Priority 0-999 

Priority of the CON Device 
There is no keyboard/mouse sharing between CON Devices with different 
priorities, so release time does not apply. If a CON device with a higher 
priority is already connected to a CPU Device, the lower priority CON 
Device will have Video Only access. 

Name Text Name of the CON Device 

Show Macro List 
Y Show the macro list instead of the CPU selection list 

N Function not active (default) 

Allow User ACL 
Y Allow activation of the User Access Control List at the local console (see 

Access Control) 
N Function not active (default) 

Force Login 
Y 

Force user login at this CON device 
Note: Console ACL remains active. When a user is logged in, only the 
user favorites are accessible, not the CON favorites. 

N Function not active (default) 

LOS Frame 
Y 

•  When the video signal is lost between source and the CPU Unit, or the 
connection between matrix and the CON Unit is lost, an orange frame 
will be displayed. 
•  When switching to a CPU unit without a video signal, a blank screen 
will appear surrounded by an orange frame 

N Function not active (default) 

Disable OSD 
Y Disable OSD access for the CON Device 

N Function not active (default) 

CPU Colors Selection list The connected CPU Device name will be highlighted according to the 
color setting for text and background. Select between 16 colors.  

Virtual Device 
Y Automatically set for Virtual CON device 

N Function not active (default) 

Allow CPU Scan 
Y 

Allow scan mode, where the CON Device’s favorites list or a logged-in 
user’s favorites list, can be cycled through automatically at the CON 
Device 

N Function not active (default) 

Force CPU Scan 
Y 

Force continuous timed change of connection CPUs, using the CON 
Device’s favorites list or a logged-in user’s favorites list. 
Note: Active scanning can be stopped by a mouse or keyboard event. 
Full Access to the currently connected CPU device is granted if Force 
Connect is also active. 

N Function not active (default) 

Scan Time [sec] 0-99 seconds Length of time before scan mode switches to the next CPU in the list 
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Field Selection Description 

Port Mode 
Y 

The favorites list is replaced by a port list where ports from 1-999 can be 
directly selected at each matrix or Matrix grid. 
Note: This selection only applies to CPU Devices. CON and User favorites 
lists are deactivated when using Port Mode. 

N Function not active (default) 

Redundancy Off 
Y Do not automatically switch to the second link of a connected redundant 

CON Unit if the primary link to a CPU Unit is lost. 

N Switching to redundant links at link loss is active (default). 

Reference 
Y 

Make this device a reference CON Device that passes both Device and 
extender settings to any CON unit connecting to Orion FX for the first 
time. Only activate this setting for a single CON Device. 

N Function not active (default) 

Fix Color Selection list 
Show a colored frame on the video of a connected CPU device. Selection 
between 7 colors. The colored frame of the CPU device has priority over 
the colored frame of the CON device. 

 
Table 47. CON Device Settings 
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Setting up CON Devices through the OSD 
 Select Configuration in the main menu and log in. 
 Select CON Devices in the Configuration menu. 
 

 
 

Figure 116. Setting Up CON Devices through the OSD 

 

To create a CON Device, proceed as follows:  
1. Click the New R. button to create a new Real CON Device, or click the New V. button to create a new 

Virtual CON Device. (For a description on Real and Virtual Consoles, see Virtual Console). 

2. Enter a CON Device name into the field Name.  

3. Click the Okay button.  

The CON Device is created.  
 
To assign an EXT Unit to a CON Device, proceed as follows:  

1. Select the CON Device you want to assign to an EXT Unit.  

2. Select the EXT Unit for the assignment in the EXT available list.  

3. Click the Okay button.  

The CON Device is assigned to the EXT Unit. 
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Setting up CON Devices through the Java Tool 
 Select Extender & Devices > CON Devices in the task area. 
 

 
 

Figure 117. Setting Up CON Devices through the Java Tool 

 

Select between the following buttons: 
 

Button Function 

New Device Create a new CON Device 

Delete Device Delete a CON Device 

Apply Confirm a created CON Device 

Cancel Reject changes 
 Assign selected extender units 
 Assign all available extender units 
 Remove the selected extender units 
 Remove all extender units 

 
Table 48. Buttons in the Java Tool CON Devices Screen 
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The following keyboard commands can be used. 
 

Function Keyboard Command 

Change assignment number of the EXT unit upwards <+> 

Change assignment number of the EXT unit downwards <-> 
 

Table 49. Keyboard Commands in the Java Tool CON Devices Screen 

 

To create a new console, proceed as follows: 
1. Click the New Device button. 

2. In the pop-up menu, select Create a real Console, Create a virtual Console, or Choose template if 
an existing console should be used as a template. 
Note: A template can only be selected if there is at least one existing CON device. 

 

 
 

Figure 118. New CON Device Type 

 

3. Click the OK button. 

4. Make the appropriate parameter selections for the console. 

5. To confirm the creation of the new console, click the Apply button. 
 
One or more CON EXT Units must be assigned to the console device for it to access a CPU through the 
matrix. To make an extender assignment, proceed as follows. 

1. Select the console in the CON Devices list to be assigned an extender.  

2. Click the Extender Assignment tab, and select from the unassigned extenders in the Extender 
available list to assign to the CON Device. 

3. Perform the assignment by clicking the  button. To assign all available extenders to the console, click 
the  button. The assignments are displayed in the Extender assigned list. 

4. Confirm the assignment by clicking the Apply button. 
 
To remove an extender assignment, proceed as follows: 

1. Select the console to modify in the CON Devices list. 

2. Select the extender to be removed from assignment to the console in the Extender assigned list. 

3. Remove the assignment with the  button. To remove all existing assignments, click the  button. 

4. Confirm the removal with the Apply button. 
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To configure a console’s CPU access rights, proceed as follows: 
1. Select a console in the CON Devices list. 

2. Select the CPU Access Control tab. 

3. Assign access rights by using the right mouse button or the appropriate keyboard commands (see the 
table below). 

 
Figure 119. Assign CON Device Access Rights by Right Click 

4. Confirm the configuration by clicking the Apply button. 
 
The following keyboard commands can be used. 
 

Function Keyboard Command 

Add CPU to list Full Access <F> 
Add CPU to list Video Access <V> 
Add CPU to list No Access <N> 

 
Table 50. Keyboard Commands for CPU Access Assignment in Java Tool in CON Devices Menu 
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OSD Mouse and Keyboard Configuration 
Console mouse and keyboard behavior in the OSD menus is configured in this menu. These settings can be 
set separately for each console. This menu can be accessed in the OSD and the Java Tool. 
 
The following settings are available. 
 

Field Selection Description 

Horizontal mouse speed [1/x] 1 to 9 Adjustment of the horizontal mouse speed,  
1 = slow, 9 = fast (default value: 4) 

Vertical mouse speed [1/x] 1 to 9 Adjustment of the vertical mouse speed,  
1 = slow, 9 = fast (default value: 5) 

Double click time [ms] 100 to 800 
Set the maximum time between 2 mouse clicks for 
them to be recognized as a double click (default 
value: 200 ms) 

Keyboard Layout Region 
Set the keyboard layout used by the OSD to match 
that of the keyboard in use (English US, German, 
etc.). 

Video Mode Variable or specific 
resolution 

Display resolution used for the OSD 

Hot Key Keystroke Key that opens command mode 

Fast Key Keystroke Single Key that displays the OSD 
 

Table 51. Mouse and Keyboard Settings 

 

Note: A console’s Hot Key and Fast Key settings take precedence over Global Hot Key and Fast Key 
assignments. 
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Modifying OSD Mouse and Keyboard Settings with the OSD 
 Select Configuration in the main menu and log in. 
 Select EXT Units in the Configuration menu. 
 

 
 

Figure 120. Modifying OSD Mouse and Keyboard Settings through the OSD 

 

Select a Console extender and make the appropriate changes to the mouse and keyboard settings in the 
General OSD Data section. Then click one of the following buttons: 
 

Button Function 

Cancel Reject changes 

Okay Save changes 
 

Table 52. Buttons in the Console Extender OSD Mouse and Keyboard Settings Screen 
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Modifying OSD Mouse and Keyboard Settings through the Java Tool 
 Select Extender & Devices > EXT Units in the task area.  
 

 
 

Figure 121. Modifying Mouse and Keyboard Settings through the Java Tool 

 

1. Select an EXT unit with type CON. 

2. Click the General OSD Data tab. 

3. Make the appropriate changes to the mouse and keyboard settings. 

4. Click the Apply button to save the changes. 
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Console Extender OSD Settings 
Console Extender OSD properties can be adjusted here. These local settings apply to individual consoles. The 
menu can be accessed from the OSD and the Java Tool. The following Extender OSD settings can be 
modified. 
 

Field Selection Description 

Enable CPU Selection 
Y 

When the key sequence to open the OSD is entered, a CPU selection 
list will be displayed in the center of the screen. Pressing <F7> 
while the selection list is on the screen displays the Main OSD 
menu. 

N Function not active (default) 

Enable Connection Info 
Y Enable extender connection info OSD (default) 

N Function not active 

Update Connection Info 
Y Update connection changes during fade-in of Extender OSD 

(default) 

N Function not active 

Display Time [sec] 0-999 
seconds Duration of OSD fade-in (default: 10) 

Horizontal Position [10 px] 10 pixels Horizontal position of the OSD (default: -2) 

Vertical Position [10 px] 10 pixels Vertical position of the OSD (default: 2) 

OSD Position Presets Selection Preset locations for the connection information OSD on the Console 
display 

 
Table 53. Extender OSD Settings 

 

Note:  
■ When setting the Connection Info OSD horizontal position, a prefixed minus describes the location with 

respect to the right edge of the monitor, e.g. -2 means 2 x 10 = 20 pixels of distance to this edge. When 
setting a vertical position, a prefixed minus describes the location with respect to the bottom edge of the 
monitor. 

■ If Update Connection Info is deactivated, the Extender OSD only appears when switching via OSD. 
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Modifying Console Extender OSD Settings through the OSD 
 Select Configuration in the main menu and log in. 
 Select EXT Units in the Configuration menu. 
 

 
 

Figure 122. Modifying Extender OSD Settings through the OSD 

To change the Extender OSD settings, proceed as follows: 
1. Select the console extender in the EXT Units list for which OSD settings are to be modified. 

2. Confirm the selection by pressing the <Enter> key, and the console’s EXT Data will be enabled for 
editing. 

3. Make the desired modifications to the Extender OSD Data settings. 

4. Click the Okay button to confirm the changes. 
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Modifying Console Extender OSD Settings through the Java Tool 
 Select Extender & Devices > EXT Units in the task area. 
 

 
 

Figure 123. Modifying Extender OSD Settings through the Java Tool 

 

In order to change the Extender OSD settings, proceed as follows: 
1. Select the console extender in the EXT Units list for which Extender OSD settings are to be modified. 

2. Click the Extender OSD Data tab. 

3. Modify the desired settings and confirm by clicking the Apply button. 
 



 

  Orion FX Manual 130 
 

Console Favorites List 
Lists of up to 32 favorite CPUs can be created for each console. Switching to a CPU in the console favorites 
list is done by pressing the keyboard 'Hot Key' sequence followed by the number of the CPU in the list (1 to 
16). This menu can be accessed in the OSD and the Java Tool.  
 
Setting up Console Favorites through the OSD 
 Select Assignments in the main menu. 
 Select CON Favorites. 
 

 
 

Figure 124. Setting up Console Favorites through the OSD 

 

To create a list of favorites for the console in use, proceed as follows: 
1. Select a CPU from the CPU Devices list. Press the keyboard <a> key to move the selected CPU device 

to the CON favorites list. Press the <r> key to remove a selected CPU from the favorites list. Repeat the 
process to add more CPUs to the favorites list. 

2. The position of the CPU devices within the favorites list can be changed by selecting a CPU and 
pressing the <+> and <-> keys. 

3. Click the Okay button to save the settings. 
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Setting up Console Favorites with the Java Tool 
 Select Extender & Devices > CON Devices in the Task area, then select a console in the CON Devices 

list and click the Favorites tab to open it. 
 

 
 

Figure 125. Setting Up Console Favorites through the Java Tool 

 

To create a favorites list for any console, proceed as follows: 
1. Select CPU devices in the CPU Device available list to be added to the console favorites list (Favorite 

CPU Devices). Press and hold the <Ctrl> key to select more than one CPU device at a time. 

2. Click the  button to move the selected CPU devices to the favorites list. If the  button is pressed, the 
first 32 CPU devices in the CPU Device available list will be moved to the favorites list. 

3. The position of a selected CPU device within the favorites list can be changed by pressing the <+> and 
<-> keypad keys to move the selected CPU up or down in the list, or alternatively by clicking the up and 
down arrows to the right of the favorites list. 

4. To remove selected CPU devices from the favorites list, press the  button. If the  button is pressed, 
all CPU devices will be removed from the console favorites list. 

5. Click the Apply button to save the list. 
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Console Macros 
This menu is used to create console macro commands for switching, disconnecting or user administration. 
Console macro commands are created for each console separately. A single macro can execute up to 16 
successive switching commands. Console macros are invoked by typing the keyboard 'Hot Key' sequence, 
followed by the function key assigned to the macro, <F1>-<F16>. It can be accessed in the OSD and the Java 
Tool. The following functions can be used in console macros. The Macros can also be used to switch to CPU 
groups. 
 

Field Selection Description 

Function 
(01-16) 

Connect  
(P1=CON, P2=CPU) 

Make a full keyboard, mouse, and video connection from console P1 
to CPU P2 

Connect Video  
(P1=CON, P2= CPU) 

Make a video connection from console P1 to CPU P2 

Disconnect  
(P1=CON) 

Disconnect console P1 

Logout User Logout current user 

Assign CPU  
(P1=VCPU, P2=RCPU) 

Assign a virtual CPU device to a real CPU device (see Virtual CPU) 

Assign CON  
(P1=RCON, P2=VCON) 

Assign a real CON device to a virtual CON device (see Virtual 
Console) 

Push  
(P1=CON) 

The console’s current full KVM connection is forwarded to console P1 
and the console’s connection is changed to video only. 

Push Video  
(P1=CON) 

The video signal of the console’s current connection (KVM or video 
only) is forwarded to console P1. The console’s connection remains 
unchanged (KVM or video only). 

Get  
(P1=CON) 

The console gets a KVM connection to the CPU that is currently 
connected to console P1. The connection of console P1 is changed to 
a video only connection. 

Get Video  
(P1=CON) 

The console gets a video only connection to the CPU that is 
currently connected to console P1. The connection of console P1 
remains unchanged (KVM or video only). 

Login User  
(P1= User, P2= CON) Login User P1 at console P2  

 
Table 54. Console Macro Settings 
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Setting up Console Macros through the OSD 
 Select Configuration in the main menu and log in. 
 Select CON Macros. 
 

 
 

Figure 126. Setting Up Console Macros through the OSD 

 

To create a macro for a console, proceed as follows: 
1. Select a console in the CON devices list. 

2. Select a keyboard function key (F1 to F16, or Shift-F1 to Shift-F16) in the Key field to be used with the 
hot key sequence to invoke the macro. 

3. Select the position in the macro list (1-16) where the macro command is to be inserted. 

4. Click the Edit button to activate the Function field, and select the desired function by pressing the 
keyboard up or down arrow keys. 

5. Press the Tab key to select the appropriate parameters P1 and P2 (e.g. CON Devices or CPU Devices) 
for the selected macro command. 

6. Pressing the keyboard <Enter> key will confirm the current command and add it to the macro list.  
Repeat the process to add additional commands to the macro as necessary. 

 



 

  Orion FX Manual 134 
 

Setting up Console Macros through the Java Tool 
 Select Extender & Devices > CON Devices in the Task area, then select a console in the CON Devices 

list and click the Macros tab. 
 

 
 

Figure 127. Setting up Console Macros through the Java Tool 

 

To create a macro for the selected console, proceed as follows: 
1. Select a keyboard function key (F1 to F16, and Shift + F1 to F16) in the Key field to be used to invoke 

the macro.  

2. In the Function column, select the action that should be part of the macro. The selection list is opened 
by a double click on an empty field. 

3. Select in the P1 and P2 columns the appropriate parameters for the macro function (e.g. consoles and 
CPUs). 

4. Confirm the inputs by clicking the Apply button. 
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For convenient macro configuration, the following context functions are available: 
 
To assign a console’s macros to other consoles: 

1. Click on the console, then click the Assign Settings to… button (located below the CON devices list).  
 

 
 

Figure 128. Assign Settings Menu in the Java Tool 
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2. Select Macros from the pop-up list of settings, and then click Next.  
 

 
 

Figure 129. Select CON Device to Receive Assigned Settings in the Java Tool 

 

3. Select the consoles to receive the macros from the list of available consoles and click the  button to 
add those consoles to the Assign settings to… list.  

4. Click Finish to complete the macro assignments.  
 
The Copy Settings from... button functions similarly, except the console to receive macros is selected first. 
 
All the macro commands of a selected key can be copied into the cache by clicking the Copy Key Macros icon 
located below the P1 column. These macros can then be pasted into a different key by selecting the key and 
clicking the Paste Key Macros icon. All macros of a selected key can be removed by clicking the Delete Key 
Macros icon. 
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Virtual Console 
Orion FX allows assigning real consoles to virtual consoles. The process of setting and changing access 
permissions can be simplified by changing the permissions of a virtual console, and then applying them to all 
real consoles assigned to the virtual console. Virtual consoles can be switched in exactly the same way as real 
consoles. If a virtual console is switched to a CPU, all real consoles assigned to the virtual console will receive 
the video signal. The last real console assigned to a virtual console will also have keyboard and mouse control.  
 
This menu is available in the OSD and the Java Tool. 
 
Assignment of Virtual Consoles through the OSD 
 Select Assignments > Virtual CON devices in the main menu. 
 

 
 

Figure 130. Virtual CON Devices Assignment through the OSD 
 

To make an assignment, proceed as follows:  
1. Select the real console in the Real Devices list that is to be assigned to a virtual console.  

2. Click the Edit button.  

3. Select the virtual console in the Virtual Devices list that is to be assigned to the selected real console.  

4. Click the Okay button to confirm the assignment.  
 
A virtual console can be assigned to more than one real console. 
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Assignment of Virtual Consoles through Java Tool 
 Select Assignment > Virtual CON Devices in the task area.  
 

 
 

Figure 131. Virtual to Real Console Assignment through Java Tool 

 

To make an assignment, proceed as follows:  
1. Select the desired real console in the Real Console table.  

2. Double click in the Virtual Console column to get a list of all available virtual consoles.  

3. Select the desired virtual console.  
 
Select between the following buttons: 
 

Button Function 

Send Send assignments to the matrix 

Reload Reload changes 
 

Table 55. Java Tool Virtual CON Assignment Screen Buttons 
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When the Auto Send function in the left lower corner of the working area is ticked, switching operations will be 
done immediately without confirmation by pressing the Send button.  
 
There is a blank field just above the Real Console and Virtual Console, which can be used to enter characters 
to filter long lists of devices. Only those consoles whose names or ID numbers match the entered characters 
are displayed. 
 
Shared Operation 
This menu enables shared operation of a CPU Device by two or more CON Devices. A CPU Device can be 
controlled by only one CON Device at a time but control can be taken over by other CON Devices. Control of a 
CPU Unit by a CON Unit is relinquished after the expiration of an inactivity timer associated with the controlling 
CON Device. The mouse or keyboard may also be used to take control. 
 
In order to allow a smooth and accurate function of the shared operation, you should use identical mice and 
keyboards. They should be connected to the same USB-HID ports of each CON Unit. 
 
If the Release Time value is set to less than 10 seconds, and if control transfer takes place in less than 10 
seconds, any assigned USB 2.0 / 3.0 extenders will not be switched due to security and stability 
considerations. Shared operation will be not be active between CON Devices with a different priority.  
 
The Shared Operation menu can be accessed in the OSD and the Java Tool. 
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Setting up Shared Operation with the OSD 
 Select Configuration in the main menu and log in. 
 Select Switch. 
 

 
 

Figure 132. Enabling Shared Operation with the OSD 

 
1. Activate the Enable Video Sharing function. 

2. Activate the Force Connect function. 

3. Activate the Keyboard Connect function, if taking over control by a keyboard event should be possible. 

4. Activate the Mouse Connect function, if taking over control by a mouse movement should be possible. 

5. Define a Release Time of inactivity (0 - 999 sec.) after which control can be taken over. 
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Setting up Shared Operation with the Java Tool 
 Select System Settings > Switch in the task area. 
 

 
 

Figure 133. Enabling Shared Operation with the Java Tool 

 

1. Activate the Enable Video Sharing function. 

2. Activate the Force Connect function. 

3. Activate the Keyboard Connect function, if taking over control by a keyboard event should be possible. 

4. Activate the Mouse Connect function, if taking over control by a mouse movement should be possible. 

5. Define a Release Time of inactivity (0 - 999 sec.) after which control can be taken over. 

6. Click the Apply button to confirm the changes. 
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Multi-Screen Control 
Multi-screen control allows a CON device to switch between up to eight computer sources using a single 
connected mouse and/or keyboard. The CON device can consist of up to eight CON units (eight monitors), or 
up to sixteen monitors when using Dual-head extender modules. The Extender Units assigned to the 
multi-display CON Device must be physically connected to the same block of eight ports on a matrix I/O board. 
 
Note: When configuring Multi-Screen Control via OSD, the number of supported monitors is limited to four. For 
this reason, it is recommended to configure Multi-Screen control with the Java Tool software. 
 
Typically, one of the CON Devices in the multi-screen group is designated “Control CON Device”, which means 
it has USB-HID keyboard and mouse control of the connected sources. The Control Device performs smooth 
switching between sources with the mouse by dragging the mouse pointer beyond the edge of the currently 
active display. The displays can be arranged side by side, in a grid layout, or completely freely. Switching can 
also be performed by Control Device keyboard commands. 
 
Note: Sources to be used in a Multi-Screen configuration should support absolute mouse mode. 
 
When using multi-head sources (e.g. dual-head), the necessary extended configuration must be set up with the 
Java Tool. Multi-Head configuration for Apple Mac sources is not supported.  
 
CON Units that have been already configured for Multi-Screen Control can be connected together to other 
blocks of up to 8 ports. In this case, any further configuration is not necessary; their functionality will remain as 
set previously. 
 
If a CON Unit with the ability to connect a local source (computer, CPU) is configured for Multi-Screen control, 
switching to the local source will be disabled. 
 
Configuring Multi-Screen Control through the OSD (for Single-Head Applications) 
The following parameters can be configured through the OSD menu: 
 

Field Selection Description 

Enabled 
Y Activate the display for multi-screen control 

N Function not active (default) 

Control 
Y Enable the CON device to have USB-HID control of other CON 

devices in the Multi-Screen group 

N Function not active 

Owner Selection 

•   Shared (default) permits a Control device’s keyboard and mouse   
to access this device. 

•   The device’s own name instead of Shared restricts access by 
other devices in the group. 

Frame 0-999 seconds Time to fade-in a red frame on the display currently controlled by 
keyboard and mouse 

 
Table 56. Multi-Screen Parameters in the OSD 
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To configure Multi-Screen Control using the OSD, proceed as follows: 

1. Open the OSD of a CON unit connected to an I/O board where the connected CON units are to be 
configured for Multi-Screen Control. Choose the CON unit which will be used as the Control Device. 

2. Select Assignments > Multi-Screen Control in the main menu and log in. Only the CON EXT units 
connected to the selected I/O board will be visible. 

 

 
 

Figure 134. Setting Up Multi-Screen Control with the OSD 
 

3. In the Arrangement field, select layout for the CON Device, 1 x 4 or 2 x 2. The fields for the 
configuration of the individual displays will be arranged accordingly. 

4. Activate the Manual option if USB-HID switching is to be restricted to keyboard commands. For more 
information, see Operations section, Multi-Screen Control.  

5. Ensure that the Enabled option is set to Y on all displays to be included in Multi-Screen Control.  

6. Set the Control function to Y on one or more CON devices to be enabled as Control CON device. 
These extender units have the ability to control the connected computers. 

7. The Owner function is used to designate a control display whose keyboard and mouse will be used to 
switch between the sources. By default, the function is shared between the Control displays. To restrict 
the Owner function to a single Control display, click the Owner field and select the name of the desired 
Control CON Device.  

8. Use the Frame function to configure a red frame that shows the video on the current display with 
mouse control after the expiration of a selectable timer. The frame to fade in can be individually 
activated by using a timer value greater than 0 seconds. 
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Access Restriction when using Multiple Control CON Devices  

Switching by dragging the mouse pointer past the edge of a display is only permitted with those CON devices 
that are enabled for access by a Control Device of the Multi-Screen group. To enable access to a display by a 
single Control CON Device, proceed as follows: 

1. Click the Owner field of a Control CON Device and select the name of that Control CON Device from 
the list. 

2. Click the Owner field of the other CON Devices and select the name of the Control CON Device. 
 

Access to the other Con devices is now limited to the selected Control Device. 
 
No simultaneous USB HID sharing by multiple Control CON devices 

When more than one CON unit in a Multi-Screen group is designated a Control device, there is no 
simultaneous sharing of other devices in the group. For example:  In a Multi-Screen setup of 4 CON Devices, 
Devices 1 and 2 are each designated Control CON Devices. Both Devices 3 and 4 are configured 
Owner = Sharing. Devices 1 and 2 can access the displays of Devices 3 and 4, but they cannot have 
keyboard and mouse control of the same device at the same time. The keyboard and mouse of the Control 
CON Device that first had USB-HID control will be returned to its "own" display when the second Control CON 
Device takes over.  
 
Changing Multi-Screen Control 

To modify the Multi-Screen setup of a specific I/O board, proceed as follows: 
1. Open the OSD of a Control CON Device on the I/O board.  

2. Select Assignments > Multi-Screen Control in the main menu. Only the CON EXT Units connected 
to the selected I/O board are visible.  

3. Make any required edits of the Multi-Screen configuration.  

4. Click the Okay button to confirm the changes.  
 
Deleting Multi-Screen Control  

To delete the Multi-Screen Control for a setup of a specific I/O board, proceed as follows:  
1. Open the OSD of a Control CON Device of the specific I/O board.  

2. Select Assignments > Multi-Screen Control in the main menu. Only the CON EXT Units connected 
to the selected I/O board are visible. 

3. Set the Enable option to N on all CON Devices. 

4. Click the Okay button to confirm the changes. Multi-Screen Control is disabled for all CON Devices on 
the I/O board. 
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Configuring Multi-Screen Control with the Java Tool 
The following parameters can be configured with the Java Tool software: 
 

Field Selection Description 

Dual-Head Extender 
Y Enable configuration of 2 displays for this Dual-Head extender 

N Function not active (default) 

Enabled 
Y Activate the display for multi-screen control 

N Function not active (default) 

Control 
Y Enable the CON device to have USB-HID control of other CON 

devices in the Multi-Screen group 

N Function not active 

Owner Selection 

•   Shared (default) permits a Control device’s keyboard and mouse   
to access this device. 

•   The device’s own name instead of Shared restricts access by 
other devices in the group. 

Frame 0-999 seconds 

Set the keyboard/mouse inactivity timer after which a red frame is 
faded in at the display with current mouse/keyboard control. This 
frame remains active for a fixed period of time and disappears 
thereafter. 

 
Table 57. Setting Up Multi-Screen Control with the Java Tool 

To configure Multi-Screen Control using the Java Tool software, proceed as follows: 
 Select Assignment > Multi-Screen Control in the task area. 
 

 
 

Figure 135. Setting Up Multi-Screen Control with  the Java Tool 

 



 

  Orion FX Manual 146 
 

1. Select the block of four or eight ports in the working area list that are to be configured for Multi-Screen 
Control. Only blocks of four or eight ports that contain at least one CON Unit are shown.  

2. Activate the Manual option if USB-HID switching should be restricted to keyboard commands. Manual 
switching allows the use of multi-head consoles. For more information, see Operations section, Multi-
Screen Control.  

3. Select the desired layout for the CON Devices being configured in the Arrangement field.  

 Horizontal: for a maximum of four CON units 

 Block: for a maximum of four CON units 

 Free: for a maximum of eight CON units. Free allows flexible positioning of displays. To configure 
more than four CON Devices for Multi-Screen Control, the free layout must be used. Selecting Free 
will cause an Available Screens field to be displayed. Move the displays icons to the Arrangement 
field and position them as desired. 

4. If a CON unit should be configured as a Dual-Head extender, click the Dual-Head Extender checkbox 
to activate the option. 

5. Click the Enable checkbox of each CON Device to activate it in the Multi-Screen configuration. 

6. Select one or more control displays within the CON Devices by clicking its Control checkbox function. 
These extenders have a keyboard and mouse connected, and have the ability to control the Multi-
Screen setup by switching the keyboard and mouse from one CON unit to the next. 

7. The Owner function is used to designate whether a CON unit can be accessed by a Control Device. To 
make a CON Unit’s display accessible to control displays in the group, set the Owner function to 
shared. To prevent access to the CON device by Control devices, select the unit’s name instead of 
shared. 

8. Use the Frame function to configure a red frame that shows the current display with mouse control after 
the expiration of a selectable timer. The frame can be individually activated by using a timer value 
greater than 0 seconds. 

9. Click the Apply button to confirm the Multi-Screen Control group. 
 
Access Restriction when using Multiple Control CON Devices  

Switching by dragging the mouse pointer past the edge of a display is only permitted with those CON devices 
that are enabled for access by a Control Device of the Multi-Screen group. To enable access to a display for a 
single Control CON Device, proceed as follows: 

1. Click the Owner field of a Control CON Device and select the name of that Control CON Device from 
the list. 

2. Click the Owner field of the other CON Devices and select the name of the Control CON Device from 
step 1. 

 

The selected Control Device’s mouse can now be used to access the other displays. 
 
No simultaneous USB HID sharing by multiple Control CON devices 

When more than one CON unit in a Multi-Screen group is designated a Control device, there is no 
simultaneous sharing of other devices in the group. For example: In a Multi-Screen setup of 4 CON Devices, 
Devices 1 and 2 are each designated Control CON Devices. Both Devices 3 and 4 are configured 
Owner = Sharing. Devices 1 and 2 can access the displays of Devices 3 and 4, but they cannot have 
keyboard and mouse control of the same device at the same time. The keyboard and mouse of the Control 
CON Device that first had USB-HID control will be returned to its "own" display when the second Control CON 
Device takes over.  



 

  Orion FX Manual 147 
 

Changing Multi-Screen Control 

Changes to Multi-Screen Control configuration are permitted only the if the keyboard and mouse of the Control 
Device are switched to the Control Device’s own display. To modify the Multi-Screen setup of a specific I/O 
board, proceed as follows: 

1. Switch keyboard and mouse control to the Control CON Device. 

2. Select Assignments > Multi-Screen Control in the main menu, and click the Activate Edit Mode 
menu item in the toolbar. 

3. Select the Multi-Screen Control group to be modified in the Screens field of the Working area.  

4. Make any required edits to the Multi-Screen configuration.  

5. Click the Apply button to confirm the changes.  
 
Deleting Multi-Screen Control  

Changes to Multi-Screen Control configuration are permitted only the if the keyboard and mouse of the Control 
Device are switched to the Control Device’s own display. To delete the Multi-Screen Control for a setup of a 
specific I/O board, proceed as follows:  

1. Switch keyboard and mouse control to the Control CON Device. 

2. Select Assignments > Multi-Screen Control in the main menu, and click the Activate Edit Mode 
menu item in the toolbar. 

3. Select the Multi-Screen Control group to be modified in the Screens field of the Working area. 

4. Click the Enable checkboxes of all the CON devices in the group to remove the checkmarks. 

5. Click the Control checkbox of any unit designated as a Control CON Device to remove the checkmark. 

6. Click the Apply button to confirm the changes. Multi-Screen Control is disabled for all CON Devices in 
the grouping. 
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Extended Configuration for Multi-Head Multi-Screen Control with the Java Tool 
For the use of Multi-Head computer sources in Multi-Screen applications, an additional configuration of the 
CPU Devices is required.  
 
 Select Extender & Devices > CPU Devices in the task area. 
 

 
 

Figure 136. Multi-Head Multi-Screen Configuration with the Java Tool 

 

1. Select the CPU Device to be configured and open the Monitor Arrangement tab. Configuration of 
CPU devices connected to Single-Head sources is not required. 

2. Enter the resolution of the total desktop area in the Width and Height fields of Total Desktop 
Resolution. For example, if there are 4 video source outputs with a resolution of 1920x1080 each, 
enter 7680 as Width and 1080 as Height. 

3. Select the individual resolution of the graphic card output from the selection list in the Resolution 1 
field (for example, 1920x1080). This is the video output of the source to which the CPU Device is 
connected. 

4. Enter the pixel coordinates of the CPU device in the Multi-Screen arrangement in the Offset X and 
Offset Y fields. For instance, enter 1920 into Offset X to shift the output in the Multi-Screen 
arrangement 1920 pixels to the right. The CPU device icon will be positioned accordingly in the grid. 

If the CPU Device is a Dual-Head extender, click the Dual-Head Extender checkbox. Then enter the 
resolution of the second graphic card output and the offset information in the Resolution 2 field, and 
the Offset X and Offset Y fields. 
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5. For some operating systems the Multiplier checkbox must be ticked if the mouse cursor does not 
reach all areas of the desktop. 

6. Click the Apply button to save the changes. A pop-up menu will prompt to restart the extender, which is 
mandatory. 

 

The Multi-head CPU device is now configured for use in a Multi-screen application. 
 
Saving and Loading of Configurations 
The menus described in this section provide a variety of ways to save and recall configurations, whether 
currently active configurations, internally stored configurations, or configurations saved on media external to 
the Orion FX equipment. 
 
There are two ways to save configuration changes internally: 

1. Save as the active configuration in Orion FX memory. 

2. Save in one of eight predefined storage locations in Orion FX memory. These can be loaded as the 
active configuration when required. 

 

Saving the Current Configuration to the Orion FX 
This menu can be accessed in the OSD and the Java Tool. 
 

 To save the Configuration with the OSD, select Configuration in the Main menu, log in, and select Save. 
 

d  
Figure 137. Configuration Save in the OSD 
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By selecting this menu item, the admin user can save the active configuration of the Orion FX to its non-volatile 
memory. By default, the last configuration saved in this way is restored as the active configuration after a 
restart of the matrix.  
 

Note: Changing or saving configurations will block the matrix memory briefly, resulting in a freeze of all OSD 
menus for a few seconds. The connections between consoles and CPUs are not affected.  
 

If Auto Save is activated in the Configuration > System settings, and if there are changes to the configuration 
or switching operations, the configuration will be saved every 10 minutes. 
 
To save the current configuration with the Java tool: 

1. Click the Remote Save menu item in the toolbar. 

  
 

Figure 138. Remote Save in the Java Tool 

2. When a prompt to confirm saving the configuration appears, click the Yes button. The previous Active 
Configuration is overwritten. 

 
 

Figure 139. Remote Save Configuration Prompt in the Java Tool 
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Saving the Configuration in a specific internal location 
This menu allows storing the active configuration in a specific internal location. This does not replace the 
Active Configuration saved in the method described above, unless you choose the Default location. The menu 
can be accessed from the OSD and the Java Tool. 
 
Saving the Configuration to a Specific Storage using the OSD 
It is possible to save the current configuration in one of eight storage locations in the Orion FX (File #1 to 
File #8), as well as in the Default location (loaded each time the matrix restarts). Active shows the current 
configuration’s name and information. Default and File #1 to File #8 show the name and information records of 
previously saved configurations. Each of these storage locations can be overwritten.  

1. Select Configuration in the Main menu and log in. 

2. Select Save As... 
3. Select the desired storage location (File #1 - File #8) or Default. 
4. Save the configuration by pressing the keyboard <Enter> key. 

 

The current configuration is saved to the storage location, and the configuration previously saved at that 
location is overwritten. 
 

 
 

Figure 140. Saving Configuration to Internal Storage Locations with the OSD 

Note: To give the configuration a name and description before saving, see Modifying System Settings through 
the OSD. 
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Saving the Configuration to a Specific Location using the Java Tool 
To save the current configuration in the internal memory, proceed as follows: 

1. Select File > Upload in the menu bar. 

2. Enter the IP address of the Orion FX, your user name and password and confirm the inputs with the 
Next button. 

 

 
 

Figure 141. Saving Configuration to Internal Storage with the Java Tool 
 

3. Select the storage location in which the configuration is to be saved (Default, or File #1 – File #8) and 
confirm with the Finish button. 

 

+  
 

Figure 142. Select a Configuration Internal Storage Location with the Java Tool 
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Loading Configurations from Internal Memory 
In this menu, configurations previously saved to internal memory are loaded to become the active 
configuration. This menu can be accessed from the OSD and the Java Tool. 
 
Loading a Configuration from Internal Memory with the OSD 
 

 
 

Figure 143. Loading Internal Configuration through the OSD 

 

Active shows the current configuration’s name. In addition to the default configuration, one of eight other 
configurations can be loaded.  
 
To load the configuration from the Orion FX internal memory, proceed as follows: 

1. Select Configuration in the Main menu and log in. 

2. Select Open. 

3. Select the desired configuration. 

4. Load the configuration by clicking the Okay button. 
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Loading a Configuration from Internal Memory with the Java Tool 

 
 

Figure 144. Loading Internal Configuration through the Java Tool 
 

To load a saved configuration from Orion FX internal memory, proceed as follows: 
1. Select Status & Updates > Activate Configuration in the task area. Be sure Edit Mode is active. 

2. Select the required configuration. 

3. Load the configuration by clicking the Activate button. 

 
 

Figure 145. Prompt to Activate Loaded Configuration 

4. A query to restart the Orion FX will be displayed. Click the Yes button. The connection to Orion FX will 
be disconnected and the Orion FX will restart with the selected configuration loaded and shown as the 
Active Configuration. 
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Saving of Configurations (External) 
Configurations can also be saved as files which are stored outside of the matrix. This menu can only be 
accessed from the Java Tool. 
 

 
 

Figure 146. Saving External Configuration through the Java Tool 

 

To save the active configuration as an external configuration file, proceed as follows: 
1. Select File > Save As in the menu bar. 

2. Select the directory in the Java Tool computer where the configuration file is to be saved. 

3. Enter a file name for the configuration. 

4. Click the Save button. 
 
Configurations files have the extension “dtc”. 
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Loading of Configurations (external) 
Externally saved configuration files are opened and activated in this menu. This menu can only be accessed in 
the Java Tool. 
 

 
 

Figure 147. Loading external configuration through the Java Tool 

 

To load an external configuration file, proceed as follows: 
1. Select File > Open… when Edit Mode is not active, and select the storage location and configuration 

file that is to be opened. 

2. Open the configuration by clicking the Open button. 
 



 

  Orion FX Manual 157 
 

3. Select File > Upload in the menu bar to transfer the opened configuration to the matrix. Enter Orion FX 
IP address, the admin login name and password, and click the Next button. 

 

 
 

Figure 148. File Upload of Externally Saved Configuration in the Java Tool 
 

4. Select the Configuration Slot to store the configuration.  
 

 
 

Figure 149. Selecting a Slot to Store the Externally Saved Configuration in the Java Tool 
 

5. To make the configuration active after the upload, click the check box (Orion FX will restart). 

6. Click the Finish button. 
 

.  
 

Figure 150. Completed Loading of Externally Stored Configuration in the Java Tool 
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Export and Import Options 
The Orion FX offers the option to export configuration lists (extender, CPUs, consoles and users) and import 
them again with the Java Tool. Exported configuration lists are always saved as files with the .csv extension, for 
ease of offline editing with common spreadsheet applications. 
 
Export Options 
To export a configuration list, proceed as follows: 

1. Select File > Export in the menu bar. 

2. Select the list to export and click the Next button. 
 

x  
 

Figure 151. Exporting Configuration Lists in the Java Tool 

3. Select the storage location and enter a name for the export file. 
 

 
 

Figure 152. Configuration List File Name and Storage Location in the Java Tool 

4. Confirm the export by clicking the Finish button. 
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Import Options 
Configuration lists con be imported into inactive configurations with this Java menu. Importing configuration 
lists is only possible when an external configuration file (.dtc) has been opened. 
 
To import a configuration list, proceed as follows: 

1. Select File > Import in the menu bar of an offline configuration. 

2. Select the type of list to import and click the Next button. 
 

 
 

Figure 153. Importing a Configuration List in the Java Too 

3. Select the directory and Configuration list file to import. 
 

 
 

Figure 154. Importing Configuration Lists through the Java Tool 

4. Confirm the import by clicking the Finish button. 
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Matrix Cascading 
Cascading allows a switchable connection to be established between two Orion FX switches through Tie 
Lines. This kind of configuration may be useful when the number of ports in the entire system needs to be 
increased, or when important connections should be distributed to several Orion FX switches for redundancy. 
 
Tie Lines are unidirectional and can only be used in one direction according to their configuration. For 
cascading with bidirectional signal flows, two Tie Lines have to be set up in opposite directions. To use Tie 
Lines between Orion FX switches, Cascade CON and Cascade CPU devices must be created for switching 
within the cascaded environment. 
 
Matrix Cascading can be configured with the OSD or the Java Tool. 
 
Setting Up Matrix Cascading through the OSD 

1. Select an Orion FX to be the Master Matrix. All other connected matrix switches will be configured as 
Sub Matrices in the configuration process. Tie Lines must not be connected until the configuration 
process is completed. 

2. Open the OSD of the Master Matrix, select Configuration in the Main menu and log in. 

3. Select EXT Units. 
 

 
 

Figure 155. Setting Up Matrix Cascading Through the OSD 

4. Click the New button. A new Extender Unit to be connected to Tie Lines will be created. 

5. Enter an appropriate extender name in the Name field. 

6. Enter a port number in the Port field based on where the Tie Line is to be connected. 



 

  Orion FX Manual 161 
 

7. If the Tie Line’s direction is to be from the Sub Matrix to the Master Matrix, set the Cascade-CON 
option to Y (C#1) in the Input Signals column. If the Tie Line’s direction is to be from the Master Matrix 
to the Sub Matrix, set the Cascade-CPU option to Y (C#1) in the Output Signals column.  

8. Save the settings by pressing the Okay button. 

9. If a Master/Sub CON Unit was created, select Configuration > CON Devices in the main menu of the 
master matrix and press the New R. button. A switchable CON Device will be created. 

10. If a Master/Sub CPU Unit was created, select Configuration > CPU Devices in the main menu of the 
master matrix and press the New R. button. A switchable CPU Device will be created. 

11. Enter an appropriate Device name in the Name field. 

12. Assign the previously configured Extender Unit to the newly created Device by moving the Extender 
Unit from the Ext available field to the Ext assigned field and save the settings. 

13. Select Configuration > EXT Units in the main menu of the Sub matrix, and repeat steps 2 to 12 for the 
Sub Matrix. 

14. Select Configuration > System in the main menu of the Sub Matrix and set the Sub Matrix option to 
Y. The OSD of the Sub Matrix will immediately freeze and will be only accessible by using the keyboard 
command <'Hot Key'>, <s>, <o>. 

15. Restart all I/O boards on which any Cascade CON or CPU Units have been configured, or alternatively 
restart the Orion FX switches. 

16. Connect the Tie Lines to the matrix switches. Ensure that each Cascade CON on one matrix is 
connected to the Cascade CPU on the other matrix to be able to switch between the two Orion FX 
units.  

 
The Matrix Cascading is now configured and ready be used. Additional Tie Lines can be configured as needed.  
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Setting Up Matrix Cascading through the Java Tool 
 

 
 

Figure 156. Setting Up Matrix Cascading Through the Java Tool 

 

1. Connect to the Master Matrix and then select Activate Edit Mode. 

2. Select Extender & Devices > EXT Units in the task area. 

3. Click the New Unit button. This opens a pop-up selection window. 
 

 
 

Figure 157. Creating New Cascade Units with the Java Tool 
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4. If the Tie Line should be directed from the Sub Matrix to the Master Matrix, select Cascading CON 
Unit in the selection box. If the Tie Line should be directed from the Sub Matrix to the Master Matrix, 
select Cascading CPU Unit in the selection box. 

5. Enter an appropriate extender name in the Name field. 

6. Enter the port number where the Tie Line is to be connected into the Port field. 

7. Confirm the settings by clicking the Apply button.  

8. If a Cascading CON Unit was created, select Extender & Devices > CON Devices in the task area of 
the master matrix and click the New Device button. A switchable CON Device will be created. 

9. If a Cascading CPU Unit was created, select Extender & Devices > CPU Devices in the task area of 
the Master Matrix and press the New Device button. A switchable CPU Device will be created. 

10. Enter an appropriate name for the extender into the Name field. 

11. Assign the previously configured Extender Unit to the newly created Device by moving the Unit’s 
definition from the Extender available field to the Extender assigned field, and save the settings by 
clicking the Apply button. 

12. Connect to the Sub Matrix and select Activate Edit Mode. Repeat steps 2 to 11.  

13. Select System Settings > System in the task area of the Sub Matrix and activate the Sub Matrix 
option. The OSD of the Sub Matrix will be only accessible by using the keyboard command <'Hot Key'>, 
<s>, <o>. 

14. Restart all I/O boards on which any Cascading CON or CPU Units have been configured, or 
alternatively restart the matrix switches. 

15. Now connect the Tie Lines to the matrix ports. Ensure that each Cascade CON on one matrix is 
connected to a Cascade CPU on the other matrix to enable switching between the two switches. 

 
The Matrix Cascading is now configured and can be used. Additional Tie Lines can be configured as needed.  
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Matrix Grid 
This menu is used to configure a Matrix Grid connecting two or more Orion FX switches. This may be 
necessary if the total number of ports in the entire system needs to be increased, or if connections to important 
equipment should be distributed among several Orion FX switches for redundancy. 
 
The connections between two matrix switches are established through Grid Lines that are connected between 
particular I/O ports. The Grid Lines are bi-directional, and each can handle a full access connection of a CON 
Device to a CPU Device. 
 
The number of Grid Lines in the system determines whether a CON Device can be switched to a CPU Device 
with Non-Blocking Access or with Blocking Access. This has to be determined for each Grid environment. 
Non-Blocking Access means that a Grid Line for cross-matrix switching of a CON Device to a CPU Device is 
available at any time. Blocking Access means that for a specific switching operation, no Grid Line may be 
available due to the current connection status within the Grid. In that case, cross-matrix switching may not be 
possible. 
 
Matrix Grids can be configured through the OSD or the Java Tool. 
 
Administration of Settings 
Within a Matrix Grid, some settings are made locally to each Orion FX switch, and others are global settings 
that apply to the whole Matrix Grid.  
 
These settings have to be made separately for each matrix (local settings), or within the master matrix (the 
Grid Master) to affect all matrix switches in the Grid (global setting): System, Access, Switch, Network, Date 
+ Time, SNMP, Matrix Grid, Multi-Screen Control. 
 
These settings have to be made once globally within the Matrix Grid: EXT Units, CPU Devices, CON 
Devices, User, CON Macros, User Macros, CON Favorites, User Favorites, Virtual CPU Devices, Virtual 
CON Devices. Global settings made in these menus will be immediately available on each matrix within the 
Matrix Grid. 
 
General Preparation 
The following conditions must be met before starting the Matrix Grid configuration: 

1. Firmware Revision V04.00 or later must be installed on all matrix switches that are to be connected to 
the Grid. 

2. All matrix switches to be connected to the Grid must be within the same TCP/IP network. 

3. Port 5556, which is needed for network communication, must not be blocked by a firewall. 
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Setting Up a Matrix Grid through the OSD 
In order to configure a Matrix Grid, proceed as follows. The following configuration steps have to be repeated 
for each Orion FX in the grid separately. 
 

1. Select Configuration in the Main menu and log in. 

2. Select System. 
 

 
 

Figure 158. Setting Up a Matrix Grid through the OSD - Step 1 

 

3. Enter a unique name for each Matrix switch into the Device field. No two matrix switches within the 
Matrix Grid can use the same name. 

4. Enter a unique Grid name into the Name field. The Grid name must be the same on all Orion FX units 
in the Grid.  

5. Confirm these name choices by clicking the Okay button. 
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6. Select Matrix Grid in the Configuration menu. 
 

 
 

Figure 159. Setting Up a Matrix Grid through the OSD - Step 2 

7. Activate the Enable Matrix Grid function. 

8. Enter the device names of each Orion FX in the Grid into the Matrix Grid list, starting in the left column. 
A Grid Master will be automatically selected for the Matrix Grid. The closer a matrix is to the top of the 
list, the more likely it is to be considered in the selection process, if certain criteria like system 
availability are met. 

9. Activate each matrix in the Matrix Grid list by changing its setting in the Active column to Y. 

10. Enter the number of chassis ports for each matrix (16, 24, 32, 40, 48, 64, 80, 120, 128, 144, or 160). 

11. Select Okay to confirm, and restart all Orion Matrix switches, beginning with the master Switch. 
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Setting Up a Matrix Grid through the Java Tool 

1. Select System Settings > Matrix Grid in the Task area.  
 

 
 

Figure 160. Setting Up a Matrix Grid through the Java Tool 

 

2. Click the Start Grid Wizard (online) button 
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3. Verify each condition has been met, and click the Next button. 
c 

 
 

Figure 161. Matrix Grid Wizard in the Java Tool, Step 1 

 

 
 

Figure 162. Matrix Grid Wizard in the Java Tool, Step 2 

4. Proceed through each step in the Wizard to complete the Matrix Grid setup. 
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Firmware Update 
This topic includes updating the firmware on the Orion FX matrix and the extenders connected to it. Firmware 
update is available in the Java Tool. 
 
Matrix Update 
The firmware of the Orion FX can be updated in this menu.  
 
Notes: 
 Only use stand-alone computers that are not connected as CPU devices to the matrix to update the 

matrix firmware. 
 Ensure that the computer used for the update cannot go into standby mode or sleep mode during the 

update. 
 Ensure that the current configuration has been saved externally before the update is started. 
 For reasons of network stability, firmware update via direct LAN is recommended. 
 Ensure that all USB 2.0 extender modules are only connected to their assigned ports (fixed ports) prior to 

beginning the update, or the stability of the update may be affected. 
 
Preparation 
Take the following steps in order to prepare for the matrix update: 

1. Save the matrix configuration externally. 
2. Open Extras > Options in the menu bar, and enter the path to the firmware update files in the 

Firmware Directory setting. Click the Okay button to confirm the path. 
3. Put any spare boards intended for hot swapping into unused slots in the matrix. 
4. Activate the Syslog function to monitor the update. 

 
Ensure that all USB 2.0 extenders are only connected to their assigned ports (fixed ports) before the matrix 
update is started, or the stability of the update may be affected.  
 
The following information is displayed in the working area: 
 

Option Description 

Name •   Name of the chassis or I/O board 
•   Name of the chassis firmware or I/O board firmware 

Type The type of the chassis firmware 

Current Version Installed firmware version 

Update Version Firmware version available for update 

Status Module availability 

Update Selected / deselected for firmware update 
 

Table 58. Firmware Update Options in the Java Tool 

 

The following options are available in the Additional selection options drop-down menu of the Update – Matrix 
firmware menu: 
 

Option Description 

Expand Tree View Expand the tree view to show detailed information. This allows the 
user to select or deselect individual firmware to be updated. 

Collapse Tree View Collapse the tree view to hide detailed information. Individual 
firmware selection will not be possible. 

Select All Select all available firmware for update. 

Deselect All Deselect all selected firmware. 
 

Table 59. Additional Selection Options in the Update firmware menu 
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Figure 163. Additional Firmware Update Selection Options 

Performing the Update 
To perform the matrix update, proceed as follows: 

1. Select Status & Updates > Update – Matrix Firmware in the task area. All components of the matrix 
which are eligible for updates will be automatically selected and highlighted in green. 

 

 
 

Figure 164. Update Matrix Firmware in the Java Tool 
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2. Deselect any components which are not be updated. 

3. Start the update by clicking the Update button. A prompt to save the Matrix Status will be displayed.  

4. Select the Save Matrix Status button to save the status locally, or click Skip. 

 
Figure 165. Save Matrix Status Prompt 

5. The progress of the update is displayed in the working area. 

 
Figure 166. Firmware Update Progress Indicator 
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6. After the update has completed, a prompt to restart the Orion FX is displayed. Click yes to restart the 
Matrix with the updated firmware. 

 

 
 

Figure 167. Prompt to Restart the Matrix After Firmware Update 

7. After the Orion FX has restarted, the outcome of the Update operation is indicated in the Java Tool. 
 

 
 

Figure 168. Firmware Update Success 
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Extender Update 
The firmware of the extenders connected to the matrix can be updated with the Java Tool, with the exception of 
firmware of type xxxMSD, which must be updated via mini-USB service port.  
 
Preparation 
Take the following steps to prepare for the extender update: 

1. Save the matrix configuration externally. (See Saving of Configurations (External). 

2. Open Extras > Options in the menu bar, and enter the path to the *.efw firmware update files in the 
Firmware Directory setting. Click the Ok button to save the path setting. 

 

 
 

Figure 169. Firmware Directory in the Java Tool 

 

3. Connect all spare extenders to the matrix. 
 
Note: The extender update should be performed over a direct LAN connection, due to network stability issues. 
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Performing the Update in Standard Mode (Parallel Update) 

1. Select Status & Updates > Update - Extender Firmware in the task area. The standard mode for 
parallel update will be selected by default, and the Step 1: Upload Firmware tab will be selected. 

 

 
 

Figure 170. Extender Update in Standard Mode through the Java Tool - Step 1: Upload Firmware 

 

2. Before the actual update process can begin, all firmware files have to be uploaded to the I/O boards of 
the extenders to be updated. If a newer firmware is available, the appropriate I/O boards will be 
automatically selected for upload in the Selected column and highlighted in green. 
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3. Start the upload and distribution of the update files by clicking the Upload button. Uploading does not 
install the update files in the extenders, and the actual update can be performed at a later time. 

 

 
 

Figure 171. Upload Extender Firmware to I/O boards with Java Tool 

 

4. The successful completion of the upload process will be confirmed by a pop-up. Proceed to the actual 
update process by clicking the Yes button. The Java Tool will automatically open the Step 2: Update 
Firmware tab. 

 

 
 

Figure 172. Extender Firmware Update Part 2 in the Java Tool 
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5. To update with a firmware identical to or older than the version currently installed, click the Enable 
Downgrade option in the upper part of the Step2 working area. 

6. Start the actual update process by clicking the Update button. 
 

 
 

Figure 173. Enable Downgrade to Reload Current or Previous Firmware with the Java Tool 

 

Note:  Just before update begins, all affected I/O boards will be put into Service Mode. Each will be 
reactivated when its firmware update has completed. 
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Performing the Update in Expert Mode (sequential Update) 
Take the following steps to prepare for the extender update. 
 

1. Select Status & Updates > Update – Extender Firmware and select Sequential Mode in the upper 
part of the working area. All extenders eligible for update will be automatically selected and highlighted 
in green. 

 

 
 

Figure 174. Extender Update in Sequential Mode – Step 1 (from the Java Tool) 
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2. Put the Orion FX into Service Mode upon request in the pop-up window or through Device > 
Advanced Service > Activate Service Mode in the menu bar. 

 

 
 

Figure 175. Activate Service Mode with the Java Tool 

 

Note: During Service Mode, all matrix functions are disabled on the I/O boards on which updates are being 
performed. An OSD notice indicating that the I/O boards were placed in Service Mode is displayed on all 
monitors connected to the matrix through a CON device. Additionally, the Service Mode is indicated by a red 
tool icon in the lower part of the working area of the Java Tool. 
 

 
 

Figure 176. OSD View Service Mode – Step 2 (from the Service Mode of the OSD) 

 

3. Start the update by clicking the Update button in the lower part of the working area. 

4. Exit Service Mode after updating by responding to the confirmation request in the pop-up window or 
through Device > Advanced Service > Deactivate Service Mode in the task area. 

5. After the update, verify through the Java Tool that the updates for all extenders have been installed 
correctly. This is done in Status & Updates > Update – Extender Firmware. 



OPERATION 
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Operation 
The Orion FX can be operated in three different ways: 

1. Direct Switching through a keyboard connected to a CON port 
■ using 'Hot Keys' to switch between as many as 16 favorites 
■ using 'Hot Keys' to invoke switching macros 

2. OSD Switching using 'Hot Keys' to display the OSD and then selecting from the entire range of CPUs 
the console or user can access 
■ through a keyboard connected to a CON port 

3. External Switching Commands 
■ from an external computer running the Java Tool (network connection required) 

 
Switching Operation via Keyboard Commands 
Several operations on the Orion FX can be performed using the ‘Hot Keys’ at a console keyboard, as 
described below. 
 
Direct Switching 
Direct switching by 'Hot Keys' on a keyboard is the quickest way for a user to switch a console between 
different CPUs in their favorites list. It is possible to switch video, keyboard and mouse together, or just the 
video. 
 
Direct Switching of Video, Keyboard and Mouse 

1. Start Command Mode with the 'Hot Key' sequence. The Caps Lock and Scroll Lock keyboard LEDs 
will flash repeatedly when Command Mode is activated. 

2. Enter the index number of the new CPU from the list of favorites and confirm with <Enter>. 
Command Mode is closed and the console is connected to the new CPU with complete control. 
Example:  Switch video, keyboard and mouse to number 7 in the favorites list using the default hot key 
<left Shift>, <left Shift>, <7>, <Enter> 

 
Note: The fastest switching will be achieved when identical mice, keyboards and monitors are used at all 
consoles. This contributes to a smooth and seamless direct switching of the matrix. 
 
Direct Switching of Video, Keyboard and Mouse in Private Mode 

1. Start Command Mode with the 'Hot Key' sequence. The Caps Lock and Scroll Lock keyboard LEDs 
will flash repeatedly when Command Mode is activated. 

2. Enter the index number of the new CPU from the list of favorites and confirm by pressing the 
<left Shift>+<Enter> keys at the same time. Command Mode is closed and the console is connected to 
the new CPU with complete control in Private Mode. 
Example: Switch video, keyboard and mouse to number 3 in the favorites list in Private Mode using the 
default hot key   
<’left Shift’>, <’left Shift’>, <3>, <left Shift>+<Enter> 
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Direct Switching of Video Only 

1. Start Command Mode with the 'Hot Key' sequence. The Caps Lock and Scroll Lock keyboard LEDs 
will flash repeatedly when Command Mode is activated. 

2. Enter the index number of the new CPU from the list of favorites and confirm with <Space>. 
Command Mode is closed and the console is connected to the new CPU with video only. 
Example: Switching to number 1 in the favorites list with video only using default hot key 
<left Shift>, <left Shift>, <1>, <Space> 

 
Direct Switching of Video, Keyboard and Mouse to previous CPU 

1. Start Command Mode with the 'Hot Key'. The Caps Lock and Scroll Lock keyboard LEDs will flash 
repeatedly when Command Mode is activated. 

2. Press the <p> key on the keyboard. Command Mode is closed and the console is connected to the 
previous CPU with complete control. 

 
Note:  
■ If the console is switched to a CPU that was previously connected with Video Only Access, it will now be 

connected to this CPU with full KVM access. 
■ When using ‘Hot Keys’ for direct switching, the user may only be able to connect to unused CPUs to which 

access is permitted. The Force Connect and Force Disconnect options, as well as the restrictions of the 
User ACL and CON ACL are taken into account.  

■ ‘Hot Keys' switching is only supported if the User is logged in, or if neither Enable User Login nor Enable 
User ACL is selected. 

 

Disconnect current connection 

1. Start Command Mode with the 'Hot Key' sequence. The Caps Lock and Scroll Lock keyboard LEDs 
will flash repeatedly when Command Mode is activated. 

2. Press the <Backspace> key on the keyboard. Command Mode is closed and the console is 
disconnected from the currently connected CPU. 

 
Scan Mode 
Scan Mode enables fast switching between video inputs from different CPUs in the favorites list without 
continuously using the 'Hot Key'. The switching between two video signals can even take place within one 
frame. 

1. Start command mode with the 'Hot Key'. The Caps Lock and Scroll Lock keyboard LEDs will flash 
repeatedly when Command Mode is activated. 

2. Press the <Left Shift> key and hold it down. The index numbers of CPUs from the list of favorites can 
be entered on the keyboard, causing the matrix to switch immediately to the video signal of the 
specified CPU. 

3. Leave Scan Mode by pressing <Left Shift> + <Esc>. 
 
Note:  Optimal scan mode results can be achieved by the use of display resolutions as close to identical as 
possible. This contributes to a smooth and seamless switching in scan mode. 
 
Function Keys <F1>-<F16> 
In Command Mode, macros 1-16 can be invoked with the function keys <F1>–<F16> of the connected 
keyboard. Macros 17-32 are invoked by simultaneously holding the key <Left Shift> while typing the keys 
<F1>–<F16>. The stored command sequence for the appropriate function key is executed and Command Mode 
is closed. It is not necessary to press <Enter> to confirm selection of macros. 
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Switching a CON Unit to a local Source 
CON Units connected to a local source can be locally switched by keyboard commands or the OSD.   
 
The following keyboard commands allow switching to the local source: 
 

Function Keyboard Command 
Switching to extender connection 1 <'Hot Key'>, <k>, <1>, <Enter> 

Switching to extender connection 2 (only with redundant CON 
Units) <'Hot Key'>, <k>, <2>, <Enter> 

Switching to the local source (computer, CPU) <'Hot Key'>, <l>, <Enter> 
 

Table 60. Keyboard Commands for Local Source Switching 
 

Multi-Screen Control 
The Multi-Screen function allows a CON Device with several assigned monitors to switch keyboard and mouse 
between several CPU sources by either moving the mouse pointer beyond the edge of the current monitor, or 
by keyboard command. Configuring CON Devices for Multi-screen control is described in the Configuration 
section, Console Device Settings, Multi-Screen Control. 
 
Switching through the mouse 
Switching the USB-HID devices can be done by moving the mouse pointer beyond the edge of the current 
display. In order to perform a switching operation by moving the mouse, proceed as follows. 

1. Move the mouse pointer to the vertical or horizontal edge of the display that borders a neighboring 
display in the CON Device. 

2. Move the mouse pointer beyond the edge of the display. USB HID switching will occur to the CPU 
displayed on the neighboring monitor. The mouse pointer will appear on the adjacent display, and any 
other console USB-HID devices (e.g. keyboard) will also be available at the CPU device displayed on 
that monitor. 

 
Switching through the keyboard 
Switching the USB-HID devices can also be done using the keyboard. In order to perform a switching 
operation via keyboard command, proceed as follows. 

1. Start Command Mode with the 'Hot Key'. 

2. Select the target display by pressing the appropriate key on the numeric pad of the keyboard. 
 
The switching operation will be performed and the USB-HID devices will be available at the CPU connected to 
the target display. 
 
The keyboard commands to switch to each display’s CPU connection are given the table below. 
 

Keyboard Command Function 

<'Hot Key'>, <Num 0> Switch the USB-HID signal to the own display (CON Unit with keyboard 
and mouse)  

<'Hot Key'>, <Num 1> Switch the USB-HID devices to the CPU connected to display #1 

<'Hot Key'>, <Num 2> Switch the USB-HID devices to the CPU connected to display #2 

<'Hot Key'>, <Num 3> Switch the USB-HID devices to the CPU connected to display #3 

<'Hot Key'>, <Num 4> Switch the USB-HID devices to the CPU connected to display #4 
 

Table 61. Keyboard Commands for Multi-Screen Switching 
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Switching Operation through the OSD 
KVM Switching 
KVM Switching can be performed through the OSD. 
 
 Display the OSD main menu and select Switch. 
 

 
 

Figure 177. Main Menu of the OSD 
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Figure 178. KVM Switching Through the OSD 

 

To switch the console to an available CPU, proceed as follows: 
1. Select a CPU device from the CPU Devices list on the left side to connect to the CON device. Press 

the <F8> key to expand the list to show inactive CPU Devices. 

2. Confirm the desired connection type with the appropriate keystroke: <Space> for video only, <Enter> 
for full KVM access, and <Shift>+<Enter> for a private connection. 

 
Switching operations by a CON device can only be made to the devices in the CPU Devices list. 
 
Note:  Listed CPU Devices highlighted in red are currently connected in Private Mode and are blocked by the 
currently connected CON Device. 
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Switching using the Selection List for CPU Devices 
It is also possible to switch CPU devices by means of a second selection list which can be displayed whenever 
the OSD is activated at a console.  
 
In order to use the selection list for CPU Devices, proceed as follows. 

1. In the OSD Main Menu, select Configuration and log in. 
2. Select EXT Units and activate the Enable CPU Selection option in the menu for each console where 

the selection list for CPU Devices should be displayed. 
3. Execute the key sequence for opening the OSD. The selection list immediately appears in the preset 

position of the extender OSD. 
Note: Pressing <F8> shows inactive CPU Devices for a more complete list. 

4. Select a CPU, and complete the switching operation by pressing the key which corresponds to the kind 
of connection desired. 

 

Function Keyboard Command 

Make a video only connection <Space> 

Make a full KVM connection <Enter> 

Make a full KVM connection in private mode <Shift> + <Enter> 

Disconnect from current CPU connection <Backspace> 
 

Table 62. Keyboard Commands for Connecting and Disconnecting in the OSD 

 

To move to the Main OSD menu when the Selection List is displayed, press <F7>. To close the selection list, 
press <Esc>. 
 

 
 

Figure 179. CPU Selection List in the OSD for KVM Switching 

 

Activating automatic Scan Mode for CPU Devices 
The matrix offers an automatic scan mode based on the favorites list of each console or user. Scan mode 
allows the matrix to switch sequentially between the CPU Devices in the favorites list at a specified time 
interval. Automatic scan mode operates in video only mode. Scan Mode configuration was described in the 
Configuration section (see CON Devices). Scan Mode is activated through from the OSD. 
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To activate scan mode, proceed as follows. 
1. Create a favorites list for a CON Device or User (see Console Favorites List or User Favorites List). 

2. Start Command Mode with the 'Hot Key' and press <o> to open the OSD. 

3. Select one of the CPU Devices in the CPU selection list that is defined in the favorites list.  

4. Confirm the CPU Device selection by clicking the CPU Scanner button. The scan will automatically 
start. 

5. If the Force CPU Scan option is enabled, the scan will automatically start after switching the CON 
Device to any CPU Device in the favorites list without the need to press the CPU Scanner button. 

 
Extended Switching 
Extended switching allows other consoles to be switched to any CPU, subject to access control. It can be 
performed through the OSD or the Java Tool. 
 
To switch any console to any available CPU through the OSD, proceed as follows: 
 Select Switch in the main menu. 
 
Note: Pressing <F8> shows inactive CPU Devices for a more complete view. 
 

 
 

Figure 180. Extended KVM Switching through the OSD 
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1. Select a CON device from the CON Devices list on the left side to be switched to a CPU device, and 
open it by pressing <Enter>. 

2. Now select a CPU device from the CPU Devices list on the left side to be connected to the open CON 
device. 

3. Select the desired connection type with the appropriate keyboard command, as listed in Table 62 
above. 

 
A given CON device can only be switched to a CPU device that is shown as available in CPU Devices list. 
The following information is shown in this menu: 
 

Field Description 

CON device Assigned physical extender unit (CON unit) 

CON assigned Virtual CON Device that is assigned to the real CON device 

CPU connected Currently connected CPU device 

CON status Current connection status (CON device) 

EXT list List of all available physical extender units (CON units) 

CPU device Assigned physical extender unit (CPU unit) 

CPU assigned Real CPU device that is assigned to a virtual CPU device 

CON connected Currently connected CON device 

CPU status Current connection status (CPU device) 

EXT list List of all available physical extender units (CPU units) 
 

Table 63. Extended KVM Switch Settings in the OSD 

USB 2.0 Switching 
Switching of USB 2.0 extenders works like the switching of KVM extenders. There are two options for switching 
USB 2.0 extenders depending on how the extenders are configured in the Matrix. 

1. An extender unit with USB 2.0 is created and assigned to an existing device which has KVM extender 
units. 

2. A separate device is created for the extender unit with USB 2.0 which has no KVM extender units 
assigned to it. This allows switching of USB 2.0 devices independently from KVM devices. 

 

Note:  
■ Switching of USB 2.0 signals uses Extended Switching functionality as described earlier in this section. 
■ When using parallel operation within the matrix, set the Release Time in the System Settings > Switch 

menu to 10 s or more (see Shared Operation). Otherwise, the USB 2.0 extender connection will not be 
established for reasons of security and stability. 
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Switching a CON Unit to a Local Source with the OSD 
CON Units connected to a local source (computer, CPU) can be switched with the matrix. Switching to the 
local source causes any matrix KVM connection to be automatically disconnected. 
 
In order to switch to a local source, proceed as follows: 
 Display the OSD Main Menu and select Switch. 
 
 

 
 

Figure 181. CON Switching Through the OSD 

 

1. If not in the Switch menu of the OSD, start Command Mode with the 'Hot Key'. 

2. Press <o> to open the OSD. This shows a list of all available CPUs as a start menu. 

3. Select Local CPU in the list and switch to it. The switching operation to the local source will be 
performed immediately. 

 

Note:   
■ The local source (computer, CPU) will only be shown in the OSD if the CON Unit includes the option for a 

local connection. 
■ When CON Units that can connect to a local source (computer, CPU) are used in a Multi-Screen Control 

environment, switching to the local source is disabled. 
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Switching via Macro List 
In addition to invoking macros with their assigned function keys (<F1> to <F16> and <Lshift-F1> to 
<Lshift-F16>), macros can also be executed via Macro List in the OSD. The Macro List also allows the user to 
view the content of macros before executing them. Sixteen macros of the 32 possible are displayed on a page. 
 
In order to switch to a local source, proceed as follows: 
 Select Macro List in the main menu. 
 

 
 

Figure 182. Switching via Macro List in the OSD 

 

1. Make sure either CON or user macros have been defined. 

2. Select one of the first 16 macros to be executed. Or press <Page Down> to select from macros  
17 – 32. 

3. Execute the macro by pressing the key <Enter>. 
 
Note:  To have the Macro List displayed each time the OSD is invoked, activate the option Show Macro List 
in the menu Configuration > CON Devices for the appropriate CON Devices. 
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Switching Single EXT Units within Devices through the OSD 
Individual extenders within multi-extender CON and CPU devices can be switched independently of the other 
extenders. This type of switching is done through the OSD. 
 
To switch a single extender in a device which has multiple extenders, proceed as follows: 
 Display the OSD Main Menu and select Switch. 
 

 
 

Figure 183. Switching of Single Extenders within Devices in the OSD 

 

1. Select the CPU Device in the list which contains the extender to be accessed. 

2. Press the function key <F7> on the keyboard. The mode will change to single extender switching. 

3. Select the extender to switch in the CON device EXT list. 

4. Press the <Tab> key to move to the CPU device EXT list. 

5. Select the CPU extender to connect to and press the <Space> key to execute switching. 
 
Note:  Switching of single extenders within a Device is only possible in video only mode. Single extenders 
within a device that are already connected will be indicated with “!”. 
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Addressing of Master and Sub Matrices 
The Orion FX can be cascaded over two levels. Commands (including displaying the OSD) can be sent to either 
the master or the sub matrix.  
 
When command mode is active, an extra keystroke can indicate whether the command should be handled by 
the main matrix or the sub matrix. 
 
■ Display the main matrix OSD: 

<’Hot Key’>, <’Hot Key’>, <m> (optional), <o> 
■ Display the sub matrix OSD: 

<’Hot Key’>, <’Hot Key’>, <s>, <o> 
 
In order to perform cross-matrix switching, proceed as follows. 

1. Open the OSD of the master matrix with the following keyboard sequence: 

2. <'Hot Key'>, <o>  

3. Select the CPU device configured as a Tie Line in the CPU selection list and press <Enter> to switch to 
it. 

4. Open the OSD of the sub matrix with the following keyboard command:  

5. <'Hot Key'>, <s>, <o>  

6. Select the target CPU in the CPU selection list of the sub matrix and press <Enter> to switch to it. 
 
Note:  The selected main matrix / sub matrix mode will remain activated unless some other mode is manually 
activated, or Command Mode is exited. This means that if <s> is currently selected for example, all subsequent 
commands will be sent to the slave for as long as Command Mode remains active. 
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Switching Operation through the Java Tool 
Extended Switching  
There are two methods to perform switching operations in the Orion FX via the Java Tool. 
 
Method 1: 
 Select Control > Extended Switch in the task area. 
 

 
 

Figure 184. Extended KVM Switching through Java Tool - Method 1 (From Extended Switch) 

 

All consoles and their CPU connections are shown in columns in the working area in this screen. 
 
Extended switching operations can only be performed in Edit mode, that is, when there is an active network 
connection between the matrix and the Java Tool, and Edit mode has been activated by clicking the icon in the 
Tool Bar or selecting the option in the Device menu. 
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 To make a KVM connection between a console and a CPU, select the console, double-click on the 
corresponding selection box in the Full Access column, and select the desired CPU from the drop-down 
list. 

 

 
 

Figure 185. Full Access Selection List in the Java Tool 

 

 To make a video connection between a console and a CPU, select the console, double-click on the 
corresponding selection box in the Video Only column and select the desired CPU from the drop-down list. 

 To make a Private Mode connection between a console and a CPU, select the console, double-click on the 
corresponding selection box in the Private Mode column and select the desired CPU from the drop-down 
list. 

 To disconnect the console’s current connection, select the console, double-click on the corresponding 
selection box that shows the connection, and select blank entry at the top of the drop-down list. 

 
Note: CPUs to which a console does not have access rights will not appear in the selection list. 
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When more than one console is connected to the same CPU, the following symbols are shown in the Extended 
Switch overview of connections: 
 

Symbol Description 

 CON device is connected with Shared Access with at least one additional console to the same CPU. 
The CON device currently has a Full Access connection. 

 CON device is connected with Shared Access with at least one additional console to the same CPU. 
The CON device currently has a Video Only connection. 

‘ 
Table 64. Description of Connection Symbols in the Java Tool Extended Switch Screen 

 

Use the following buttons to execute switching operations: 
 

Button Function 

Send Send desired switching operations to the matrix 

Reset Disconnect all existing connections within the matrix 

Reload Reload switching status list 
 

Table 65. Buttons in the Java Tool Extended Switching Screen 

 

Note: 
■ When the Auto Send checkbox in the left lower corner of the work area is selected, switching operations 

will be completed as soon as a CPU is selected without needing to click the Send button. 
■ When the Hide Devices w/o Extender Assignment checkbox in the lower left corner of the work area is 

selected, only CON and CPU Devices that are assigned to extenders are shown. 
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Method 2: 
 Select View > Matrix in the task area or select View > Grid when using a Matrix Grid. 
To perform switching operations between CON and CPU devices proceed as follows: 

1. Move the mouse cursor to the port that is to be switched. 

2. Hold down the left mouse button and move the cursor to the port that is to be connected to the first port. 
The cursor movement will be indicated as a black line. 

 

 
 

Figure 186. Extended KVM Switching through Java Tool - Method 2 (From View Matrix) 

3. Release the left mouse button. A pop-up menu to select the available connection type (Full Access, 
Video Access or Private Mode) is displayed. 

4. Select the desired switching type. The switching operation will be executed, and all extender units 
assigned to the selected devices will be switched. 

 
Note: If there is a red X on a port when switching by using the View > Matrix, the console selected for 
connection does not have access rights to the CPU at that port. 
 
To disconnect an existing connection between CON and CPU devices proceed as follows: 

1. Right click on the port to be disconnected. 

2. Select Disconnect in the drop-down list. The connected ports will be disconnected immediately, and all 
extenders assigned to those CON and CPU devices will be disconnected as well. 
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Predefining Macros 
This menu allows the creation and activation of predefined macros for switching the matrix without loading a 
new configuration. It is a function of the Java Tool, not the Matrix.  
 
 Select Control > Presets in the task area. 
 

 
 

Figure 187. Setting up Macro Presets in the Java Tool 

 

To create a new switch macro, proceed as follows: 
1. Select a Console device and open a new switch macro by clicking on the New symbol in the Presets 

column. A prompt asks whether to use the existing connections in the new switch macro. 
 

 
 

Figure 188. New Preset Macro Query 
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2. Set the desired switching operation by double clicking in the appropriate column (Full Access, Video 
Only or Private Mode) and selecting the desired target (or select Disconnect CPU). 

 
 

Figure 189. Selecting the Preset Switching Operation 

3. Save the created switch macro by clicking the Save symbol to the right of the New symbol in the 
Presets column of the working area. A Save Preset dialog will be opened. 

4. Enter a name for the new switch macro and confirm by clicking the Ok button in the dialog. 

5. By clicking on a selected switch macro with the right mouse button, you can create a copy of the 
current switch macro when using the Save as... option. 

6. Previously saved macros can be deleted by pressing the Delete symbol. 
 
To load a switch macro preset to the matrix, proceed as follows: 

1. Select the switch macro to be loaded in the Presets column of the working area. 

2. Activate the selected macro by clicking the Send button below the Presets column. 
 
Note: 
■ A predefined switch macro can only be executed in the Java Tool when edit mode is activated. 
■ Only switch macros that are hardware and current configuration compliant can be executed. 
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Redundancy 
KVM extenders with redundant interconnect connectors can be simultaneously operated with both connectors 
at a single Matrix or a Matrix Grid (firmware version V04.00 and later). KVM extender connectors labeled Link 
1 are for the primary connection. If the connection on either the CON or CPU Unit side is interrupted, the 
connection will be automatically reestablished through the connector labeled Link 2. This requires no 
configuration of the KVM matrix or the KVM extenders. If needed, it is possible to manually switch between 
Link 1 and Link 2 at the CON Unit (see Switching a CON Unit to a Local Source with the OSD). 
 
Redundancy status can be checked with the OSD or the Java Tool. 
 
Monitoring Redundancy Status with the OSD 
 Display the main OSD menu and select Switch. 
 

 
 

Figure 190. Checking Redundant Links with the OSD 

 

When using redundant KVM extenders, the active connector of the selected extender is shown under EXT list 
in the field CON/CPU Data. If the first connector (Link 1) is active, it will be highlighted with :1 behind the 
extender. If the second connector (Link 2) is active, this will be highlighted with :2. 
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Monitoring Redundancy Status with the Java Tool 
 Select View > Matrix in the task area. 
 

 
 

Figure 191. Checking Redundant Links with the Java Tool 

 

In order to check the connection status of the redundant KVM extenders, proceed as follows: 
1. Click the checkbox Show Redundant Links (L1/L2) under Routing Information on the right side of 

the working area. 

2. Open the Redundancy menu on the right side of the working area to display current status of the 
redundant links. 

 
Redundant connectors are highlighted in the Matrix View with L1 and L2. The active link is highlighted with a 
light green label. 
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Power Up and Power Down Functions 
This section deals with power and firmware reset functions of the Orion FX. 
 
Restart 
The Orion FX can be restarted through the OSD and the Java Tool. 
 
Restarting Through the OSD 

1. Display the main OSD menu, select Configuration and log in. 
2. Select Restart Matrix or Restart IO Board. 

3. Confirm the selection with Okay button. 
 
The Orion FX and I/O boards will be restarted with the current settings. 
 
Restarting through the Java Tool 

1. Select Device > Advanced Service in the menu bar and select Restart Matrix in the drop-down 
menu. 

2. Enter the Admin user credentials in the pop-up Authentication menu and click the OK button. 
 
The Orion FX will be restarted with the current settings. 
 
Note: The boot process of the matrix might take longer if no physical network connection is available. 
 
Factory Reset 
Resetting the Orion FX or the IO Boards to factory default settings is available through the OSD and the Java 
Tool. 
 
When a factory reset is performed, all current settings and all configurations stored in the matrix will be lost. 
This also applies to the network parameters (DHCP reset to N) and the admin password (reset to “admin”). 
 
If firmware updates have been performed, the Orion FX will be set to the defaults defined in the most recent 
firmware applied. 
 
Resetting Through the OSD 

1. Display the main OSD menu, select Configuration and log in. 
2. Select Factory Reset. 
3. Confirm the selection with the Okay button. 

 
The Orion FX will be reset to factory default settings. 
 
Resetting Through the Java Tool 

1. Select Device > Advanced Service in the menu bar. 

2. Select Restart Matrix in the drop-down menu, and select either Factory Reset or Factory Reset of I/O 
Boards. 

3. Enter the Admin user credentials in the pop-up Authentication menu and click the OK button. 
 



 

  Orion FX Manual 200 
 

Power Down  
A complete system shutdown can be performed through the OSD and the Java Tool. An I/O board shutdown 
can be performed through the OSD. 
 
Power Down through the OSD 
To shut down the system, proceed as follows. 

1. Display the main OSD menu, select Configuration and log in. 
2. Select Shut down Matrix.  

3. Confirm the selection with the Okay button.  
 
The matrix will be shut down. Fans will be switched to maximum speed after the shutdown command, and then 
the Orion FX can be disconnected from power. 
 
To shut down an I/O Board, proceed as follows. 

1. Display the main OSD menu, select Configuration and log in. 
2. Select Shut down IO Board.  

3. Confirm the selection with the Okay button. 
 
The I/O board will be shut down. 
 
Power Down through the Java Tool 
To shut down the system, proceed as follows. 

1. Select Device > Advanced Service > Shutdown Matrix in the menu bar. 

2. Enter the Admin user credentials in the pop-up Authentication menu and click the OK button. 
 
The Orion FX will be shut down. 
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Summary of Keyboard Commands 
The following two tables list all the keyboard commands that affect either extender functions or matrix 
functions. In the command notation, ‘+’, and ‘,’ have these meanings: 
 <Key> + <Key> = Press keys simultaneously 

 <Key>, <Key> = Press keys successively 
 
Extender Commands 
 

Keyboard Command Description 

<'Hot Key'>, <a> Download of DDC information for the monitor connected to the CON Unit 
into the CPU Unit  

<'Hot Key'>, <k>, <1>, <Enter> Switch to matrix KVM connection 1 (only with CON Units with 
connection available for a local source) 

<'Hot Key'>, <k>, <2>, <Enter> Switch to matrix KVM connection 2 (only with CON Units with 
connection available for a local source and a redundant interconnection) 

<'Hot Key'>, <l>, <Enter> Switch to local source (computer, CPU) (only with HDMI CON Units with 
connection available for a local source) 

<'Hot Key'>, <h>, <w>, <Enter> 
USB-HID Ghosting: Write device descriptions of the input devices 
connected to the CON Unit into the CPU Unit. Activate emulation in the 
CPU Unit. 

<'Hot Key'>, <h>, <e>, <Enter> Activate the emulation of already stored device descriptions in the CPU 
Unit 

<'Hot Key'>, <h>, <d>, <Enter> 
Deactivate the emulation of device descriptions in the CPU Unit. The 
input devices connected to the CON Unit will be passed transparently to 
the source (computer, CPU). 

<'Hot Key'>, <h>, <r>, <Enter> 

Deactivate the emulation of device descriptions in the CPU Unit, and 
remove the descriptions stored in the CPU Unit. The input devices 
connected to the CON Unit will be passed transparently to the source 
(computer, CPU). 

 
Table 66. Extender Keyboard Commands 
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Matrix Commands 
 

Keyboard Command Description 

<'Hot Key'>, <o> Open OSD 

<‘Hot Key‘>, <m>, <o> Open OSD of the master matrix in a cascaded environment 

<‘Hot Key‘>, <s>, <o> Open OSD of the sub matrix in a cascaded environment 

<'Hot Key'>, <Backspace> Close the current connection of the console 

<'Hot Key'>, <p> Switch back to the previously connected source (computer, CPU) with a 
KVM connection 

<'Hot Key'>, <1> ... <16>, 
<Enter> (or <Space> + <Enter>  

or <Left Shift> + <Enter>) 

Switch to a source (computer, CPU) stored in the favorites List with a 
KVM connection (video only or Private-Mode connection) 

<'Hot Key'>, <F1> ... <F16> Execute a predefined macro (1 – 16) 

<'Hot Key'>, <Left Shift> + 
<F1> ... <F16> Execute a predefined macro (17 – 32) 

<'Hot Key'>, <c>,  
<new 'Hot Key'-Code>, <Enter> 

Change the 'Hot Key' to one of the predefined values specified in the 
'Hot Key' table 

<'Hot Key'>, <c>, <0>, 
<new 'Hot Key' key >, <Enter> 

Define a freely selectable new 'Hot Key'  

<'Hot Key'>, <f>,  
<new 'Hot Key'-Code>, <Enter> 

Change the 'Hot Key' for direct OSD access to one of the predefined 
values in the 'Hot Key' table 

<'Hot Key'>, <f>, <0>,  
<new 'Hot Key' key>, <Enter> 

Change the ‘Hot Key” for direct OSD access to a user defined value 

<'Hot Key'>, <Num 0> Switch the USB-HID signals to the user’s display (in Multi-screen 
control) 

<Right Shift> + <Del>  Reset Hot Key to default settings, when executed within 5 seconds of 
plugging in a keyboard 

<'Hot Key'>, <Num 1> Switch the USB-HID signals to display #1 (in Multi-screen control) 

<'Hot Key'>, <Num 2> Switch the USB-HID signals to display #2 (in Multi-screen control) 

<'Hot Key'>, <Num 3> Switch the USB-HID signals to display #3 (in Multi-screen control) 

<'Hot Key'>, <Num 4> Switch the USB-HID signals to display #4 (in Multi-screen control) 
 

Table 67. Matrix Keyboard Commands 
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Diagnostics and Status 
This section describes the diagnostics that are available on the Orion FX. Status indicators, both physically on 
the unit as LED indicators, and in the software, are discussed here. 
 
LED Indicators 
The Orion FX units are fitted with the following LEDs for overall status indication. 
 
Device Status LEDs 
 

 
 Figure 192. Device Status LED 1 and LED 2 

 

LED 1 LED 2 Description 

White White System is booting 

Green Off System is ready 

Red Red System is shutting down 

Green flashing Red flashing System is off 

Off Blue I/O modules are initialized 
 

Table 68. Device Status Indicators 

 

Due to variations in LED type, "white" might also appear as light purple or light blue. 
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Port Link Status LEDs, CATx 1G 

 
 

Figure 193. I/O Port Link Status Indicators, 1G CATx 

LED 1 / 2 Description 

Off No connection detected 

Orange Cable connection ok, detecting extender 

Green Cable connection ok, data traffic active 
 

Table 69. CATx 1G Link Status Indicators 

 

Port Link Status LEDs, CATx 3G 

 
 

Figure 194. I/O Port Link Status Indicators, 3G CATx 

1 – Link status LED 1 for lower port 3 – Link status LED 1 for upper port 
2 – Link status LED 2 for lower port 4 – Link status LED 2 for upper port 

 
LED 1 / 3 LED 2/ 4 Description 

Off Green No connection detected 

Orange Green Cable connection ok, detecting extender 

Off Green Cable connection ok, data traffic active 

Orange flashing Off Extender not detected 
 

Table 70. CATx 3G Link Status Indicators 
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Port Link Status LEDs, Fiber 

 
 

Figure 195. I/O Board Port Link Status Indicators, Fiber 

1 – Link status LED 1 for lower port 3 – Link status LED 1 for upper port 
2 – Link status LED 2 for lower port 4 – Link status LED 2 for upper port 

 
LED 1 / 3 LED 2/ 4 Description 

Green Off Connection established 

Green Red Cable connection ok, detecting extender 

Green Off Cable connection ok, data traffic active 

Flashing Red Off Extender not detected 
 

Table 71. Fiber Link Status Indicators 
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Network Connection Link and Activity Status LEDs 

 
 

Figure 196. Network Connection Link and Activity Status LEDs 

1 – Activity status LED network connection 2 3 – Activity status LED network connection 1 
2 – Link status LED for network connection 2 4 – Link status LED for network connection 1 

 
Position LED  Status Description 

1 or 3 
Activity status 
(Orange) 

Off No network connection available or Data traffic not active 

On Network connection available, data traffic active 

2 or 4 
Link Status 
(Green) 

Off No network connection available 

On Network connection available 
 

Table 72. Network Connection Link and Activity Status Indicators 

 
Power Supply Status LEDs 
 

 
 

Figure 197. Power Supply Status Indicators 

 

Pos. LED Status Description 

1 AC Input 1 
(Green) 

On Power supply 1 available 

Off Power supply 1 not available 

2 AC Input 2 
(Green) 

On Power supply 2 available 

Off Power supply 2 not available 
 

Table 73. Front Panel Power Supply Indicators 
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Port Status 
The connections and the switching status between the various consoles and CPUs are shown in this Java Tool 
menu. 
 
Viewing Port Status with the Java Tool 
The current port configuration of the Orion FX is illustrated in this screen.  
 
 Select View > Matrix in the task area when connected to the matrix. 
 

 
 

Figure 198. Viewing Port Status with the Java Tool 

 

The colors indicate the connection status: 
 

Color Description 

Grey Port not connected 

Orange Video connection 

Green KVM connection 

Red Faulty Port 

Blue Port connected to another matrix through a Grid Line 
 

Table 74. Color Indicators in the Java Tool Port Status Screen 
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The symbol indicates an extender that is recognized and defined at a certain port: 
 

Symbol Description 

 
Port connected to a CPU unit 

 
Port is connected to a CPU unit that is switched to a CON unit in Private Mode 

 
Port connected to a CON unit 

 
Port connected to a CON unit with Shared Access to a CPU. 

 
Port is connected to a CON unit that is connected to a CPU unit in Private Mode 

 
Port connected to an USB 2.0 CPU unit 

 
Port connected to an USB 2.0 CON unit 

 
Port is configured as Cascade-CON port for cascading of matrices. 

 
Port is configured as Cascade-CPU port for cascading of matrices. 

 
Table 75. Symbols in the Java Tool Port Status Screen 

 

■ Red framed ports are defined as "fixed" (e. g. for USB 2.0 connections) 
■ The port with a static blue frame and blue squares at the corners is currently selected. 
■ If a port is selected, all the other ports will be displayed transparent except those that are connected to the 

currently selected port. A selection can be cleared by clicking the Clear Selection button. 
■ If a red X is shown on a port when attempting to switch with Matrix View, the console to be connected does 

not have access rights to the CPU at that port. 
 
 Click the left mouse button on a port to select it and display its extender information on the right-hand side of 

the working area. The following information is available: 
 

Field Description 

Extender Name Name of the extender 

Extender Type Type of the extender 

Port Number of the selected port 

Slot (global) The slot location of the extender 

Device ID The Orion FX assigned Device ID number 

Device Name Name of the connected console or CPU device 

Extender Name of the selected extender 

Connections Listing of current devices connected to the selected port (Full or Video Access) 
 

Table 76. Extender Information for a Port in the Java Tool Port Status Screen 
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 Click the right mouse button on a port to display the same information and also open the context menu for 
the port with available functions. The following context functions are available: 

 

Function Description 

Open Extender The extender definition menu will be opened 

Open Device The device definition menu will be opened 

Extended Switch The extended switching menu will be opened 

Disconnect Disconnect an existing connection 

Restart Extender Restart the extender 

Restart I/O Board Restart the extender’s I/O board 

Factory Reset I/O Board Reset the extender’s I/O board to factory defaults 
 

Table 77. Mouse Context Menu for a Port in the Java Tool Port Status Screen 
 

 
 

Figure 199. Port Status Mouse Context Menu 
 

The Java Tool View - Matrix information can be reloaded in four ways: 
■ Press the <F5> key on the keyboard.  
■ Select Edit > Reload in the menu bar. 
■ Click the Reload button in the tool bar. 
■ Click the Automatic Reload checkbox in the right panel of the View > Matrix menu under Options. 
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Port Status Matrix Grid 
This Java Tool menu shows the connections and switching status between the CON and CPU Devices within a 
Matrix Grid. 
 
The screen is divided into the different Grid matrices. Each matrix is displayed in an optimized view of 24 ports 
per line, in order to be able to show a larger number of ports,  
 
 Select View > Port in the task area when connected to the matrix. If Orion FX units are connected in a 
Matrix Grid, they will appear in the display. 
 

 
 

Figure 200. View Port Status Matrix Grid 

 

Note: Functions, colors and symbols used in the View Port screen are identical to those used for port status in 
the Matrix View. 
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Extender OSD 
All CON extenders used with the Orion FX are provided with their own OSD to display the connection status of 
the console. 
 

 
 

Figure 201. Extender OSD 

 

The following information is shown in the OSD information screen: 
 

Field Description 

CON Name of the console 

CPU 

Name of the currently connected CPU 
Color Coding: 
Green: The connection to the CPU is completely established 
Yellow: The connection to the CPU is partially established 
Red: The connection to the CPU cannot be established 
Note: Possible reasons for incomplete or failed connection can be powered down extenders, or insufficient 
available Grid lines in Matrix Grid operation (the message No more grid lines available would be 
displayed).  

ACCESS 

Full Access: The console has a KVM connection to the displayed CPU. 
Video Access: The console has a video only connection to the displayed CPU. 
Private Mode: The console has a Private Mode connection to the displayed CPU. 
Not connected: The console is not connected to a CPU. 

SHARES 
x device(s) shows the number of devices that are connected to the console’s currently connected CPU 
(e.g. 3 devices).  

If the field is blank, no other devices are connected to the current CPU. 
 

Table 78. Information Displayed in the Extender OSD Screen 
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Note:  If the Mouse Connect or Keyboard Connect options are active, the name of the console with 
keyboard/mouse control will be displayed at those consoles that do not currently have keyboard/mouse 
control. The console name is displayed in yellow color under Access. 

 
Network Status 
The current network configuration is shown in this screen. This screen can be accessed through the OSD or 
the Java Tool. 
 
The following information is shown in this menu: 
 

Field Description 
DHCP The network is allowed to assign network settings dynamically. Displays YES or NO. 

IP Address The current IP address of the matrix, whether provided manually or via DHCP 

Subnet Mask The current subnet mask, whether provided manually or via DHCP 

Gateway The current gateway address, whether provided manually or via DHCP 

Multicast The Multicast address, if there is a Matrix Grid within a Multicast group 

MAC ID The MAC address of the matrix 
 

Table 79. Network Status Settings 

 

Viewing Network Status through the OSD 
 Select Status > Network in the main menu. 
 

 
 

Figure 202. Network Status in the OSD 
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Viewing Network Status with the Java Tool 
 Select System Settings > Network in the Main Menu task area. 
 

 
 

Figure 203. Viewing Network Status through the Java Tool 
 

Matrix Firmware Status 
The current firmware status of the installed boards is shown in this menu. It can be accessed through the OSD 
and the Java Tool. 
 
The following information is shown in this screen: 
 

Field Description 

Name Description of the modules 

Type Type of the modules by functionality 

Ports Number of ports 

Version Complete description of the firmware version 

Date Date of the firmware version 

Status Module status (Java Tool only) 
 

Table 80. Information Displayed in the Matrix Firmware Status Screen 
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Firmware Status through the OSD 
 Select Status > Firmware in the main menu. 
 

 
 

Figure 204. Firmware Status through the OSD 

 



 

  Orion FX Manual 215 
 

Firmware Status through the Java Tool 
Select Status & Updates > Status – Matrix Firmware in the task area. 
 

 
 

Figure 205. Viewing Firmware Status through the Java Tool 

 

The current firmware status can be stored as a file in the computer running the Java Tool (file extension .zip). 
1. Select Device > Save Status in the menu bar, or click the Save Status icon in the tool bar. 

 

 
 

Figure 206. Save Status Location and File Name in the Java Tool 
 

2. Select a location and name for the file and click the Next button. 
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3. To save the file with personal data rendered anonymous, click the Anonymize checkbox and click Next. 
 

 
 

Figure 207. Save Status Anonymous Option in the Java Tool 

 

4. Click the Finish button when all steps are complete. 
 

 
 

Figure 208. Save Status Steps in the Java Tool 
 

Extender Firmware Status 
The current firmware status of the connected extenders is shown in this menu, found in the Java Tool. 
 
The following information is shown in this screen. 
 

Field Description 

ID Serial number of the extender  

Name Name assigned to the extender unit 

Port I/O port where the extender is connected to the matrix 

Type Description of the extender module and its components 

Device Device associated with the extender 

Version Current firmware version by component 
 

Table 81. Information Displayed in the Extender Firmware Status Screen 
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 Select Status & Updates > Status - Extender Firmware in the task area. 
 

 
 

Figure 209. Extender Firmware Status in the Java Tool 
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To view the version of each type of firmware in an extender, click the plus box in front of an extender’s ID to 
expand the entry. 
 

 
 

Figure 210. Expanded Firmware Status of Extender with the Java Tool 

Firmware types to be updated, or firmware conflicts are highlighted in color. 
 

Color Description 

  
Extender firmware version conflict 

 
Manual update of EXTMSD / EXTIMSD recommended* 

 
Wrong module (CPU/CON mismatch) 

  
Undefined type 

 
Table 82. Extender Firmware Update Indicators in the Java Tool 

*Updating EXTMSD firmware is only required when it is specifically advised by Technical Support. EXTMSD 
firmware must be manually updated via the mini-USB service port of the extender modules. 

 



 

  Orion FX Manual 219 
 

Extender Firmware on I/O Board Status 
The Extender firmware currently stored in the memory of the I/O boards can be viewed in this menu. The 
firmware name, type, and version are displayed in this menu, along with the I/O board memory usage. 
 

1. Select Status & Updates > Status - Extender Firmware in the task area. 

2. Select Extender Firmware Status on I/O Board tab in the working area. 
 

 
 

Figure 211. Extender Firmware on I/O Board Status 

 

The following information is displayed in the working area: 
 

Column Description 

Slot Slot number of the I/O Board 

Name Name of the I/O Board and the extender module firmware 

Type Type of the I/O board and the extender module firmware 

Mem Usage / Version 
 Memory used on the I/O board 
 Extender Firmware versions stored on the I/O Board 

 
Table 83. Information Displayed in the Extender Firmware on I/O Board Status Screen 
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Trace Function 
This function is used for diagnostic purposes. All events in the Orion FX matrix are logged and displayed in this 
screen. This screen can be accessed from the OSD. 
 
The following information is shown in this menu: 
 

Field Description 

Date Event date stamp 

Time Event time stamp 

Message Detailed description of the event 
 

Table 84. Information Displayed in Trace Function 

 

 Select Status > Trace in the OSD menu. 
 

 
 

Figure 212. Trace Log Monitoring in the OSD 
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Syslog Monitoring 
The Syslog function offers complete logging of matrix activities and switching operations. During logging, the 
activities are written continuously into log files and stored locally. This function is found in the Java Tool. To set 
up and activate and the Syslog function, see Activating Syslog. 
 
Note: Syslog messages are transmitted via UDP. Network port 514 should not be blocked by a firewall. 
To start Syslog Monitoring proceed as follows. 
 
 Select Device > Monitoring in the menu bar, or click the Monitoring icon in the tool bar. 
 

 
 

Figure 213. Syslog Monitoring with the Java Tool 

 

The logging of system activities starts when the Monitoring menu is opened, and remains active until the tab 
is closed.  
 
During logging, the activities are written continuously into logging files and stored locally. This logging process 
includes a number of options as described below. 
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Filter Function 
To filter relevant messages out of a number of logged activities of the Orion FX, Syslog Monitoring offers 
various filter options. These are set up using the fields at the top of the Syslog screen. 
 
To set and activate a filter, proceed as follows: 

1. Set the desired filter option(s) by clicking the appropriate checkbox(es). 

2. Activate the filter settings by pressing the Filter button. 
 
To deactivate an activated filter setting, press the Clear button. 
 
The following filter options are available: 
 

Option Description 

Date Messages of a defined date range will be displayed 

Facility Messages of a defined facility will be displayed 

Severity Messages of a specified severity will be displayed 

Host Messages of a named Orion FX will be displayed 

Message Messages containing specified text will be displayed 
 

Table 85. Filter Options for Syslog Monitoring 

 

Note: Filter options are not valid in stored log files. 
 
Recording Function 
Syslog messages shown in the Monitoring window can be saved or deleted. 
 To store the messages shown in the Syslog (filtered or unfiltered), click the Save trace button. The 

messages will be stored in a text file with the .csv extension. 
 To remove the messages shown in the Syslog, click the Clear trace button. 
 To stop recording the messages, click the Pause button. To continue, click the button again. 
 



 

  Orion FX Manual 223 
 

Syslog Find Function 
The find function can be used to find specific Syslog messages in a variety of logged activities from the matrix, 
extender modules, and chassis. 
 

 
 

Figure 214. Syslog Find Function 

To find specific Syslog messages, proceed as follows: 
1. Click the Find Tab in the working area. Recorded Syslog messages are displayed in the working area. 

2. Enter a search term in the Find Message search field. 

3. Click the Find Next button. The first message with the search term is highlighted. 

4. Click the Find Next again to find another message with the search term. 
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System Check 
System Check provides a diagnostic tool for checking the matrix configuration. This feature detects and 
displays suboptimal and faulty settings. It is used as a confidence check and does not make any changes in 
the configuration. It is accessed through the Java Tool. 
 
The following configuration details are checked: 
■ Matrix Firmware  
■ Extender Firmware  
■ Macros  
■ System Configuration  
■ Ports 
■ Ext Units  
■ CPU Devices  
■ CON Devices  
■ User  
 

 

 Select Device > System Check in the menu bar, or click the System Check icon in the tool bar. 
 

 
 

Figure 215. System Check with the Java Tool 
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The following notification levels are shown: 
 

Level Description 

OK (green) System Check completed without any abnormalities. 

WARNING (yellow) 
System Check found abnormalities in the configuration that are not system critical, 
such as incomplete parts of the configuration, firmware differences, duplications or 
unconnected extenders. 

ERROR (red) System Check found errors in the configuration that can have both functional and 
system critical influences on the system. 

 
Table 86. System Check Notification Levels 

 

If "WARNING" and "ERROR" messages are generated by the System Check function, the problem will be 
described and a basic guideline to resolve the problem will be provided. 
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Repair 
This Unit does not contain any internal user-serviceable parts. In the event a Unit needs repair, you must first 
obtain a Return Authorization (RA) number from Rose Electronics or an authorized repair center. This Return 
Authorization number must appear on the outside of the shipping container. 
 
See Limited Warranty for more information.  
 
When returning a Unit, it should be double-packed in the original container or equivalent, insured and shipped 
to: 
 Rose Electronics  
 

 Attn: RA __________ 
 

 10707 Stancliff Road 
 

 Houston, Texas 77099 USA   
 
Technical Support 
If you are experiencing problems, or need assistance in setting up, configuring or operating your Orion FX unit, 
consult the appropriate sections of this manual. If, however, you require additional information or assistance, 
please contact the Rose Electronics Technical Support Department at: 
 
 Phone: (281) 933-7673 
 

 E-mail: TechSupport@rose.com  
 

 Web:    www.rose.com  
 
Technical Support hours are from: 8:00 am to 6:00 pm CST (USA), Monday through Friday. 
 
Please report any malfunctions in the operation of this Unit or any discrepancies in this manual to the Rose 
Electronics Technical Support Department. 
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Safety 
The Orion FX has been tested for conformance to safety regulations and requirements, and has been certified 
for international use. Like all electronic equipment, the Orion FX should be used with care. To protect yourself 
from possible injury and to minimize the risk of damage to the Unit, read and follow these safety instructions. 
 
■ Follow all instructions and warnings marked on this Unit. 
■ Except where explained in this manual, do not attempt to service this unit yourself. 
■ Do not use this unit near water. 
■ Assure that the placement of this unit is on a stable surface or rack mounted. 
■ Provide proper ventilation and air circulation. 
■ Keep power cord and connection cables clear of obstructions that might cause damage to them. 
■ Use only power cords, power adapter and connection cables designed for this Unit. 
■ Use only a grounded (three-wire) electrical outlet. 
■ Use only the power adapter provided with the unit. 
■ Keep objects that might damage this Unit and liquids that may spill, clear from this Unit. Liquids and foreign 

objects might come in contact with voltage points that could create a risk of fire or electrical shock. 
■ Operate this Unit only when the cover is in place. 
■ Do not use liquid or aerosol cleaners to clean this Unit. Always unplug this Unit from its electrical outlet 

before cleaning. 

Unplug this Unit from the electrical outlet and refer servicing to a qualified service center if any of the following 
conditions occur: 

 The power cord or connection cables are damaged or frayed. 

 The Unit has been exposed to any liquids. 

 The Unit does not operate normally when all operating instructions have been followed. 

 The Unit has been dropped or the case has been damaged. 

 The Unit exhibits a distinct change in performance, indicating a need for service. 
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Safety and EMC Regulatory Statements 
Safety information 

 
Documentation reference symbol. If the product is marked with this symbol, refer to the product 
documentation to get more information about the product. 

 
WARNING   A WARNING in the manual denotes a hazard that can cause injury or death.  
 
CAUTION  A CAUTION in the manual denotes a hazard that can damage equipment. 
 
Do not proceed beyond a WARNING or CAUTION notice until you have understood the hazardous conditions 
and have taken appropriate steps. 
 
Grounding 
There must be an un-interruptible safety earth ground from the main power source to the product’s input wiring 
terminals, power cord, or supplied power cord set. Whenever it is likely that the protection has been impaired, 
disconnect the power cord until the ground has been restored. 
 
Service 
The Orion FX contains no user serviceable parts. Only service-trained personnel must perform any servicing, 
maintenance, or repair of all other parts. 
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Troubleshooting  
This section provides solutions for problems with the Orion FX matrix. It is assumed that fully operational CPU 
and CON Devices are available, which can be tested over a peer-to-peer connection using CATx or fiber 
cables. Please refer to the Orion Xtender manuals, if necessary. 
 
External Failure 
 

Problem Possible Reason Solution 

Matrix will not power up Fuse at the standard appliance 
outlet  Check the fuse 

 
Table 87. Troubleshooting an External Failure 

 

Video Interference 
 

Problem Possible Reason Solution 

Unable to open OSD OSD Jumper not set on user’s 
extender unit 

 Set jumper 11 on user’s extender 
unit 

Incorrect video display Cable connection faulty 
 Check the connections, length and 
quality of the interconnect cables to 
the units 

 
Table 88. Troubleshooting Video Interference 

 

Fan Malfunction 
 

Problem Possible Reason Solution 

Fans do not run, OK LED on Fans defective  Contact Rose Electronics 
 

Table 89. Troubleshooting a Fan Malfunction 

 

Power Supply Unit Malfunction 
 

Problem Possible Reason Solution 

Matrix cannot be started 
No power available  Check that the power supply cables 

are connected properly 

Power Supply Units are not 
switched on 

 Check switch position of the Power 
Supply Units 

 
Table 90. Troubleshooting a Power Supply Unit Malfunction 
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Network Error 
 

Problem Possible Reason Solution 

Network settings are not in use 
after editing 

Restart of the matrix not yet 
completed  Restart the matrix 

 
Table 91. Troubleshooting a Network Error 

 

Failure at the matrix 
 

Problem Possible Reason Solution 

USB 2.0 Port definitions invalid Restart of the matrix not yet 
completed  Restart the matrix 

No OSD access Wrong Hot Key  Reset Hot Key if necessary 
 

Table 92. Troubleshooting a Failure at the Matrix 

 

Port Interconnect Failure 
Error Indication at the 1G CATx port 
 

 
 

Figure 216. Troubleshooting a 1G CATx Port Error 

 

Problem Possible Reason Solution 

LED 1 or LED 2 flashing 
orange 

Connections between CON Unit, 
matrix, and CPU Unit  

 Check connecting cables and connectors 
(cable break, CPU/CON Unit offline)  
 Connect a 1G extender to a 1G port 
 Contact Rose Electronics if necessary 

 
Table 93. Troubleshooting a 1G CATx Port Error 
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Error Indication at the 3G CATx Port 
 

 
 

Figure 217. Troubleshooting a 3G CATx Port Error 

 

Problem Possible Reason Solution 

LED 1 or LED 2 flashing 
orange 

Connections between CON Unit, 
matrix, and CPU Unit  

 Check connecting cables and connectors 
(cable break, CPU/CON Unit offline)  
 Connect a 3G extender to a 3G port 
 Contact Rose Electronics if necessary 

 
Table 94. Troubleshooting a 3G CATx Port Error 

 

Error Indication at the Fiber Port 
 

 
 

Figure 218. Troubleshooting a Fiber Port Error 

 

Problem Possible Reason Solution 

LED 1 or LED 2 flashing 
red 

Connections between CON Unit, 
matrix, and CPU Unit  

 Check connecting cables and connectors 
(cable break, CPU/CON Unit offline)  
 Connect a 3G extender to a 3G port 
 Contact Rose Electronics if necessary 

 
Table 95. Troubleshooting a Fiber Port Error 
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Blank Screen 
 

 
 

Figure 219. Troubleshooting Blank Screen 

 

Problem Possible Reason Solution 

LED 1 and LED 2 off Power supply  Check the connection to the power 
source 

Monitor remains dark after 
switching operation 

Switching to a port with no 
connected source 

 Switch to a port with a connected 
source 

Connections between CON Unit, 
matrix, and CPU Unit 

 Check connecting cables and 
connectors (Cable missing or broken, 
CPU/CON unit offline, CPU/CON unit 
connected to the wrong port). 

 
Table 96. Troubleshooting a Blank Screen 
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Appendix A – General Specifications 

This section gives the general specifications for the Orion FX connectors, pinouts, cables and dimensions. 
 
Interfaces 
The different types of possible connections, and any restrictions on them, are discussed here. 
 
RJ45 (Network) 
Communication with Orion FX requires a 100BASE-T connection. Cabling must comply with EIA/TIA-568-B 
(100BASE-T), with RJ45 connectors at both ends. All four wire pairs are used in both directions. The cabling is 
suitable for a full duplex operation. To connect a computer directly to the network connector, a crossover 
network cable must be used. 
 
RJ45 (Interconnect) 
The communication of the CATx devices requires a 1000BASE-T connection. Connector wiring must comply 
with EIA/TIA-568-B (1000BASE-T), with RJ45 connectors at both ends. All four cable wire pairs are used. 
 
Fiber SFP Type LC (Interconnect) 
Communication with fiber devices is performed via Gigabit SFPs that are connected to suitable fiber cables 
with LC type connectors. 
 
Note:  
■ The correct function of the device can only be guaranteed with SFPs provided by Rose Electronics. 
■ SFP modules can be damaged by electrostatic discharge (ESD). Please consider ESD handling 

specifications. 
 
Interconnect Cable 
The cables used to connect the Orion FX to the extenders are described here. 
 
CATx 
A point-to-point connection is required. Operation with several patch fields is possible. Routing over an active 
network component, such as an Ethernet Hub, Router or Matrix, is not allowed. 
 
Note: 
■ Avoid routing CATx cables near power cables. 
■ To maintain regulatory EMC compliance, correctly installed shielded CATx cable must be used throughout 

the interconnection link. 
■ To maintain regulatory EMC compliance, all CATx cables should have ferrites installed on both cable ends 

close to the devices. 
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Type of Interconnect Cable 
The Orion FX requires interconnect cabling specified for Gigabit Ethernet (1000BASE-T). The use of solid-core 
(AWG24), shielded, Cat 5e (or better) is recommended. 
 

Type of Cable Specifications 

CATx Solid-Core Cable 
AWG24 

S/UTP (Cat 5e) cable according to EIA/TIA-568-B. Four pairs of wires AWG24. 
Connectors according to EIA/TIA-568-B (1000BASE-T). 

CATx Patch Cable 
AWG26/8 

S/UTP (Cat 5e) cable according to EIA/TIA- 568-B. Four pairs of wires 
AWG26/8. Connectors according to EIA/TIA-568-B (1000BASE-T). 

 
Table 97. Supported CATx Cable Types 

 

The use of flexible cables (patch cables) type AWG26/8 is possible; however, the maximum possible extension 
distance is halved. 
 
Maximum Acceptable Cable Length 
 

Type of Cable Maximum Length 

CATx Installation Cable AWG24 459 ft (140 m) 

CATx Patch Cable AWG26/8 230 ft (70 m) 
 

Table 98. Maximum CATx Cable Lengths 

Fiber 
A point-to-point connection is necessary. Operation with multiple patch panels is allowed. Routing over active 
network components, such as Ethernet hubs, matrices or routers, is not allowed. 
 
Type of Interconnect Cable 
(Cable notations according to VDE) 
 

Type of Cable Specifications 

Single-mode 9μm 

 Two fibers 9μm 

 I-V(ZN)H 2E9 (in-house patch cable) 
 I-V(ZN)HH 2E9 (in-house breakout cable) 
 I/AD(ZN)H 4E9 (in-house or outdoor breakout cable, resistant) 
 A/DQ(ZN)B2Y 4G9 (outdoor cable, with protection against rodents) 

Multi-mode 50μm 
 Two fibers 50μm 
 I-V(ZN)H 2G50 (in-house patch cable) 
 I/AD(ZN)H 4G50 (in-house or outdoor breakout cable, resistant) 

Multi-mode 62.5μm 
 Two fibers 62.5μm 
 I-V(ZN)HH 2G62.5 (in-house breakout cable) 
 A/DQ(ZN)B2Y 4G62.5 (outdoor cable, with protection against rodents) 

 
Table 99. Supported Fiber Cable Types 

 

Single-mode connection cables should only be used for fiber connections that are based on 3G SFPs. 
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Maximum Acceptable Cable Length 
 

Type of cable 1.25 Gbps 3.125 Gbps 

Single-mode 9μm 32,808 ft (10,000 m) 16,404 ft (5,000 m) 

Multi-mode 50μm (OM3) 3,281 ft (1,000 m) 1,640 ft (500 m) 

Multi-mode 50μm 1,312 ft (400 m) 656 ft (200 m) 

Multi-mode 62.5μm 656 ft (200 m) 328 ft (100 m) 
 

Table 100. Maximum Fiber Cable Lengths 

 

If single-mode SFPs are used with multi-mode fiber cables, the maximum acceptable cable length will usually 
be increased. 
 
Type of Connector 
 

Connector LC Connector 
 

Table 101. Connector Type for Fiber Cables 
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Connector Pinouts 
This section shows the pinouts for the connectors on the Orion FX. 
 
RJ45 Connector (Network) 
 

 
 

Figure 220. RJ45 Network Connector 

  

Pin Signal Pin Signal 

1 D1+ 5 D3- 

2 D1- 6 D2- 

3 D2+ 7 D4+ 

4 D3+ 8 D4- 
 

Table 102. RJ45 Network Connector Pinouts 

 

RJ45 Connector (Interconnect) 
 

 
 

Figure 221. I/O Board RJ45 Connector 

 

Pin Signal Pin Signal 

1 D1+ 5 D3- 

2 D1- 6 D2- 

3 D2+ 7 D4+ 

4 D3+ 8 D4- 
 

Table 103. I/O Board RJ45 Connector Pinouts 

 

Fiber SFP Type LC Connector 
 

 
 

Figure 222. I/O Port Fiber Type LC Connector 

 

Diode Signal 

1 Data OUT 

2 Data IN 
 

Table 104. I/O Port Fiber Type LC Connector Pinouts 
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Maximum Current, Voltage, and Power Consumption 
 

Orion FX, CATx 1G  
 

Orion FX 16-port model 3.9 A, 100-240 VAC, 50/60 Hz 53.7 W 

Orion FX 24-port model 5.1 A, 100-240 VAC, 50/60 Hz 69.3 W 

Orion FX 32-port model 6.2 A, 100-240 VAC, 50/60 Hz 85.0 W 

Orion FX 40-port model 7.3 A, 100-240 VAC, 50/60 Hz 100.6 W 

Orion FX 48-port model 9.6 A, 100-240 VAC, 50/60 Hz 126.6 W 

Orion FX 64-port model 11.9 A, 100-240 VAC, 50/60 Hz  157.4 W 

Orion FX 80-port model 14.3 A, 100-240 VAC, 50/60 Hz 188.1 W 

Orion FX 120-port model 21.9 A, 100-240 VAC, 50/60 Hz 279.6 W 

Orion FX 128-port model 23.1 A, 100-240 VAC, 50/60 Hz 294.5 W 

Orion FX 144-port model 25.4 A, 100-240 VAC, 50/60 Hz 324.3 W 

Orion FX 160-port model 27.8 A, 100-240 VAC, 50/60 Hz 354.0 W 
 

Table 105. Current and Voltage and Power Requirements for the Orion FX CATx 1G 

 

Orion FX, CATx 3G  
 

Orion FX 16-port model 5.3 A, 100-240 VAC, 50/60 Hz 72.9 W 

Orion FX 24-port model 7.2 A, 100-240 VAC, 50/60 Hz 98.1 W 

Orion FX 32-port model 9.0 A, 100-240 VAC, 50/60 Hz 123.4 W 

Orion FX 40-port model 10.8 A, 100-240 VAC, 50/60 Hz 148.6 W 

Orion FX 48-port model 13.8 A, 100-240 VAC, 50/60 Hz 182.0 W 

Orion FX 64-port model 17.5 A, 100-240 VAC, 50/60 Hz  231.2 W 

Orion FX 80-port model 21.3 A, 100-240 VAC, 50/60 Hz 280.4 W 

Orion FX 120-port model 32.4 A, 100-240 VAC, 50/60 Hz 413.6 W 

Orion FX 128-port model 34.3 A, 100-240 VAC, 50/60 Hz 437.4 W 

Orion FX 144-port model 38.0 A, 100-240 VAC, 50/60 Hz 485.1 W 

Orion FX 160-port model 41.8 A, 100-240 VAC, 50/60 Hz 532.8 W 
 

Table 106. Current and Voltage and Power Requirements for the Orion FX CATx 3G 

Orion FX, Fiber 1G and 3G  
 

Orion FX 16-port model 3.9 A, 100-240 VAC, 50/60 Hz 72.9 W 

Orion FX 24-port model 5.1 A, 100-240 VAC, 50/60 Hz 98.1 W 

Orion FX 32-port model 6.2 A, 100-240 VAC, 50/60 Hz 123.4 W 

Orion FX 40-port model 7.4 A, 100-240 VAC, 50/60 Hz 148.6 W 

Orion FX 48-port model 9.6 A, 100-240 VAC, 50/60 Hz 182.0 W 

Orion FX 64-port model 11.9 A, 100-240 VAC, 50/60 Hz  231.2 W 

Orion FX 80-port model 14.3 A, 100-240 VAC, 50/60 Hz 280.4 W 

Orion FX 120-port model 21.9 A, 100-240 VAC, 50/60 Hz 413.6 W 

Orion FX 128-port model 23.1 A, 100-240 VAC, 50/60 Hz 437.4 W 

Orion FX 144-port model 25.4 A, 100-240 VAC, 50/60 Hz 485.1 W 

Orion FX 160-port model 27.7 A, 100-240 VAC, 50/60 Hz 532.8 W 
 

Table 107. Current and Voltage and Power Requirements for the Orion FX CATx 3G 
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Environmental Conditions 
 

Operating Temperature 41°F to 113°F (5°C to 45°C) 

Storage Temperature -13°F to 140°F (-25°C to 60°C) 

Relative Humidity Max. 80% non-condensing 

Operating Altitude Max. 8202 ft (2.5km) 

Heat Dissipation Corresponds to power consumption in Watts 
 

Table 108. Environmental Conditions Requirements for the Orion X 

 

Dimensions 
Orion FX 120-port, 128-port, 144-port, and 160-port (4U) 
 
 

Matrix 17.4" x 17.7" x 7.0" (442 x 449 x 177 mm) 

Shipping Box 25.2" x 22.4" x 14.2" (640 x 570 x 360 mm) 
 

Table 109. Size of the 4U Orion FX model and its Shipping Box 

 

Orion FX 48-port, 64-port, and 80-port models (2U) 
 

Matrix 17.4" x 17.7" x 3.5" (442 x 449 x 90 mm) 

Shipping Box 23.7" x 20.7" x 7.9"  (602 x 526 x 208 mm) 
 

Table 110. Size of the 2U Orion FX model and its Shipping Box 

 

Orion FX 16-port, 24-port, 32-port, and 40-port models (1U) 
 

Matrix 17.4" x 17.7" x 1.7" (442 x 449 x 44 mm ) 
Shipping Box 23.7" x 20.7" x 6.1"  (602 x 526 x 154 mm) 

 
Table 111. Size of the 1U Orion FX model and its Shipping Box 

 

Weight 
Orion FX 120-port, 128-port, 144-port, and 160-port (4U) 
 

Matrix 41.9 lb. (19.6 kg) 
 

Table 112. Shipping Weight of the 4U Orion FX  

 

Orion FX 48-port, 64-port, and 80-port models (2U) 
 

Matrix 24.3 lb. (11 kg) 
 

Table 113. Shipping Weight of the 2U Orion FX 

 

Orion FX 16-port, 24-port, 32-port, and 40-port models (1U) 
 

Matrix 17 lb. (7.7 kg) 
 

Table 114. Shipping Weight of the 1U Orion FX 
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MTBF 
The following table contains the mean time between failure (MTBF) in power-on hours (POH). The estimate is 
based on the FIT rates of the parts included. FIT rates are based on normalized environmental conditions of 
T = 140°F and activation energy (Ea.) of 0.7 eV. Calculations are based on 90% confidence limit.  
 
It is estimated that temperature inside the housing will be 59°F higher than the ambient temperature. 
Therefore, the MTBF calculation refers to an ambient temperature of 113°F. The humidity is limited to 60%. 
 

Model MTBF, POH 

Orion FX 1U models (16-, 24-, 32-, and 40-port) 71,900  

Orion FX 2U models (48-, 64-, and 80-port) 74,300 

Orion FX 4U models (120-, 128-, 144-, and 160-port) 65,400  

CATx 1G I/O modules 899,200 

CATx 3G I/O modules 474,800 

Fiber 1G and 3G modules (without SFP) 878,700 
 

Table 115. MTBF Values for the Orion FX 
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Appendix B – Part numbers 
 

Orion FX switch – CATx ports 1G 

OXS-FX016-TP Orion FX, 16 port matrix switch, redundant PSU, CATx, 1G, 1U 

OXS-FX024-TP Orion FX, 24 port matrix switch, redundant PSU, CATx, 1G, 1U 

OXS-FX032-TP Orion FX, 32 port matrix switch, redundant PSU, CATx, 1G, 1U 

OXS-FX040-TP Orion FX, 40 port matrix switch, redundant PSU, CATx, 1G, 1U 

OXS-FX048-TP Orion FX, 48 port matrix switch, redundant PSU, CATx, 1G, 2U 

OXS-FX064-TP Orion FX, 64 port matrix switch, redundant PSU, CATx, 1G, 2U 

OXS-FX080-TP Orion FX, 80 port matrix switch, redundant PSU, CATx, 1G, 2U 

OXS-FX0120-TP Orion FX, 120 port matrix switch, redundant PSU, CATx, 1G, 4U 

OXS-FX0128-TP Orion FX, 128 port matrix switch, redundant PSU, CATx, 1G, 4U 

OXS-FX0144-TP Orion FX, 144 port matrix switch, redundant PSU, CATx, 1G, 4U 

OXS-FX0160-TP Orion FX, 160 port matrix switch, redundant PSU, CATx, 1G, 4U 
 

Table 116. Part Numbers for Orion FX Units with CATx 1G Ports 

Orion FX switch – CATx ports 3G 

OXS-FX016-T3 Orion FX, 16 port matrix switch, redundant PSU, CATx, 3G, 1U 

OXS-FX024-T3 Orion FX, 24 port matrix switch, redundant PSU, CATx, 3G, 1U 

OXS-FX032-T3 Orion FX, 32 port matrix switch, redundant PSU, CATx, 3G, 1U 

OXS-FX040-T3 Orion FX, 40 port matrix switch, redundant PSU, CATx, 3G, 1U 

OXS-FX048-T3 Orion FX, 48 port matrix switch, redundant PSU, CATx, 3G, 2U 

OXS-FX064-T3 Orion FX, 64 port matrix switch, redundant PSU, CATx, 3G, 2U 

OXS-FX080-T3 Orion FX, 80 port matrix switch, redundant PSU, CATx, 3G, 2U 

OXS-FX0120-T3 Orion FX, 120 port matrix switch, redundant PSU, CATx, 3G, 4U 

OXS-FX0128-T3 Orion FX, 128 port matrix switch, redundant PSU, CATx, 3G, 4U 

OXS-FX0144-T3 Orion FX, 144 port matrix switch, redundant PSU, CATx, 3G, 4U 

OXS-FX0160-T3 Orion FX, 160 port matrix switch, redundant PSU, CATx, 3G, 4U 
 

Table 117. Part Numbers for Orion FX Units with CATx 3GPorts 

Orion FX switch – Fiber single mode ports 1G 

OXS-FX016-FS Orion FX, 16 port matrix switch, redundant PSU, Fiber SM, 1G, 1U 

OXS-FX024-FS Orion FX, 24 port matrix switch, redundant PSU, Fiber SM, 1G, 1U 

OXS-FX032-FS Orion FX, 32 port matrix switch, redundant PSU, Fiber SM, 1G, 1U 

OXS-FX040-FS Orion FX, 40 port matrix switch, redundant PSU, Fiber SM, 1G, 1U 

OXS-FX048-FS Orion FX, 48 port matrix switch, redundant PSU, Fiber SM, 1G, 2U 

OXS-FX064-FS Orion FX, 64 port matrix switch, redundant PSU, Fiber SM, 1G, 2U 

OXS-FX080-FS Orion FX, 80 port matrix switch, redundant PSU, Fiber SM, 1G, 2U 

OXS-FX0120-FS Orion FX, 120 port matrix switch, redundant PSU, Fiber SM, 1G, 4U 

OXS-FX0128-FS Orion FX, 128 port matrix switch, redundant PSU, Fiber SM, 1G, 4U 

OXS-FX0144-FS Orion FX, 144 port matrix switch, redundant PSU, Fiber SM, 1G, 4U 

OXS-FX0160-FS Orion FX, 160 port matrix switch, redundant PSU, Fiber SM, 1G, 4U 
 

Table 118. Part Numbers for Orion FX Units with Fiber Single Mode 1G Ports 
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Orion FX switch – Fiber single mode ports 3G 

OXS-FX016-F3 Orion FX, 16 port matrix switch, redundant PSU, Fiber SM, 3G, 1U 

OXS-FX024-F3 Orion FX, 24 port matrix switch, redundant PSU, Fiber SM, 3G, 1U 

OXS-FX032-F3 Orion FX, 32 port matrix switch, redundant PSU, Fiber SM, 3G, 1U 

OXS-FX040-F3 Orion FX, 40 port matrix switch, redundant PSU, Fiber SM, 3G, 1U 

OXS-FX048-F3 Orion FX, 48 port matrix switch, redundant PSU, Fiber SM, 3G, 2U 

OXS-FX064-F3 Orion FX, 64 port matrix switch, redundant PSU, Fiber SM, 3G, 2U 

OXS-FX080-F3 Orion FX, 80 port matrix switch, redundant PSU, Fiber SM, 3G, 2U 

OXS-FX0120-F3 Orion FX, 120 port matrix switch, redundant PSU, Fiber SM, 3G, 4U 

OXS-FX0128-F3 Orion FX, 128 port matrix switch, redundant PSU, Fiber SM, 3G, 4U 

OXS-FX0144-F3 Orion FX, 144 port matrix switch, redundant PSU, Fiber SM, 3G, 4U 

OXS-FX0160-F3 Orion FX, 160 port matrix switch, redundant PSU, Fiber SM, 3G, 4U 
 

Table 119. Part Numbers for Orion FX Units with Fiber Single Mode 3G Ports 

  Note: The Orion FX CATx and fiber singlemode switches (1G) are externally identical to the CATx and fiber 
singlemode switches (3G) 

 
Orion FX switch – Hybrid ports – mixed CATx and fiber 1G 

OXS-FX24TP16FS Orion FX, 40 port hybrid matrix switch, redundant PSU, 24×CATx, 16×FS, 1G, 1U 

OXS-FX24TP40FS Orion FX, 64 port hybrid matrix switch, redundant PSU, 24×CATx, 40×FS, 1G, 2U 

OXS-FX40TP24FS Orion FX, 64 port hybrid matrix switch, redundant PSU, 40×CATx, 24×FS, 1G, 2U 

OXS-FX40TP40FS Orion FX, 80 port hybrid matrix switch, redundant PSU, 40×CATx, 40×FS, 1G, 2U 

OXS-FX80TP40FS Orion FX, 120 port hybrid matrix switch, redundant PSU, 80×CATx, 40×FS, 1G, 4U 

OXS-FX80TP80FS Orion FX, 160 port hybrid matrix switch, redundant PSU, 80×CATx, 80×FS, 1G, 4U 

OXS-FX120TP40FS Orion FX, 160 port hybrid matrix switch, redundant PSU, 120×CATx, 40×FS, 1G, 4U 
 

Table 120. Part Numbers for Orion FX Units with Mixed CATx and Fiber 1G Ports 

Orion FX switch – Hybrid ports – mixed CATx and fiber 3G 

OXS-FX24T316F3 Orion FX, 40 port hybrid matrix switch, redundant PSU, 24×CATx, 16×FS, 3G, 1U 

OXS-FX24T340F3 Orion FX, 64 port hybrid matrix switch, redundant PSU, 24×CATx, 40×FS, 3G, 2U 

OXS-FX40T324F3 Orion FX, 64 port hybrid matrix switch, redundant PSU, 40×CATx, 24×FS, 3G, 2U 

OXS-FX40T340F3 Orion FX, 80 port hybrid matrix switch, redundant PSU, 40×CATx, 40×FS, 3G, 2U 

OXS-FX80T340F3 Orion FX, 120 port hybrid matrix switch, redundant PSU, 80×CATx, 40×FS, 3G, 4U 

OXS-FX80T380F3 Orion FX, 160 port hybrid matrix switch, redundant PSU, 80×CATx, 80×FS, 3G, 4U 

OXS-FX120T340F3 Orion FX, 160 port hybrid matrix switch, redundant PSU, 120×CATx, 40×FS, 3G, 4U 
 

Table 121. Part Numbers for Orion FX Units with Mixed CATx and Fiber 3G Ports 

Orion FX switch – Matrix-Grid version – 1G 

OXS-FX032G-TP Orion FX, 32 port matrix switch, redundant PSU, 32×CATx + Matrix-Grid, 1G, 1U 

OXS-FX032G-FS Orion FX, 32 port matrix switch, redundant PSU, 32×Fiber + Matrix-Grid, 1G, 1U 
 

Table 122. Part Numbers for Orion FX Units Matrix Grid Version with 1G Ports 
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Orion FX switch – Custom design version – with expansion capability in a 2U chassis, 1G and 3G 

OXS-FX040-TP-2U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx in a 2U chassis, 1G 

OXS-FX040-FS-2U Orion FX, 40 port matrix switch, redundant PSU, 40×Fiber in a 2U chassis, 1G 

OXS-FX040-T3-2U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx in a 2U chassis, 3G 

OXS-FX040-F3-2U Orion FX, 40 port matrix switch, redundant PSU, 40×Fiber in a 2U chassis, 3G 

OXS-FX24TP16FS-2U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx, 16×FS in a 2U chassis, 1G 

OXS-FX24T316F3-2U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx, 16×FS in a 2U chassis, 3G 

OXS-FX032G-TP-2U Orion FX, 32 port matrix switch, redundant PSU, 32×CATx + Matrix-Grid in a 2U chassis, 
1G 

OXS-FX032G-FS-2U Orion FX, 32 port matrix switch, redundant PSU, 32×Fiber + Matrix-Grid in a 2U chassis, 
1G 

 
Table 123. Part Numbers for Orion FX Units with Expansion Capability in a 2U Chassis 

Orion FX switch – Custom design version –  with expansion capability in a 4U chassis, 1G and 3G 

OXS-FX040-TP-4U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx in a 4U chassis, 1G 

OXS-FX040-FS-4U Orion FX, 40 port matrix switch, redundant PSU, 40×Fiber in a 4U chassis, 1G 

OXS-FX040-T3-4U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx in a 4U chassis, 3G 

OXS-FX040-F3-4U Orion FX, 40 port matrix switch, redundant PSU, 40×Fiber in a 4U chassis, 3G 

OXS-FX24TP16FS-4U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx, 16×FS in a 4U chassis, 1G 

OXS-FX24T316F3-4U Orion FX, 40 port matrix switch, redundant PSU, 40×CATx, 16×FS in a 4U chassis, 3G 

OXS-FX032G-TP-4U Orion FX, 32 port matrix switch, redundant PSU, 32×CATx + Matrix-Grid in a 4U chassis, 
1G 

OXS-FX032G-FS-4U Orion FX, 32 port matrix switch, redundant PSU, 32×Fiber + Matrix-Grid in a 4U chassis, 
1G 

 
Table 124. Part Numbers for Orion FX Units with Expansion Capability in a 4U Chassis 
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